[PATCH] gnu: Add python-json2html.

  • Done
  • quality assurance status badge
Details
2 participants
  • Arun Isaac
  • jgart
Owner
unassigned
Submitted by
jgart
Severity
normal
J
(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
20211013045306.13449-1-jgart@dismail.de
* gnu/packages/python-xyz.scm (python-json2html): New variable.
---
gnu/packages/python-xyz.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index dc0f12ed91..1cb4f37fe5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27197,6 +27197,35 @@ location. This small Python module determines the appropriate
platform-specific directories, e.g. the ``user data dir''.")
(license license:expat)))
+(define-public python-json2html
+ (package
+ (name "python-json2html")
+ (version "1.3.0")
+ (source ; There are no tests in the PyPI tarball.
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/softvar/json2html")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ncypljnl5y8lsxy6ibcqy412kx3mzxl4ajg67568hvq98kv1sb3"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "python" "test/run_tests.py")))))))
+ (home-page "https://github.com/softvar/json2html")
+ (synopsis "JSON to HTML Table Representation")
+ (description
+"Python module to convert JSON into a human readable HTML Table
+ representation.")
+ (license license:expat)))
+
(define-public python-face
(package
(name "python-face")
--
2.33.0
A
A
Arun Isaac wrote on 16 Oct 2021 13:27
(name . jgart)(address . jgart@dismail.de)(address . 51175-done@debbugs.gnu.org)
877dedryzr.fsf@systemreboot.net
Hi jgart,

Thanks for the patch! I have pushed to master with a few minor
improvements to the synopsis and description.

Thanks,
Arun
-----BEGIN PGP SIGNATURE-----

iQFPBAEBCAA5FiEEf3MDQ/Lwnzx3v3nTLiXui2GAK7MFAmFqtxgbHGFydW5pc2Fh
Y0BzeXN0ZW1yZWJvb3QubmV0AAoJEC4l7othgCuzhuIIAMgBOBxHU1o6qRSExMpJ
jKldDVGfNKFeSvXm4az2bBXvJhe8F/Pt8CSLbHGMFpZ1kh0Vyce0znRERxMSOKSF
+J4A92QH6gvHOJn0oFSJWaUlZWlcUBO8SVzwSS1zQ/oDwhk40oLP3nHh1fxBrYWQ
p4XQSGaQ9WfYfNEPixjEzx/CGW0w2sgxxwA59opKWWQ1f+j09uYZBbVpz5D0t6ei
fQR/ghRHBBbW5IZ2tV1uMKh1+X+c01TeeenRFqubXjuYAqI8xXju8S4OyfNwjT4l
y2RQebBxDw/IURLtP0XfvrFgv9bE0Z5PEKIwYOySeaIDopRJvOXgcITmbopkg6lT
o9E=
=X3Pa
-----END PGP SIGNATURE-----

Closed
?