[PATCH] gnu: Add r-pnwcolors.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ricardo Wurmus
  • zimoun
Owner
unassigned
Submitted by
zimoun
Severity
normal

Debbugs page

zimoun wrote 3 years ago
(address . guix-patches@gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20211012204650.3150854-1-zimon.toutoune@gmail.com
* gnu/packages/cran.scm (r-pnwcolors): New variable.
---
gnu/packages/cran.scm | 24 +++++++++++++++++++++++-
1 file changed, 23 insertions(+), 1 deletion(-)

Toggle diff (46 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 937f53784e..15f8df7cee 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -31,7 +31,7 @@
;;; Copyright © 2020 Antoine Côté <antoine.cote@posteo.net>
;;; Copyright © 2020 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2020 Magali Lemes <magalilemes00@gmail.com>
-;;; Copyright © 2020 Simon Tournier <zimon.toutoune@gmail.com>
+;;; Copyright © 2020, 2021 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2020 Aniket Patil <aniket112.patil@gmail.com>
;;; Copyright © 2021 Marcel Schilling <marcel.schilling@uni-luebeck.de>
;;;
@@ -905,6 +905,28 @@ functions which can speed up workflow.")
control over dimensions and appearance.")
(license license:gpl2+)))
+(define-public r-pnwcolors
+ (package
+ (name "r-pnwcolors")
+ (version "0.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "PNWColors" version))
+ (sha256
+ (base32
+ "1phplnclkficfv8s6wsyrckk4ixzbayiy5iix6dddg40485l9nyj"))))
+ (properties `((upstream-name . "PNWColors")))
+ (build-system r-build-system)
+ (home-page
+ "https://github.com/jakelawlor/PNWColors")
+ (synopsis "Colors palettes for data visualizations")
+ (description
+ "This package provides color palettes. They are checked for colorblind
+accessibility from hue, saturation, and lightness value scaling using the
+Chroma.js Color Palette Helper. See <https://gka.github.io/palettes>.")
+ (license license:cc0)))
+
(define-public r-ecp
(package
(name "r-ecp")

base-commit: 35aaf1fe10488ae9ed732fb2c383d09a70c109c0
--
2.32.0
Ricardo Wurmus wrote 3 years ago
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 51169-done@debbugs.gnu.org)
874k9cnkbn.fsf@elephly.net
zimoun <zimon.toutoune@gmail.com> writes:

Toggle quote (2 lines)
> * gnu/packages/cran.scm (r-pnwcolors): New variable.

Pushed it to the “master” branch. Thank you!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 51169@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 51169
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help