[PATCH 0/3] Add cl-yaml

  • Done
  • quality assurance status badge
Details
2 participants
  • Foo Chuan Wei
  • Guillaume Le Vaillant
Owner
unassigned
Submitted by
Foo Chuan Wei
Severity
normal
F
F
Foo Chuan Wei wrote on 12 Oct 2021 21:12
(address . guix-patches@gnu.org)
PU1PR01MB2155FE75108C27C706BBBE178DB69@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
cl-yaml depends on cl-libyaml and cl-generic-comparability.

Foo Chuan Wei (3):
gnu: Add cl-generic-comparability
gnu: Add cl-libyaml
gnu: Add cl-yaml

gnu/packages/lisp-xyz.scm | 116 ++++++++++++++++++++++++++++++++++++++
1 file changed, 116 insertions(+)


base-commit: 344d81f35d124e7540804ac75125395f6c334a27
--
2.25.1
F
F
Foo Chuan Wei wrote on 12 Oct 2021 21:16
[PATCH 1/3] gnu: Add cl-generic-comparability
(address . 51168@debbugs.gnu.org)
PU1PR01MB2155B9B081A0F6AD62D047B38DB69@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
* gnu/packages/lisp-xyz.scm (sbcl-generic-comparability,
cl-generic-comparability, ecl-generic-comparability):
New variables.
---
gnu/packages/lisp-xyz.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 5d9db448d0..8e26b40b5e 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -18841,3 +18841,37 @@ formats within this framework.")
(define-public cl-feeder
(sbcl-package->cl-source-package sbcl-feeder))
+
+(define-public sbcl-generic-comparability
+ (let ((commit "53fc2846319a6eb46b36581e203e1f1542a8acff")
+ (revision "1"))
+ (package
+ (name "sbcl-generic-comparability")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pnathan/generic-comparability")
+ (commit commit)))
+ (sha256
+ (base32
+ "01ma0cwirxarwwmdwflnh8kmysmr2smh5kyvzhb2074ljxg8yq2p"))
+ (file-name (git-file-name name version))))
+ (build-system asdf-build-system/sbcl)
+ (inputs `(("alexandria" ,sbcl-alexandria)))
+ (native-inputs `(("fiveam" ,sbcl-fiveam)))
+ (home-page "https://github.com/pnathan/generic-comparability")
+ (synopsis "Implementation of cdr-8")
+ (description
+ "GENERIC-COMPARABILITY is an implementation of CDR-8 (Generic Equality
+and Comparison for Common Lisp). CDR-8 provides an interface for the EQUALS
+function, which is defined as a general equality predicate, as well as a set of
+ordering (COMPARE) functions for comparison. The semantics are described in the
+CDR-8 standard.")
+ (license license:llgpl))))
+
+(define-public cl-generic-comparability
+ (sbcl-package->cl-source-package sbcl-generic-comparability))
+
+(define-public ecl-generic-comparability
+ (sbcl-package->ecl-package sbcl-generic-comparability))
--
2.25.1
F
F
Foo Chuan Wei wrote on 12 Oct 2021 21:18
[PATCH 2/3] gnu: Add cl-libyaml
(address . 51168@debbugs.gnu.org)
PU1PR01MB21559BD5AD7271CB2BF755C48DB69@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
* gnu/packages/lisp-xyz.scm (sbcl-libyaml, cl-libyaml, ecl-libyaml):
New variables.
---
gnu/packages/lisp-xyz.scm | 43 +++++++++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)

Toggle diff (60 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 8e26b40b5e..4395e54899 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -84,6 +84,7 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages serialization)
#:use-module (gnu packages sdl)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages tcl)
@@ -18875,3 +18876,45 @@ CDR-8 standard.")
(define-public ecl-generic-comparability
(sbcl-package->ecl-package sbcl-generic-comparability))
+
+(define-public sbcl-libyaml
+ (let ((commit "a7fe9f68bddfd00b7ca467b65b3b41b276336843")
+ (revision "1"))
+ (package
+ (name "sbcl-libyaml")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/eudoxia0/cl-libyaml")
+ (commit commit)))
+ (sha256
+ (base32
+ "06pvmackyhq03rjmihpx6w63m6cy8wx78ll5xpwwvd85bgrqq817"))
+ (file-name (git-file-name name version))))
+ (build-system asdf-build-system/sbcl)
+ (inputs `(("cffi" ,sbcl-cffi)
+ ("libyaml" ,libyaml)))
+ (arguments '(#:asd-systems '("cl-libyaml")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "src/library.lisp"
+ (("libyaml.so")
+ (string-append (assoc-ref inputs "libyaml")
+ "/lib/libyaml.so")))
+ #t)))))
+ (home-page "https://github.com/eudoxia0/cl-libyaml")
+ (synopsis "libyaml bindings for Common Lisp")
+ (description
+ "This is a home-spun binding to the libyaml library. It's not meant as
+a full library for YAML, just a bare binding with a couple of utility macros.
+For a YAML parser and emitter using this, check out cl-yaml.")
+ (license license:expat))))
+
+(define-public cl-libyaml
+ (sbcl-package->cl-source-package sbcl-libyaml))
+
+(define-public ecl-libyaml
+ (sbcl-package->ecl-package sbcl-libyaml))
--
2.25.1
F
F
Foo Chuan Wei wrote on 12 Oct 2021 21:21
[PATCH 3/3] gnu: Add cl-yaml
(address . 51168@debbugs.gnu.org)
PU1PR01MB215575AC0C87D5B2A20945928DB69@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
* gnu/packages/lisp-xyz.scm (sbcl-yaml, cl-yaml, ecl-yaml):
New variables.
---
gnu/packages/lisp-xyz.scm | 39 +++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 4395e54899..63f580aba6 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -18918,3 +18918,42 @@ For a YAML parser and emitter using this, check out cl-yaml.")
(define-public ecl-libyaml
(sbcl-package->ecl-package sbcl-libyaml))
+
+(define-public sbcl-yaml
+ (let ((commit "c3202be9a753c51f3bc79538a5a498a8865192aa")
+ (revision "1"))
+ (package
+ (name "sbcl-yaml")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/eudoxia0/cl-yaml")
+ (commit commit)))
+ (sha256
+ (base32
+ "1izjg0v6rf7dh069bbnnr67l30lsqj86wdk7y9ggbgiwh6v9j185"))
+ (file-name (git-file-name name version))))
+ (build-system asdf-build-system/sbcl)
+ (inputs `(("cl-libyaml" ,sbcl-libyaml)
+ ("alexandria" ,sbcl-alexandria)
+ ("cl-ppcre" ,sbcl-cl-ppcre)
+ ("parse-number" ,sbcl-parse-number)))
+ (native-inputs `(("fiveam" ,sbcl-fiveam)
+ ("yason" ,sbcl-yason)
+ ("generic-comparability" ,sbcl-generic-comparability)
+ ("cl-fad" ,sbcl-cl-fad)
+ ("trivial-benchmark" ,sbcl-trivial-benchmark)))
+ (arguments '(#:asd-systems '("cl-yaml")))
+ (home-page "https://github.com/eudoxia0/cl-yaml")
+ (synopsis "YAML parser for Common Lisp")
+ (description
+ "A YAML parser and emitter for Common Lisp built on top of libyaml.
+Uses the cl-libyaml library.")
+ (license license:expat))))
+
+(define-public cl-yaml
+ (sbcl-package->cl-source-package sbcl-yaml))
+
+(define-public ecl-yaml
+ (sbcl-package->ecl-package sbcl-yaml))
--
2.25.1
G
G
Guillaume Le Vaillant wrote on 13 Oct 2021 10:53
Re: [bug#51168] [PATCH 0/3] Add cl-yaml
(name . Foo Chuan Wei)(address . chuanwei.foo@hotmail.com)(address . 51168-done@debbugs.gnu.org)
87a6jduwxw.fsf@kitej
Patches pushed as 7b8ac3e9a3b7d132fe9d564ebd8db3b89766e3b0 and following
with a few modifications.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYWaeuw8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j9FSgEAiKSydF4wdjrQ2seGeLDVETTeQrj/4vX0CDNd
J1d63DAA/jY1ufRqHTMxjx39dMG1xxZa+mJQuh5Sd+5ChGa88UQv
=yf6A
-----END PGP SIGNATURE-----

Closed
?