[PATCH] gnu: Add cl-conium

  • Done
  • quality assurance status badge
Details
2 participants
  • Foo Chuan Wei
  • Guillaume Le Vaillant
Owner
unassigned
Submitted by
Foo Chuan Wei
Severity
normal
F
F
Foo Chuan Wei wrote on 12 Oct 2021 08:42
(address . guix-patches@gnu.org)
PU1PR01MB2155FAAEE374AF16B8F912C98DB69@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
* gnu/packages/lisp-xyz.scm (sbcl-conium, cl-conium, ecl-conium):
New variables.
---
gnu/packages/lisp-xyz.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 5d9db448d0..743be1d5ce 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -18841,3 +18841,32 @@ formats within this framework.")
(define-public cl-feeder
(sbcl-package->cl-source-package sbcl-feeder))
+
+(define-public sbcl-conium
+ (let ((commit "089adfd8759ec7973bb6f67b98d7a246e67aeb05")
+ (revision "1"))
+ (package
+ (name "sbcl-conium")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sharplispers/conium")
+ (commit commit)))
+ (sha256
+ (base32
+ "0y31za8xr8734p2pf8mrw1jd1fksh2d4y1p12wwjyn8hxxsvsx1w"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs `(("closer-mop" ,sbcl-closer-mop)))
+ (home-page "https://github.com/sharplispers/conium")
+ (synopsis "Portability library for debugger- and compiler-related tasks")
+ (description
+ "Conium is a portability library for debugger- and compiler-related
+tasks in Common Lisp. It is fork of SWANK-BACKEND.")
+ (license license:public-domain))))
+
+(define-public cl-conium
+ (sbcl-package->cl-source-package sbcl-conium))
+
+(define-public ecl-conium
+ (sbcl-package->ecl-package sbcl-conium))

base-commit: 0105f33a4ddd7d3ef3d66bd16e16595dd500d404
--
2.25.1
G
G
Guillaume Le Vaillant wrote on 13 Oct 2021 10:51
(name . Foo Chuan Wei)(address . chuanwei.foo@hotmail.com)(address . 51151-done@debbugs.gnu.org)
87ily1ux1x.fsf@kitej
Patch pushed as cfc2471159740d0a5560bbe598ff7b70a131ee19 with a few
modifications.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYWaeKg8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j8hQwEAiVp1pD4ZF51IWvOOZwnO+ncYMyYkZcyFxlyi
orzBD0QA/03F61aJGIjIxo3CN0x2Iu0HW2Db/66027XFbSjxaVZd
=5crh
-----END PGP SIGNATURE-----

Closed
?