[PATCH] gnu: Add cl-terminfo

  • Done
  • quality assurance status badge
Details
2 participants
  • Foo Chuan Wei
  • Guillaume Le Vaillant
Owner
unassigned
Submitted by
Foo Chuan Wei
Severity
normal
F
F
Foo Chuan Wei wrote on 12 Oct 2021 07:05
(address . guix-patches@gnu.org)
PU1PR01MB21552BA5B1FB2F326E4A18378DB69@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
* gnu/packages/lisp-xyz.scm (sbcl-terminfo, cl-terminfo, ecl-terminfo):
New variables.
---
gnu/packages/lisp-xyz.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 5d9db448d0..f4a3f65669 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -18841,3 +18841,36 @@ formats within this framework.")
(define-public cl-feeder
(sbcl-package->cl-source-package sbcl-feeder))
+
+(define-public sbcl-terminfo
+ (let ((commit "b8b2e3ed786bfcf9f1aa4a264cee2e93135080f5")
+ (revision "1"))
+ (package
+ (name "sbcl-terminfo")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/npatrick04/terminfo")
+ (commit commit)))
+ (sha256
+ (base32
+ "1nmin9rr6f75xdhxysba66xa1dh62fh27w9ad1cvmj0062armf6b"))))
+ (build-system asdf-build-system/sbcl)
+ (synopsis "A terminfo database front end in Common Lisp")
+ (home-page "https://github.com/npatrick04/terminfo")
+ (description
+ "A terminfo database front end in Common Lisp. The package provides a
+method for determining which capabilities a terminal (e.g. \"xterm\") has and
+methods to compile or put commands to a stream.
+
+Based on terminfo by Paul Foley, terminfo was later modified for use in linedit
+and the hemlock text editor. This library consolidates changes to the terminfo
+package to provide a flexible interface.")
+ (license license:expat))))
+
+(define-public cl-terminfo
+ (sbcl-package->cl-source-package sbcl-terminfo))
+
+(define-public ecl-terminfo
+ (sbcl-package->ecl-package sbcl-terminfo))

base-commit: 0105f33a4ddd7d3ef3d66bd16e16595dd500d404
--
2.25.1
G
G
Guillaume Le Vaillant wrote on 13 Oct 2021 10:49
(name . Foo Chuan Wei)(address . chuanwei.foo@hotmail.com)(address . 51147-done@debbugs.gnu.org)
87mtndux3l.fsf@kitej
Patch pushed as 880390140e272b05cfec14c684c658616a9b4a3e with a few
modifications (added copyright line and file-name field, modified
synopsis and description).
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYWad7g8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j+6iwD+MRIsWnPT5RcD3JlNBPa42zIfKpzU9b7V597s
RyZo4ywBAJNLGCyjBBq5AZJ2Oh3Ss2KzOM539z7BYFylGS9FvAd5
=Fil8
-----END PGP SIGNATURE-----

Closed
?