[PATCH] gnu: Add rust-sha3.

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • phodina
Owner
unassigned
Submitted by
phodina
Severity
normal
P
P
phodina wrote on 3 Oct 2021 18:38
(name . phodina via Guix-patches via)(address . guix-patches@gnu.org)
p9ZNpk0uedNM7nJLmcvLRiQ5iAOfXLl88_uumKIwwflyoGMg55WmJ2SSLwL4mUkf1APR3CC52lHByW_AoxQJN4v7LAPh9hPXj5SdninPyGE=@protonmail.com
* gnu/packages/crates-io.scm (rust-sha3): New variable.

Toggle diff (38 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 48a05fb8be..d6cdc8a7a2 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -44713,6 +44713,33 @@ functions core functionality.")
(("rust-gcc" ,rust-gcc-0.3)
("rust-generic-array" ,rust-generic-array-0.8))))))

+(define-public rust-sha3-0.9
+ (package
+ (name "rust-sha3")
+ (version "0.9.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "sha3" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "02d85wpvz75a0n7r2da15ikqjwzamhii11qy9gqf6pafgm0rj4gq"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-block-buffer" ,rust-block-buffer-0.9)
+ ("rust-digest" ,rust-digest-0.9)
+ ("rust-keccak" ,rust-keccak-0.1)
+ ("rust-opaque-debug" ,rust-opaque-debug-0.3))
+ #:cargo-development-inputs
+ (("rust-digest" ,rust-digest-0.9)
+ ("rust-hex-literal" ,rust-hex-literal-0.2))))
+ (home-page "https://github.com/RustCrypto/hashes")
+ (synopsis "SHA-3 (Keccak) hash function")
+ (description "This package provides a pure Rust implementation of the SHA-3
+(Keccak) hash function.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-shader-version-0.6
(package
(name "rust-shader-version")
--
2.32.0
E
E
Efraim Flashner wrote on 4 Oct 2021 10:16
(name . phodina)(address . phodina@protonmail.com)(address . 50995-done@debbugs.gnu.org)
YVq4St/7GO06W8B6@3900XT
Thanks. Patch pushed.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmFauEoACgkQQarn3Mo9
g1FGqg//XP79OXXg5J9ji0YEDPBsNUjCKtmaZqToi0m1Xz6wC1BvAjkWcz9FT4gR
5w5z3gKGx9NYDk0NDGkSE22QFVLOfWpMo8QNqtVNy0ac7Dq6xoOoRWgmmGMJ6RPk
BZOlQUHQ+m8bSTlculL60h/CPn/ckFNCZA2q6neHfObotihEI0RYpwDAyZlvhvKW
3re7bpEit41Ifyi+nwamRHwUIWzlxmkVakwtQQVQGLyVleU7ZzygxntWonTA7Xdg
46Ad2tt/w7C/+nUgTtYU8PnEjUXHA8Rn+fjvR2nMtsXvdmcr5NZmkbOW9u5y7Lu/
awqsxgJ97PQ69Od4Lv6BaiSra0cRRCJY1A5BOi3hEFlMFIakuFOSRu36vqWHFZ8a
ynz+dTqrdtaPUtV7uAEts6nGMamBzzk0fALREt/OPjGr1i1ZBwbj3sJ9abJWEWQD
Ah7o6T+Et9sG7K0pXAdKLlX9ZWeKrXCc/oGD+7kCZbNVKPsxe0VoILRSv6PmAgOI
6cyVh4JRIYWRp4/wtGC/Akp1AjaXVtNZVO4dOEJaF/HvLHLCZWoq1ithqvju4Ppy
MC1KRMP3YSb1kAgKFfS+POYo8bKGhfC39uRalG1qTOwLDV+AZKuwHHjIg6sE6f+i
riBbhpqraYv1c/4377cKwzpX9oxb04y1xsixCHmo/IjeFLPBLjs=
=QcKr
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 50995@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 50995
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch