[PATCH] import: go: Handle extra whitespace in "go-import" meta tags.

  • Done
  • quality assurance status badge
Details
2 participants
  • Sarah Morgensen
  • Ludovic Courtès
Owner
unassigned
Submitted by
Sarah Morgensen
Severity
normal
S
S
Sarah Morgensen wrote on 29 Sep 2021 04:49
(address . guix-patches@gnu.org)
a17a80cb6c49792d27f09817e484461bb190c9d3.1632883770.git.iskarian@mgsn.dev
Some packages sites use extra whitespace in the content portion of <meta
name="go-import" ...> tags, so handle that. Example:

* guix/import/go.scm (fetch-module-meta-data)[go-import->module-meta]:
Use 'string-tokenize' instead of 'string-split'.
---
guix/import/go.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (17 lines)
diff --git a/guix/import/go.scm b/guix/import/go.scm
index 9769b557ae..ca909ab35a 100644
--- a/guix/import/go.scm
+++ b/guix/import/go.scm
@@ -474,7 +474,7 @@ Optionally include a VERSION string to append to the name."
because goproxy servers don't currently provide all the information needed to
build a package."
(define (go-import->module-meta content-text)
- (match (string-split content-text #\space)
+ (match (string-tokenize content-text char-set:graphic)
((root-path vcs repo-url)
(make-module-meta root-path (string->symbol vcs)
(strip-.git-suffix/maybe repo-url)))))

base-commit: c582be4c38596a6a31a39c6799723dcd8b6eb909
--
2.33.0
L
L
Ludovic Courtès wrote on 4 Oct 2021 16:07
(name . Sarah Morgensen)(address . iskarian@mgsn.dev)(address . 50884-done@debbugs.gnu.org)
874k9wq3xi.fsf@gnu.org
Sarah Morgensen <iskarian@mgsn.dev> skribis:

Toggle quote (7 lines)
> Some packages sites use extra whitespace in the content portion of <meta
> name="go-import" ...> tags, so handle that. Example:
> <https://k8s.io/api?go-get=1>
>
> * guix/import/go.scm (fetch-module-meta-data)[go-import->module-meta]:
> Use 'string-tokenize' instead of 'string-split'.

Applied, thanks! Would it make sense to have a regression test?

Ludo’.
Closed
?