Stackage importer change breaks tests/lint, build

  • Done
  • quality assurance status badge
Details
2 participants
  • Tobias Geerinckx-Rice
  • Xinglu Chen
Owner
unassigned
Submitted by
Tobias Geerinckx-Rice
Severity
normal
Merged with
T
T
Tobias Geerinckx-Rice wrote on 28 Sep 2021 18:22
(name . Bug reports for GNU Guix)(address . bug-guix@gnu.org)(name . Xinglu Chen)(address . public@yoctocell.xyz)
87a6jw7jgu.fsf@nckx
Guix,

Guix doesn't currently build because of a ‘lint’ test failure (log
attached). Reverting commit
9c5e5ca1c0de56a0d5b2b924de10548172095b58 makes it pass.

Kind regards,

T G-R
Attachment: test-suite.log
-----BEGIN PGP SIGNATURE-----

iIMEARYKACsWIQT12iAyS4c9C3o4dnINsP+IT1VteQUCYVNCsQ0cbWVAdG9iaWFz
LmdyAAoJEA2w/4hPVW15WjcA/AxPIpvMBtjKa3VvDWOgVhKuYrCfEW6AEotlI55o
7dMFAQC6djLmsuwVqsWpcp2+E779jUgMm+pR9dVGdvC9cNtdCw==
=ooy2
-----END PGP SIGNATURE-----

T
T
Tobias Geerinckx-Rice wrote on 28 Sep 2021 18:32
Oops… Daniel just reported the same bug.
(name . GNU bug tracker automated control server)(address . control@debbugs.gnu.org)(name . Daniel Herzig)(address . daniel.herzig@univie.ac.at)
877df07j5r.fsf@nckx
retitle 50870 Stackage importer change breaks tests/lint, build
merge 50870 50871
thanks
X
X
Xinglu Chen wrote on 28 Sep 2021 20:39
Re: bug#50871: Stackage importer change breaks tests/lint, build
87o88c35p4.fsf@yoctocell.xyz
On Tue, Sep 28 2021, Tobias Geerinckx-Rice via Bug reports for GNU Guix wrote:

Toggle quote (6 lines)
> Guix,
>
> Guix doesn't currently build because of a ‘lint’ test failure (log
> attached). Reverting commit
> 9c5e5ca1c0de56a0d5b2b924de10548172095b58 makes it pass.

Thanks for catching this! The attached patch should fix this.
From 45b002a1a39adaf76ca0ab6ca2c1dd95eb26da30 Mon Sep 17 00:00:00 2001
Message-Id: <45b002a1a39adaf76ca0ab6ca2c1dd95eb26da30.1632854267.git.public@yoctocell.xyz>
From: Xinglu Chen <public@yoctocell.xyz>
Date: Tue, 28 Sep 2021 20:34:25 +0200
Subject: [PATCH] =?UTF-8?q?test:=20lint:=20Fix=20=E2=80=98haskell-stackage?=
=?UTF-8?q?=E2=80=99=20test.?=
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

This is a follow-up to commit 9c5e5ca1c0de56a0d5b2b924de10548172095b58.

The previous package was called “ghc-x” which is not available on Stackage,
instead change it to “ghc-pandoc” which does exist, and adjust its version.

* tests/lint.scm ("haskell-stackage"): Add additional metadata for the
package; change package name to “ghc-pandoc”; and change to version to
“100.0”.

Reported-by: Tobias Geerinckx-Rice <me@tobias.gr>
---
tests/lint.scm | 17 +++++++++--------
1 file changed, 9 insertions(+), 8 deletions(-)

Toggle diff (47 lines)
diff --git a/tests/lint.scm b/tests/lint.scm
index 0f51b9ef79..e96265a55a 100644
--- a/tests/lint.scm
+++ b/tests/lint.scm
@@ -1317,29 +1317,30 @@ (define (package-with-phase-changes changes)
(test-assert "haskell-stackage"
(let* ((stackage (string-append "{ \"packages\": [{"
- " \"name\":\"x\","
+ " \"name\":\"pandoc\","
+ " \"synopsis\":\"synopsis\","
" \"version\":\"1.0\" }]}"))
(packages (map (lambda (version)
(dummy-package
- (string-append "ghc-x")
+ "ghc-pandoc"
(version version)
(source
(dummy-origin
(method url-fetch)
(uri (string-append
"https://hackage.haskell.org/package/"
- "x-" version "/x-" version ".tar.gz"))))))
- '("0.9" "1.0" "2.0")))
+ "pandoc-" version "/pandoc-" version ".tar.gz"))))))
+ '("0.9" "1.0" "100.0")))
(warnings (pk (with-http-server `((200 ,stackage) ; memoized
- (200 "name: x\nversion: 1.0\n")
- (200 "name: x\nversion: 1.0\n")
- (200 "name: x\nversion: 1.0\n"))
+ (200 "name: pandoc\nversion: 1.0\n")
+ (200 "name: pandoc\nversion: 1.0\n")
+ (200 "name: pandoc\nversion: 1.0\n"))
(parameterize ((%hackage-url (%local-url))
(%stackage-url (%local-url)))
(append-map check-haskell-stackage packages))))))
(match warnings
(((? lint-warning? warning))
- (and (string=? (package-version (lint-warning-package warning)) "2.0")
+ (and (string=? (package-version (lint-warning-package warning)) "100.0")
(string-contains (lint-warning-message warning)
"ahead of Stackage LTS version"))))))

base-commit: 5edfa6d15e5bb92609ecff7e37e3985eced1dd4d
--
2.33.0
-----BEGIN PGP SIGNATURE-----

iQJJBAEBCAAzFiEEAVhh4yyK5+SEykIzrPUJmaL7XHkFAmFTYWcVHHB1YmxpY0B5
b2N0b2NlbGwueHl6AAoJEKz1CZmi+1x57hAP/2uNfnGV431vI5dWB37sgGz6fOSk
hHgmf8HspRf8JvI/L5i9oX9r7FU41sbdMsKGYKU+FpPfKPkO9kPFIrce7G1Sw/lS
jBx0ZJPMY+4mMqCEh/7E5iQCW4+JZXPTgHIwBty5xCXGHYcqu0jeZHqr1nSZaApD
sFBvJq4WWpyQP+OlafiQqxHTSikZn90zN0k9GV7fFZ6cjDHLdodppCUMq+1vMdvx
pwL8FCjCVzSlzyHEV9npmk+GLf1ImQh/aLXyDPNu/4y2SuCRuT0LXaxGEcgNdRAU
CLXGQt1HBhmLgn9eD3MOFkMWgE0CK+dPE0vvXvkSxltIuCIpvbF+RsaimhsVwncq
wTUx5N2k55Z+cmtgYN8GmqRp+1UE0bKgAxVrujHP9ZQ4Aq9TQKFkqeWRN9CUpOiz
oiY8QDD1SMP/i8GiEGCbZZuKnUePFWnwQBKh3PGVHS+zGBxMo/0lqTpvQNEUAlD8
wQdVKMftevfL/hg4pqQQah2q1SX5ba0nxxbH/a7HPJ4oMCY3w2C7KwTlf2sAS2tT
Db/J6uG2gOtYkmJ/l5aoLkl5sH/7/qfRh0LjPNNuZyHi8JCIDV7hGiZhyYf1cZ6q
gUhBrw3rVT1pVp/J546yXc4ns1nZemvvDRSFvzrLx6lJnRFXhVrhB+0Fdt+60MTc
DOCz+5CckF+E1Wlr
=0qD9
-----END PGP SIGNATURE-----

T
T
Tobias Geerinckx-Rice wrote on 28 Sep 2021 22:29
(name . Xinglu Chen)(address . public@yoctocell.xyz)(address . 50871-done@debbugs.gnu.org)
871r58783t.fsf@nckx
Xinglu,

Xinglu Chen ???
Toggle quote (5 lines)
> On Tue, Sep 28 2021, Tobias Geerinckx-Rice via Bug reports for
> GNU Guix wrote:
>
>> Guix,

Oops, sorry for forgetting to address you…

Toggle quote (7 lines)
>> Guix doesn't currently build because of a ‘lint’ test failure
>> (log
>> attached). Reverting commit
>> 9c5e5ca1c0de56a0d5b2b924de10548172095b58 makes it pass.
>
> Thanks for catching this! The attached patch should fix this.

It did! Thanks for the prompt fix, which I've now pushed as
50d24214191abefc6b8f6c881f9a91c1f818a650.

…aand closing,

T G-R
-----BEGIN PGP SIGNATURE-----

iIMEARYKACsWIQT12iAyS4c9C3o4dnINsP+IT1VteQUCYVN8Ng0cbWVAdG9iaWFz
LmdyAAoJEA2w/4hPVW15pyoA/ivALK4rq+nlGMFQ/2rixmNMkC3nAsp+0945NrG1
SWnlAP4wj611Ec8FCRkRND/+xLY1ytHYKHkFOFwTAjntBcC2DA==
=U0Os
-----END PGP SIGNATURE-----

Closed
?