[PATCH] Update vim to v8.2.3455

  • Done
  • quality assurance status badge
Details
3 participants
  • Efraim Flashner
  • Tobias Geerinckx-Rice
  • Steve George
Owner
unassigned
Submitted by
Steve George
Severity
normal
S
S
Steve George wrote on 27 Sep 2021 10:32
(address . guix-patches@gnu.org)(name . Steve George)(address . steve@futurile.net)
20210927083219.2256220-1-steve@futurile.net
---
gnu/packages/vim.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 98e96b331f..4e06b988fb 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -73,7 +73,7 @@
(define-public vim
(package
(name "vim")
- (version "8.2.2689")
+ (version "8.2.3455")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -82,7 +82,7 @@
(file-name (git-file-name name version))
(sha256
(base32
- "0l0hkr8cw7fdsfc5zzcxx3q1wmv9k3hrgalvffq0l69lviqdgh0p"))))
+ "128j5zrvx45vr8qsf083idyhzx4c9rir5c5bfay1r0n80wf0f4nw"))))
(build-system gnu-build-system)
(arguments
`(#:test-target "test"
--
2.17.1
E
E
Efraim Flashner wrote on 30 Sep 2021 11:19
(name . Steve George)(address . steve@futurile.net)(address . 50844@debbugs.gnu.org)
YVWBCOANcZS5vGNT@3900XT
On Mon, Sep 27, 2021 at 09:32:19AM +0100, Steve George wrote:
Toggle quote (30 lines)
> ---
> gnu/packages/vim.scm | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
> index 98e96b331f..4e06b988fb 100644
> --- a/gnu/packages/vim.scm
> +++ b/gnu/packages/vim.scm
> @@ -73,7 +73,7 @@
> (define-public vim
> (package
> (name "vim")
> - (version "8.2.2689")
> + (version "8.2.3455")
> (source (origin
> (method git-fetch)
> (uri (git-reference
> @@ -82,7 +82,7 @@
> (file-name (git-file-name name version))
> (sha256
> (base32
> - "0l0hkr8cw7fdsfc5zzcxx3q1wmv9k3hrgalvffq0l69lviqdgh0p"))))
> + "128j5zrvx45vr8qsf083idyhzx4c9rir5c5bfay1r0n80wf0f4nw"))))
> (build-system gnu-build-system)
> (arguments
> `(#:test-target "test"
> --
> 2.17.1
>

I'm definitely looking forward to an update to vim, but I got a test
failure while building it for x86_64, and then the same test when I
built vim-full. Did you see this test failure?

-------------------------------
Executed: 4369 Tests
Skipped: 119 Tests
FAILED: 1 Tests


Failures:
From test_shell.vim:
Found errors in Test_shellxquote():
Caught exception in Test_shellxquote(): Vim(call):E484: Can't open file Xlog @ command line..script /tmp/guix-build-vim-8.2.3455.drv-0/source/src/testdir/runtest.vim[486]..function RunTheTest[44]..Test_shellxquote, line 13

TEST FAILURE
make[2]: *** [Makefile:49: report] Error 1
make[2]: Leaving directory '/tmp/guix-build-vim-8.2.3455.drv-0/source/src/testdir'
make[1]: *** [Makefile:2271: scripttests] Error 2
make[1]: Leaving directory '/tmp/guix-build-vim-8.2.3455.drv-0/source/src'
make: *** [Makefile:39: test] Error 2

Test suite failed, dumping logs.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmFVgQQACgkQQarn3Mo9
g1ELJA//fplYdz+SkdLGNYnATRC1dsVDklATfA8C946jT2C6ibXfIO4lLUEUaNJb
Nc4gpzO7XRbqRAwrrU3bL5FPSz0nkY1v06qzb+PlLtE3OENRckaNxaHs1AvL2kao
O+1WMKRZxcYVuUe2N1Oqm5XiORxISpHQryDPprPv1jRhywB9SRwJ+2rx/bN1hfz9
Bu1BTcNYxp0MiepMGxtrlg/rO8Fk68wgStBoCRP7kp8gLX0mKb1fwj2+1X9Hivf+
BUPj3sENKPt7utABFrhBWITfSU4Z820qEi2JnIX7oWYJx8Ggi8BDNeqQN32aooVe
U6Sla0Onjz6GYcIkIPIUpt0eOdVjasIM/HExhaF2KWzgX7ytmXuh5gPEfqSUXViA
OcrRFiilqNYrlERYAXabOgcf2imJ4MSXSFDW9vtSpEPLmrVLfBSg4eU94U30L/nY
8+YnpneVwrSrXS2EGb+A0r7C1AKEFNumUlgikGdNK08eGAOWM4dsN3Tysc9iQ0Xt
/7Jo5En41xNt8XTAYRQes7xrzHrU6R7KazzNK1lVPEwODAFXXcnJhCrw2ym6ys2s
RNTP9JU37/NZZvOdJ2GUjPumDLIPnpyRJV4SJXXmPWFxAbMB+fvZQB7t5z6vV6vQ
hFH3wK+QqBphJzME/CwlysutUb7yZRDtrYr8U5MiEBehQmTcQX4=
=Pwoh
-----END PGP SIGNATURE-----


T
T
Tobias Geerinckx-Rice wrote on 3 Oct 2021 17:56
(name . Efraim Flashner)(address . efraim@flashner.co.il)
87h7dydrsf.fsf@nckx
Steve,

I've also tried to build this new vim about 10 times now, never
successfully. In my experience spurious test failures aren't
unusual for vim, but it's not usually this hard to get them to
pass.

Did you manage to build and use this new version from the first
try?

Kind regards,

T G-R
-----BEGIN PGP SIGNATURE-----

iIMEARYKACsWIQT12iAyS4c9C3o4dnINsP+IT1VteQUCYVnTEA0cbWVAdG9iaWFz
LmdyAAoJEA2w/4hPVW15ymcBAMUZOpAIf0lv14naNw+iz/+ssmVuYPeml9VmlO8z
Y286AQCc8WY99Pn7/sZQtd2OFD1/TW+3YjEHD9VQdkfvkJwaCw==
=cWeF
-----END PGP SIGNATURE-----

S
S
Steve George wrote on 5 Oct 2021 13:25
54cd6313-0c58-6f91-d521-27cad80d9fff@futurile.net
Hi Tobias/Efraim,

Apologies for the delay, this is my first attempt at a contribution and
I've been learning/struggling with my set-ups repeatability.

The Test_shellxquote (from test_shell.vim) test fails for me
consistently after patch 3061.

I can get the current version in Guix to build fine:

guix environment guix --pure
./pre-inst-env guix environment vim

./pre-inst-env guix build vim --no-substitutes --verbosity=3
--keep-failed 2>&1 | tee ../8.2.2689-vim-build.log

In 3061
the shell tests were changed. This build fails for me:

./pre-inst-env guix build vim --no-substitutes --verbosity=3
--with-git-url=vim=https://github.com/vim/vim
--with-commit=vim=v8.2.3061 --keep-failed 2>&1 | tee
../8.2.3061-git-vim-build.log

Failures:
From test_shell.vim:
Found errors in Test_shellxquote():
Caught exception in Test_shellxquote(): Vim(call):E484: Can't
open file Xlog @ command line..script
/tmp/guix-build-vim-8.2.3477.drv-0/source/src/testdir/runtest.vim[486]..function
RunTheTest[44]..Test_shellxquote, line 13

In the tests log it says:

Cannot execute shell ./Xtestshell

The issue appears to be that if the Xtestshell file is there already
then it fails.

I can build it fine manually:

guix environment guix --pure
./pre-inst-env guix environment vim --ad-hoc less
cd <source location>
source ./environment-variables
cd src/testdir
mv Xtestshell Xtestshell.bak
make

That's as far as I've got at this point.

Are either of you able to confirm that you can:

a. Build versions before 3061 (ie 3060)

b. That with 3061 if you move Xtestshell it builds

c. Suggest any paths from here?


Thanks,

Steve


On 10/3/21 3:56 PM, Tobias Geerinckx-Rice wrote:
Toggle quote (11 lines)
> Steve,
>
> I've also tried to build this new vim about 10 times now, never
> successfully.  In my experience spurious test failures aren't unusual
> for vim, but it's not usually this hard to get them to pass.
>
> Did you manage to build and use this new version from the first try?
>
> Kind regards,
>
> T G-R
E
E
Efraim Flashner wrote on 5 Oct 2021 14:33
(name . Steve George)(address . steve@futurile.net)
YVxGATFHihj/Y8bl@3900XT
On Tue, Oct 05, 2021 at 12:25:34PM +0100, Steve George wrote:
Toggle quote (64 lines)
> Hi Tobias/Efraim,
>
> Apologies for the delay, this is my first attempt at a contribution and I've
> been learning/struggling with my set-ups repeatability.
>
> The Test_shellxquote (from test_shell.vim) test fails for me consistently
> after patch 3061.
>
> I can get the current version in Guix to build fine:
>
> guix environment guix --pure
> ./pre-inst-env guix environment vim
>
> ./pre-inst-env guix build vim --no-substitutes --verbosity=3 --keep-failed
> 2>&1 | tee ../8.2.2689-vim-build.log
>
> In 3061
> (https://github.com/vim/vim/commit/054794c20f6322bbd9482c4124041dc0a140c78e)
> the shell tests were changed. This build fails for me:
>
> ./pre-inst-env guix build vim --no-substitutes --verbosity=3
> --with-git-url=vim=https://github.com/vim/vim --with-commit=vim=v8.2.3061
> --keep-failed 2>&1 | tee ../8.2.3061-git-vim-build.log
>
> Failures:
> From test_shell.vim:
> Found errors in Test_shellxquote():
> Caught exception in Test_shellxquote(): Vim(call):E484: Can't open
> file Xlog @ command line..script /tmp/guix-build-vim-8.2.3477.drv-0/source/src/testdir/runtest.vim[486]..function
> RunTheTest[44]..Test_shellxquote, line 13
>
> In the tests log it says:
>
> Cannot execute shell ./Xtestshell
>
> The issue appears to be that if the Xtestshell file is there already then it
> fails.
>
> I can build it fine manually:
>
> guix environment guix --pure
> ./pre-inst-env guix environment vim --ad-hoc less
> cd <source location>
> source ./environment-variables
> cd src/testdir
> mv Xtestshell Xtestshell.bak
> make
>
> That's as far as I've got at this point.
>
> Are either of you able to confirm that you can:
>
> a. Build versions before 3061 (ie 3060)
>
> b. That with 3061 if you move Xtestshell it builds
>
> c. Suggest any paths from here?
>
>
> Thanks,
>
> Steve
>

./pre-inst-env guix build --no-grafts --no-substitutes vim --with-commit=vim=v8.2.3060
worked for me on the machines I was able to test it on.

(ins)efraim@3900XT ~$ cat /tmp/guix-build-vim-8.2.3061.drv-0/source/src/testdir/Xtestshell
#!/bin/sh
echo "Cmd: [$*]" > Xlog

After adding 'testdir/test_shell.vim' to the '/bin/sh' substitution in the
'patch-absolute-paths phase I was able to build 8.2.3061.

I'd go ahead and make that change in the substitution and if that fixes
the version you sent then either resend that patch with the change or
try bumping vim to a later version.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmFcRf4ACgkQQarn3Mo9
g1G4lw//QtGmobVyFigRpJmoFrtgD+S8gvb/L+9ockVbC1n/zUFEXq1ULPX+oIJn
kxiQyiIho0AXaqfyvC7xE8BgfaqcAv9omxclHJ40gahNykhdE3qsHwpjh0pBfru8
zf/1hAPlgipKxxU1nNJpBfTCPPbHvAfNei7eS3mTQ1qXKfl4H1knXRPoUUBffaeb
oDzcvToGBdVBMQI71m1/bm/QZTlGmbWqromq50uWw99XWZoqB/nV9AmaNlZYHkZ7
D/JoxC/tYDDa7syLm93pVm8z6+RsNCq/PvTE0yk08dzuBjotW6qzTKbNEZNxbSJe
irQMA/foR1cad3UxFlvqdUHOerHGaVodyR38FweAY/FdWNA3YVhi+Xllvf7Cmsh2
Hz5p0S92EMx2zsbCIcO/rrV1wRh4mGDXjuufF/tCNbMh8uTrwmnvjsreJqyfo5Is
8mYbHlzY1fkFMJwJYI3q5Et+aG3PsCmlzNJYnM9pODSj/KbtfrtvXKQGLS/+ZPeQ
V5uhfPntDGvARotf2jBicJ1WwA/zheJ8xbkF7KsRZJO63JJrAdezNwXUMUb9kW8b
5fYR8e+i81MlmatXRMNMJgKk8LLSqcL781OhI+AajdfKikrXN6vYD5CvH6frAK79
Gm7cA/q8H9n+9DNc7Q3ZLMlrRoZBc06SemU6IXe1kgv3Fv3Twm4=
=02s3
-----END PGP SIGNATURE-----


S
S
Steve George wrote on 9 Oct 2021 13:57
[PATCH] Update vim to v8.2.3487
(address . 50844@debbugs.gnu.org)(name . Steve George)(address . steve@futurile.net)
20211009115726.2387295-1-steve@futurile.net
Updated patch adding testdir/test_shell.vim to path substitutions as
Efraim said. Note this builds v8.2.3487 (original patch was v8.2.3455)

---
gnu/packages/vim.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index ee836d2789..c55908de08 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -73,7 +73,7 @@
(define-public vim
(package
(name "vim")
- (version "8.2.2689")
+ (version "8.2.3487")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -82,7 +82,7 @@
(file-name (git-file-name name version))
(sha256
(base32
- "0l0hkr8cw7fdsfc5zzcxx3q1wmv9k3hrgalvffq0l69lviqdgh0p"))))
+ "1s09jvr1vv9zjk352vbfidfy5fidbf83kz2vk0kk6zv24j1yck24"))))
(build-system gnu-build-system)
(arguments
`(#:test-target "test"
@@ -98,6 +98,7 @@
(substitute* '("src/testdir/Makefile"
"src/testdir/test_normal.vim"
"src/testdir/test_popupwin.vim"
+ "src/testdir/test_shell.vim"
"src/testdir/test_system.vim"
"src/testdir/test_terminal.vim"
"src/testdir/test_terminal2.vim")
--
2.17.1
E
E
Efraim Flashner wrote on 10 Oct 2021 08:10
(name . Steve George)(address . steve@futurile.net)(address . 50844-done@debbugs.gnu.org)
YWKD6yGBuDt2knl8@3900XT
I adjusted the commit message and pushed the patch. Thanks!

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmFig+sACgkQQarn3Mo9
g1HymxAAgM/gV1h+uKid8aokWCp3J5z2YOM4PA+OZi4pXCFbHOcRnI+yobg446dv
mueKGpCqOchnS0zpuS6aQqVK7L4xC0fmpIEu43Q2ZeSCOfnEfCUMAovAotgYoFsy
n7b/eQpt72M9zO+AY1+u1V1QYwb6CfsnhT7ydUjMbtjaq9RRenbWW+Aehes3J4jQ
oO/rDmPUJyTfPuffLNaqhC8P+BSlJFK6HvIrpwsAA7m4Xexn+YSVsrGP1KrQyqTU
UL8No9uW5lSfODHpfIt2TqtIgdPhliLoOYBunR6ImD9yBnqPOQ4tSs/KoXIM5Zyp
U5vWd9MAgQCN9qbyCPmG6e9zuQ3GXl4rWtCmAGFyn6JEAOJxHhbFf9Vr8FpFzZKQ
+f2GwgpdLSg1XY7qu++f4E8nBCaeOYuKHLcwjLVWPc8S0Vji297/uER5vurxQMWn
UIEojuIoKGplkU+OEv7LBvGwZS7/ZJQVDoQCC1L5DLR5GTQQukFstHkPiaIO4R1K
TmaCb2k7Y8EO4+3vwwMQLmqnlOTXyesGtvcADvivCEUst4KkWsZcEAaJsKJAjl0m
mgNzFdgaMvfvw3/2czm0bqmLMEULu7GjZE2rT5YiYOutR4Zw/dz/PgnCOCy8rM6c
9PL6hc3AC1ppAlBopuHVupZBV9PxrDQ+EBWqUibt/wtYOqSTALY=
=cOij
-----END PGP SIGNATURE-----


Closed
?