[PATCH] gnu: Add falltergeist.

  • Done
  • quality assurance status badge
Details
3 participants
  • Nicolas Goaziou
  • phodina
  • Xinglu Chen
Owner
unassigned
Submitted by
phodina
Severity
normal
P
P
phodina wrote on 18 Sep 2021 12:05
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
dv9Hjga0NEuzqzAGksrTJMOWCsIuWOZvR1tHMJUzgRnqx1UaomwwQ_6IR533Qs09GUSSr1hahalJFjBXIcUr7Y67nKHTin5qcTyt7MmGVpI=@protonmail.com
* gnu/packages/games.scm (falltergeist): New variable.

Toggle diff (39 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index c39770c260..ca0e46749c 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1133,6 +1133,34 @@ regular @command{cat}, but it also adds terminal escape codes between
characters and lines resulting in a rainbow effect.")
(license license:wtfpl2))))

+(define-public falltergeist
+ (package
+ (name "falltergeist")
+ (version "0.3.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/falltergeist/falltergeist")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "05cg58i2g32wbmrvmdsicic8xs83gld3qr1p7r4lnlckcl1l7dy4"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f))
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (inputs `(("sdl" ,(sdl-union (list sdl2
+ sdl2-image
+ sdl2-mixer)))
+ ("glew" ,glew)
+ ("glm" ,glm)))
+ (synopsis "Opensource crossplatform Fallout 2 game engine")
+ (description "Opensource crossplatform Fallout 2 game engine. Game data
+should be placed in ~/.local/share/falltergeist.")
+ (home-page "https://falltergeist.org/")
+ (license license:gpl3)))
+
(define-public foobillard++
;; Even though this latest revision is old already, stable release is
;; lagging way behind it, and has issues with textures rendering.
--
2.32.0
X
X
Xinglu Chen wrote on 20 Sep 2021 14:36
87tuiffmpa.fsf@yoctocell.xyz
On Sat, Sep 18 2021, phodina via Guix-patches via wrote:

Toggle quote (27 lines)
> * gnu/packages/games.scm (falltergeist): New variable.
>
> diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
> index c39770c260..ca0e46749c 100644
> --- a/gnu/packages/games.scm
> +++ b/gnu/packages/games.scm
> @@ -1133,6 +1133,34 @@ regular @command{cat}, but it also adds terminal escape codes between
> characters and lines resulting in a rainbow effect.")
> (license license:wtfpl2))))
>
> +(define-public falltergeist
> + (package
> + (name "falltergeist")
> + (version "0.3.1")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/falltergeist/falltergeist")
> + (commit version)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "05cg58i2g32wbmrvmdsicic8xs83gld3qr1p7r4lnlckcl1l7dy4"))))
> + (build-system cmake-build-system)
> + (arguments
> + `(#:tests? #f))

What’s the reason for disabling tests?

Toggle quote (10 lines)
> + (native-inputs `(("pkg-config" ,pkg-config)))
> + (inputs `(("sdl" ,(sdl-union (list sdl2
> + sdl2-image
> + sdl2-mixer)))
> + ("glew" ,glew)
> + ("glm" ,glm)))
> + (synopsis "Opensource crossplatform Fallout 2 game engine")
> + (description "Opensource crossplatform Fallout 2 game engine. Game data
> +should be placed in ~/.local/share/falltergeist.")

The description should consist of one or more full sentences (the first
sentence is lacking a subject). The path should use Texinfo syntax:

@file{~/.local/share/filltergeist}


Toggle quote (3 lines)
> + (license license:gpl3)))

‘license.txt’ says gpl3+.

Could you send an updated patch?
-----BEGIN PGP SIGNATURE-----

iQJJBAEBCAAzFiEEAVhh4yyK5+SEykIzrPUJmaL7XHkFAmFIgFEVHHB1YmxpY0B5
b2N0b2NlbGwueHl6AAoJEKz1CZmi+1x5hBAQAJI/7WpAylIVvARj7iukBvyAlwGg
yJrkse0uv5qdxDx5eOz78sk+D5qBndoFgCBJSa5KieyMQVCYAvjN3dvAobYDhsoc
zruqIP6zt/QLvToz+VZLWUEvN9bmFuwiOXu2a01MBXCwneS0Urg2/fKd/ffDVa0w
KeAR1P/yGcY9Jr6XCIicxut/JAzweG28fnKvDui9lGrDDBLFUwsDAZMNjrBqsFCp
4hQbGq6hBdFMMSC1LDlOFoMsOpde3lYk2BMb6gmb5ts55SpH61rjoKUSW8VgRwKk
PkM2p747OXdRmfIN6nknXmJoO8gtM8zTfBGVB8HUowdNmWsrbhDafnICJDzVNQ1C
I+LfPeiDM2R9yeNh5edGFNM2MkAKbq8FeNsvfam+CNaifs1gNenoloZjT0/s8niB
yX/uHFZpkl1LVmxN96sCM97diFQ54y0A6is2IBtGcY5IVQMm5XKX6LrZ5UdftB9R
43LGg9j4tfzc/QLizsCl5BwAl5X9ETQAtn/xqt0xVGYj94sV6Kc3r7ZR5UkbCaV+
G5aF2py4YhLwRdzMZtwONB08+keyknmCFoHfcOY6MlJat0jcDPXwDt9g0cdA5ECs
Xw2ax6w8mjTJNIdMDEMIs6iQeSDQWpBKQoDSAt2rbM46cnaN+swN/9S4f9rPkPw6
p+iscdm2BWz+YEyH
=BzB4
-----END PGP SIGNATURE-----

P
P
phodina wrote on 28 Sep 2021 00:24
[PATCH v2] gnu: Add falltergeist.
(name . Xinglu Chen)(address . public@yoctocell.xyz)(address . 50655@debbugs.gnu.org)
TqjWn9k20_BTf4KqbvryLUHK-3PfH2kqKhC6K9NP0l9D-Elb2FbhsZP6zgv55ekp4h4jBJ9DrphIzwmxV4LfThCuWlCBiNfnfnYVL1FQ69g=@protonmail.com
Hi Xinglu,

here's the updated patch.

I'm not entirely sure about the license though I'm not a lawyer. I checked the file license.txt and it still seems to me as GPL3, don't know how to spot the "or later" -> GPL3+.

Toggle snippet (45 lines)
* gnu/packages/games.scm (falltergeist): New variable.

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index c39770c260..7d08fafc13 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1133,6 +1133,34 @@ regular @command{cat}, but it also adds terminal escape codes between
characters and lines resulting in a rainbow effect.")
(license license:wtfpl2))))

+(define-public falltergeist
+ (package
+ (name "falltergeist")
+ (version "0.3.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/falltergeist/falltergeist")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "05cg58i2g32wbmrvmdsicic8xs83gld3qr1p7r4lnlckcl1l7dy4"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f)) ; no tests provided
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (inputs `(("sdl" ,(sdl-union (list sdl2
+ sdl2-image
+ sdl2-mixer)))
+ ("glew" ,glew)
+ ("glm" ,glm)))
+ (synopsis "Opensource Fallout 2 game engine")
+ (description "This package provides opensource Fallout 2 game engine.
+Game data should be placed in @file{~/.local/share/falltergeist.}")
+ (home-page "https://falltergeist.org/")
+ (license license:gpl3+)))
+
(define-public foobillard++
;; Even though this latest revision is old already, stable release is
;; lagging way behind it, and has issues with textures rendering.
--
2.32.0
X
X
Xinglu Chen wrote on 28 Sep 2021 21:14
(name . phodina)(address . phodina@protonmail.com)(address . 50655@debbugs.gnu.org)
87ee98343p.fsf@yoctocell.xyz
On Mon, Sep 27 2021, phodina wrote:

Toggle quote (8 lines)
> Hi Xinglu,
>
> here's the updated patch.
>
> I'm not entirely sure about the license though I'm not a lawyer. I
> checked the file license.txt and it still seems to me as GPL3, don't
> know how to spot the "or later" -> GPL3+.

On line 637, it says

This program is free software: you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation, either version 3 of the License, or
(at your option) any later version.

Toggle quote (40 lines)
> --8<---------------cut here---------------start------------->8---
>
> * gnu/packages/games.scm (falltergeist): New variable.
>
> diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
> index c39770c260..7d08fafc13 100644
> --- a/gnu/packages/games.scm
> +++ b/gnu/packages/games.scm
> @@ -1133,6 +1133,34 @@ regular @command{cat}, but it also adds terminal escape codes between
> characters and lines resulting in a rainbow effect.")
> (license license:wtfpl2))))
>
> +(define-public falltergeist
> + (package
> + (name "falltergeist")
> + (version "0.3.1")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/falltergeist/falltergeist")
> + (commit version)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "05cg58i2g32wbmrvmdsicic8xs83gld3qr1p7r4lnlckcl1l7dy4"))))
> + (build-system cmake-build-system)
> + (arguments
> + `(#:tests? #f)) ; no tests provided
> + (native-inputs `(("pkg-config" ,pkg-config)))
> + (inputs `(("sdl" ,(sdl-union (list sdl2
> + sdl2-image
> + sdl2-mixer)))
> + ("glew" ,glew)
> + ("glm" ,glm)))
> + (synopsis "Opensource Fallout 2 game engine")
> + (description "This package provides opensource Fallout 2 game engine.
> +Game data should be placed in @file{~/.local/share/falltergeist.}")
> + (home-page "https://falltergeist.org/")
> + (license license:gpl3+)))

LGTM!
-----BEGIN PGP SIGNATURE-----

iQJJBAEBCAAzFiEEAVhh4yyK5+SEykIzrPUJmaL7XHkFAmFTaXoVHHB1YmxpY0B5
b2N0b2NlbGwueHl6AAoJEKz1CZmi+1x59P0P/RURa84KsI2iKh/3SM6GtTzXChCu
hnxSH+SlF5yz2f8hnVn2KiQrYj/bFFhHKfmkQzWLlOVaEs1UINTJz9OLl36EjrAi
g54vX1ew1dTlMNZlR9Sz7vHLGEYEE55SNwdXnGfJgQaajDplXJxcH3lFHtJBQbvQ
0D7EtagInzbZtwyJDuuvvssP3nPix8+bjHEj2OLlx1xhxysryhUiRGaeyDglIjWo
jciA4A4LUligbZK6sVAJ4CHGGujIR6/a7FpGIqAdxjILdfouoGcJ46UPSC5yZz0W
CxSC9NobDQpIijDk0tVAE+RHOSOgdgIaZVpWN+OOSOvyeID/3LQsvvADLPgcIsO0
N4QZxdUGPAn7AYXU6I4DT2b+N8wMwicUMx5Xu8UZOO/ekWSgZ/0olOpgRLSefbck
jXmnzHu1WAHlzPpepTTHaAY9wr0FUeisYMjSu0RBGvVKqvP4PngsfBlp1cKIoitA
GrtB6P0XWpQ7Zncy1+/jRKL+ZFVgX6TD71/q7XAlZCiuycMqi8DupOudK/0FmrQ1
tTjAlXBL0jpiS8t5VSJnTF5DfoPjbtyhbuzSq732txyh7G+MEXL0Q+W0T/X6WnQk
eYIcFENZRLK85rodNB4bD4Q37ynGYJ+/boMUK4P+6XeVGimWq02/l+DzLHVaise3
Vtw3h0AIVaMCszw0
=LFp1
-----END PGP SIGNATURE-----

N
N
Nicolas Goaziou wrote on 28 Sep 2021 21:40
Re: [bug#50655] [PATCH v2] gnu: Add falltergeist.
(name . Xinglu Chen)(address . public@yoctocell.xyz)
875yukzdx3.fsf@nicolasgoaziou.fr
Hello,

Xinglu Chen <public@yoctocell.xyz> writes:

Toggle quote (4 lines)
> On Mon, Sep 27 2021, phodina wrote:
>
>> here's the updated patch.

Thank you. I removed "opensource" since everything is free in Guix, and pushed.

Toggle quote (3 lines)
>
> LGTM!

Thanks for the review.

Regards,
--
Nicolas Goaziou
Closed
?