(address . guix-patches@gnu.org)
From: Guix Together <jgart@dismail.de>
* gnu/packages/games.scm (go-github-com-anaseto-gruid): New variable.
Co-authored-by: Arun Isaac <arunisaac@systemreboot.net>
Co-authored-by: Brice Waegeneire <brice@waegenei.re>
Co-authored-by: jgart <jgart@dismail.de>
Co-authored-by: Julien Lepiller <julien@lepiller.eu>
---
gnu/packages/games.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)
Toggle diff (43 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 262b85edc0..468f59ec5a 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -9374,6 +9374,36 @@ and bring the war to your enemy.")
license:expat license:fdl1.3+ license:public-domain
license:zlib))))
+(define-public go-github-com-anaseto-gruid
+ (package
+ (name "go-github-com-anaseto-gruid")
+ (version "0.21.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/anaseto/gruid")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0rvsavkvg2hziwdh8sjk3n5v92m5mfjb8v9m7ch22maxfwq5kv6y"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/anaseto/gruid"))
+ (propagated-inputs
+ `(("go-golang-org-x-image" ,go-golang-org-x-image)))
+ (home-page "https://github.com/anaseto/gruid")
+ (synopsis "Cross-platform grid-based UI and game framework")
+ (description
+"The gruid module provides packages for easily building grid-based
+ applications in Go. The library abstracts rendering and input for
+ different platforms. There are drivers available for terminal apps ,
+ native graphical apps and browser apps. The original application for the
+ library was creating grid-based games, but it's also well-suited for any
+ grid-based application.")
+ (license license:isc)))
+
(define-public go-github-com-anaseto-gruid-tcell
(package
(name "go-github-com-anaseto-gruid-tcell")
--
2.33.0