[PATCH 3/4] gnu: Add go-github-com-anaseto-gruid.

  • Done
  • quality assurance status badge
Details
2 participants
  • jgart
  • Maxim Cournoyer
Owner
unassigned
Submitted by
jgart
Severity
normal
J
(address . guix-patches@gnu.org)
20210830164041.19770-3-jgart@dismail.de
From: Guix Together <jgart@dismail.de>

* gnu/packages/games.scm (go-github-com-anaseto-gruid): New variable.

Co-authored-by: Arun Isaac <arunisaac@systemreboot.net>
Co-authored-by: Brice Waegeneire <brice@waegenei.re>
Co-authored-by: jgart <jgart@dismail.de>
Co-authored-by: Julien Lepiller <julien@lepiller.eu>
---
gnu/packages/games.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 262b85edc0..468f59ec5a 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -9374,6 +9374,36 @@ and bring the war to your enemy.")
license:expat license:fdl1.3+ license:public-domain
license:zlib))))
+(define-public go-github-com-anaseto-gruid
+ (package
+ (name "go-github-com-anaseto-gruid")
+ (version "0.21.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/anaseto/gruid")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0rvsavkvg2hziwdh8sjk3n5v92m5mfjb8v9m7ch22maxfwq5kv6y"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/anaseto/gruid"))
+ (propagated-inputs
+ `(("go-golang-org-x-image" ,go-golang-org-x-image)))
+ (home-page "https://github.com/anaseto/gruid")
+ (synopsis "Cross-platform grid-based UI and game framework")
+ (description
+"The gruid module provides packages for easily building grid-based
+ applications in Go. The library abstracts rendering and input for
+ different platforms. There are drivers available for terminal apps ,
+ native graphical apps and browser apps. The original application for the
+ library was creating grid-based games, but it's also well-suited for any
+ grid-based application.")
+ (license license:isc)))
+
(define-public go-github-com-anaseto-gruid-tcell
(package
(name "go-github-com-anaseto-gruid-tcell")
--
2.33.0
J
This one can be closed since it was merged
(address . 50277@debbugs.gnu.org)(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
20210911205338.GB8633@gac.attlocal.net
Just a friendly reminder that this issue can be closed since it was merged in f48156dc
_________________________________________
/ 3B1D 7F19 E36B B60C 0F5B 2CA9 A52A A2B4 \
\ 77B6 DD35 /
-----------------------------------------
\ ^__^
\ (oo)\_______
(__)\ )\/\
||----w |
|| ||
M
M
Maxim Cournoyer wrote on 12 Sep 2021 05:05
(name . jgart)(address . jgart@dismail.de)(address . 50277-done@debbugs.gnu.org)
87fsuapk7p.fsf@gmail.com
Hello!

jgart <jgart@dismail.de> writes:

Toggle quote (12 lines)
> Just a friendly reminder that this issue can be closed since it was merged in f48156dc
>
> _________________________________________
> / 3B1D 7F19 E36B B60C 0F5B 2CA9 A52A A2B4 \
> \ 77B6 DD35 /
> -----------------------------------------
> \ ^__^
> \ (oo)\_______
> (__)\ )\/\
> ||----w |
> || ||

Thanks for the reminder!

I'm closing it by replying with the CC adjusted from
50277@debbugs.gnu.org to 50277-done@debbugs.gnu.org :-).

Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 50277@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 50277
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch