(address . guix-patches@gnu.org)
From: Guix Together <jgart@dismail.de>
* gnu/packages/games.scm (go-github-com-anaseto-gruid-tcell): New variable.
Co-authored-by: Arun Isaac <arunisaac@systemreboot.net>
Co-authored-by: Brice Waegeneire <brice@waegenei.re>
Co-authored-by: jgart <jgart@dismail.de>
Co-authored-by: Julien Lepiller <julien@lepiller.eu>
---
gnu/packages/games.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)
Toggle diff (51 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 07a61f2c0b..262b85edc0 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -131,6 +131,7 @@
#:use-module (gnu packages gnu-doc)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages gnuzilla)
+ #:use-module (gnu packages golang)
#:use-module (gnu packages gperf)
#:use-module (gnu packages graphics)
#:use-module (gnu packages gsasl)
@@ -9373,6 +9374,36 @@ and bring the war to your enemy.")
license:expat license:fdl1.3+ license:public-domain
license:zlib))))
+(define-public go-github-com-anaseto-gruid-tcell
+ (package
+ (name "go-github-com-anaseto-gruid-tcell")
+ (version "0.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/anaseto/gruid-tcell")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "09ajr9mbldjfc44qprplbf8dr8yhlbn2nfnas2z62m9wmklc0qiv"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/anaseto/gruid-tcell"))
+ (propagated-inputs
+ `(("go-github-com-gdamore-tcell-v2"
+ ,go-github-com-gdamore-tcell-v2)
+ ("go-github-com-anaseto-gruid"
+ ,go-github-com-anaseto-gruid)))
+ (home-page
+ "https://github.com/anaseto/gruid-tcell")
+ (synopsis "Gruid driver using the tcell library")
+ (description
+"The gruid-tcell module provides a gruid driver for building terminal
+full-window applications.")
+ (license license:isc)))
+
(define-public harmonist
(package
(name "harmonist")
--
2.33.0