[PATCH] gnu: Add slstatus.

  • Done
  • quality assurance status badge
Details
One participant
  • Raghav Gururajan
Owner
unassigned
Submitted by
Raghav Gururajan
Severity
normal
R
R
Raghav Gururajan wrote on 13 Jun 2021 07:51
(address . guix-patches@gnu.org)(name . Raghav Gururajan)(address . rg@raghavgururajan.name)
20210613055140.2414-1-rg@raghavgururajan.name
* gnu/packages/suckless.scm (slstatus): New variable.
---
gnu/packages/suckless.scm | 43 +++++++++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)

Toggle diff (56 lines)
diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
index f4bf01c5df..e3d2ca2a17 100644
--- a/gnu/packages/suckless.scm
+++ b/gnu/packages/suckless.scm
@@ -49,6 +49,49 @@
#:use-module (guix utils)
#:use-module (guix packages))
+(define-public slstatus
+ (let ((commit "84a2f117a32f0796045941260cdc4b69852b41e0")
+ (revision "0"))
+ (package
+ (name "slstatus")
+ (version
+ (git-version "0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "git://git.suckless.org/slstatus.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "063a4fnvsjbc61alnbfdpxy0nwhh9ql9j6s9hkdv12713kv932ds"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no target
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (substitute* "config.mk"
+ ;; To correct PREFIX path.
+ (("/usr/local")
+ (assoc-ref outputs "out"))
+ ;; To correct X11 path.
+ (("/usr/X11R6")
+ (assoc-ref inputs "x11"))
+ ;; To correct CC value.
+ (("CC = cc")
+ (string-append "CC = " ,(cc-for-target))))))
+ (delete 'configure)))) ; no target
+ (inputs
+ `(("x11" ,libx11)))
+ (home-page "https://tools.suckless.org/slstatus/")
+ (synopsis "Status Monitor for Window Managers")
+ (description "SlStatus is a suckless status monitor for window managers
+that use WM_NAME or stdin to fill the status bar.")
+ (license license:isc))))
+
(define-public blind
(package
(name "blind")
--
2.31.1
R
R
Raghav Gururajan wrote on 13 Jun 2021 07:57
[PATCH v2] gnu: Add slstatus.
(address . 48996@debbugs.gnu.org)(name . Raghav Gururajan)(address . rg@raghavgururajan.name)
20210613055751.2638-1-rg@raghavgururajan.name
* gnu/packages/suckless.scm (slstatus): New variable.
---
gnu/packages/suckless.scm | 40 +++++++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
index f4bf01c5df..4ced54ef0e 100644
--- a/gnu/packages/suckless.scm
+++ b/gnu/packages/suckless.scm
@@ -49,6 +49,46 @@
#:use-module (guix utils)
#:use-module (guix packages))
+(define-public slstatus
+ (let ((commit "84a2f117a32f0796045941260cdc4b69852b41e0")
+ (revision "0"))
+ (package
+ (name "slstatus")
+ (version
+ (git-version "0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "git://git.suckless.org/slstatus.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "063a4fnvsjbc61alnbfdpxy0nwhh9ql9j6s9hkdv12713kv932ds"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no target
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (substitute* "config.mk"
+ ;; To correct PREFIX path.
+ (("/usr/local") (assoc-ref outputs "out"))
+ ;; To correct X11 path.
+ (("/usr/X11R6") (assoc-ref inputs "x11"))
+ ;; To correct CC value.
+ (("CC = cc") (string-append "CC = " ,(cc-for-target))))))
+ (delete 'configure)))) ; no target
+ (inputs
+ `(("x11" ,libx11)))
+ (home-page "https://tools.suckless.org/slstatus/")
+ (synopsis "Status Monitor for Window Managers")
+ (description "SlStatus is a suckless status monitor for window managers
+that use WM_NAME or stdin to fill the status bar.")
+ (license license:isc))))
+
(define-public blind
(package
(name "blind")
--
2.31.1
R
R
Raghav Gururajan wrote on 13 Jun 2021 08:13
[PATCH v3] gnu: Add slstatus.
(address . 48996@debbugs.gnu.org)(name . Raghav Gururajan)(address . rg@raghavgururajan.name)
20210613061341.3384-1-rg@raghavgururajan.name
* gnu/packages/suckless.scm (slstatus): New variable.
---
gnu/packages/suckless.scm | 39 +++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)

Toggle diff (52 lines)
diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
index f4bf01c5df..b7f6aeca93 100644
--- a/gnu/packages/suckless.scm
+++ b/gnu/packages/suckless.scm
@@ -49,6 +49,45 @@
#:use-module (guix utils)
#:use-module (guix packages))
+(define-public slstatus
+ ;; No release tarballs yet.
+ (let ((commit "84a2f117a32f0796045941260cdc4b69852b41e0")
+ (revision "0"))
+ (package
+ (name "slstatus")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "git://git.suckless.org/slstatus.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "063a4fnvsjbc61alnbfdpxy0nwhh9ql9j6s9hkdv12713kv932ds"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no target
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (substitute* "config.mk"
+ ;; To correct PREFIX path.
+ (("/usr/local") (assoc-ref outputs "out"))
+ ;; To correct X11 path.
+ (("/usr/X11R6") (assoc-ref inputs "x11"))
+ ;; To correct CC value.
+ (("CC = cc") (string-append "CC = " ,(cc-for-target))))))
+ (delete 'configure)))) ; no target
+ (inputs
+ `(("x11" ,libx11)))
+ (home-page "https://tools.suckless.org/slstatus/")
+ (synopsis "Status Monitor for Window Managers")
+ (description "SlStatus is a suckless status monitor for window managers
+that use WM_NAME or stdin to fill the status bar.")
+ (license license:isc))))
+
(define-public blind
(package
(name "blind")
--
2.31.1
R
R
Raghav Gururajan wrote on 16 Jun 2021 05:00
[PATCH v4] gnu: Add slstatus.
(address . 48996@debbugs.gnu.org)(name . Raghav Gururajan)(address . rg@raghavgururajan.name)
20210616030005.6489-1-rg@raghavgururajan.name
* gnu/packages/suckless.scm (slstatus): New variable.
---
gnu/packages/suckless.scm | 65 +++++++++++++++++++++++++++++++++++++++
1 file changed, 65 insertions(+)

Toggle diff (78 lines)
diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
index f4bf01c5df..a1ecfb68fe 100644
--- a/gnu/packages/suckless.scm
+++ b/gnu/packages/suckless.scm
@@ -49,6 +49,71 @@
#:use-module (guix utils)
#:use-module (guix packages))
+(define-public slstatus
+ ;; No release tarballs yet.
+ (let ((commit "84a2f117a32f0796045941260cdc4b69852b41e0")
+ (revision "0"))
+ (package
+ (name "slstatus")
+ (version (git-version "0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "git://git.suckless.org/slstatus.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "063a4fnvsjbc61alnbfdpxy0nwhh9ql9j6s9hkdv12713kv932ds"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ;no test-suite
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (substitute* "config.mk"
+ ;; To correct PREFIX path.
+ (("/usr/local") (assoc-ref outputs "out"))
+ ;; To correct X11 path.
+ (("/usr/X11R6") (assoc-ref inputs "x11"))
+ ;; To correct CC value.
+ (("CC = cc") (string-append "CC = " ,(cc-for-target))))))
+ (delete 'configure)))) ;not required
+ (inputs
+ `(("x11" ,libx11)))
+ (home-page "https://tools.suckless.org/slstatus/")
+ (synopsis "Status Monitor for Window Managers")
+ (description "SlStatus is a suckless status monitor for window managers
+that use WM_NAME or stdin to fill the status bar.
+It provides following features:
+@itemize
+@item Battery percentage/state/time left
+@item CPU usage
+@item CPU frequency
+@item Custom shell commands
+@item Date and time
+@item Disk status (free storage, percentage, total storage and used storage)
+@item Available entropy
+@item Username/GID/UID
+@item Hostname
+@item IP address (IPv4 and IPv6)
+@item Kernel version
+@item Keyboard indicators
+@item Keymap
+@item Load average
+@item Network speeds (RX and TX)
+@item Number of files in a directory (hint: Maildir)
+@item Memory status (free memory, percentage, total memory and used memory)
+@item Swap status (free swap, percentage, total swap and used swap)
+@item Temperature
+@item Uptime
+@item Volume percentage
+@item WiFi signal percentage and ESSID
+@end itemize")
+ (license license:isc))))
+
(define-public blind
(package
(name "blind")
--
2.32.0
R
R
Raghav Gururajan wrote on 16 Jun 2021 05:14
[PATCH v5] gnu: Add slstatus.
(address . 48996@debbugs.gnu.org)(name . Raghav Gururajan)(address . rg@raghavgururajan.name)
20210616031436.6991-1-rg@raghavgururajan.name
* gnu/packages/suckless.scm (slstatus): New variable.
---
gnu/packages/suckless.scm | 65 +++++++++++++++++++++++++++++++++++++++
1 file changed, 65 insertions(+)

Toggle diff (78 lines)
diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
index f4bf01c5df..bf362d9a80 100644
--- a/gnu/packages/suckless.scm
+++ b/gnu/packages/suckless.scm
@@ -49,6 +49,71 @@
#:use-module (guix utils)
#:use-module (guix packages))
+(define-public slstatus
+ ;; No release tarballs yet.
+ (let ((commit "84a2f117a32f0796045941260cdc4b69852b41e0")
+ (revision "0"))
+ (package
+ (name "slstatus")
+ (version (git-version "0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "git://git.suckless.org/slstatus.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "063a4fnvsjbc61alnbfdpxy0nwhh9ql9j6s9hkdv12713kv932ds"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ;no test-suite
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (substitute* "config.mk"
+ ;; To correct PREFIX path.
+ (("/usr/local") (assoc-ref outputs "out"))
+ ;; To correct X11 path.
+ (("/usr/X11R6") (assoc-ref inputs "x11"))
+ ;; To correct CC value.
+ (("CC = cc") (string-append "CC = " ,(cc-for-target))))))
+ (delete 'configure)))) ;no configure script
+ (inputs
+ `(("x11" ,libx11)))
+ (home-page "https://tools.suckless.org/slstatus/")
+ (synopsis "Status monitor for window managers")
+ (description "SlStatus is a suckless status monitor for window managers
+that use WM_NAME or stdin to fill the status bar.
+It provides following features:
+@itemize
+@item Battery percentage/state/time left
+@item CPU usage
+@item CPU frequency
+@item Custom shell commands
+@item Date and time
+@item Disk status (free storage, percentage, total storage and used storage)
+@item Available entropy
+@item Username/GID/UID
+@item Hostname
+@item IP address (IPv4 and IPv6)
+@item Kernel version
+@item Keyboard indicators
+@item Keymap
+@item Load average
+@item Network speeds (RX and TX)
+@item Number of files in a directory (hint: Maildir)
+@item Memory status (free memory, percentage, total memory and used memory)
+@item Swap status (free swap, percentage, total swap and used swap)
+@item Temperature
+@item Uptime
+@item Volume percentage
+@item WiFi signal percentage and ESSID
+@end itemize")
+ (license license:isc))))
+
(define-public blind
(package
(name "blind")
--
2.32.0
R
R
Raghav Gururajan wrote on 16 Jun 2021 08:29
[PATCH v6] gnu: Add slstatus.
(address . 48996@debbugs.gnu.org)(name . Raghav Gururajan)(address . rg@raghavgururajan.name)
20210616062906.10490-1-rg@raghavgururajan.name
* gnu/packages/suckless.scm (slstatus): New variable.
---
gnu/packages/suckless.scm | 62 +++++++++++++++++++++++++++++++++++++++
1 file changed, 62 insertions(+)

Toggle diff (75 lines)
diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
index f4bf01c5df..65f4fa85a9 100644
--- a/gnu/packages/suckless.scm
+++ b/gnu/packages/suckless.scm
@@ -49,6 +49,68 @@
#:use-module (guix utils)
#:use-module (guix packages))
+(define-public slstatus
+ ;; No release tarballs yet.
+ (let ((commit "84a2f117a32f0796045941260cdc4b69852b41e0")
+ (revision "0"))
+ (package
+ (name "slstatus")
+ (version (git-version "0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "git://git.suckless.org/slstatus.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "063a4fnvsjbc61alnbfdpxy0nwhh9ql9j6s9hkdv12713kv932ds"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ;no test suite
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (substitute* "config.mk"
+ (("/usr/local") (assoc-ref outputs "out"))
+ (("/usr/X11R6") (assoc-ref inputs "x11"))
+ (("CC = cc") (string-append "CC = " ,(cc-for-target))))))
+ (delete 'configure)))) ;no configure script
+ (inputs
+ `(("x11" ,libx11)))
+ (home-page "https://tools.suckless.org/slstatus/")
+ (synopsis "Status monitor for window managers")
+ (description "SlStatus is a suckless status monitor for window managers
+that use WM_NAME or stdin to fill the status bar.
+It provides the following features:
+@itemize
+@item Battery percentage/state/time left
+@item CPU usage
+@item CPU frequency
+@item Custom shell commands
+@item Date and time
+@item Disk status (free storage, percentage, total storage and used storage)
+@item Available entropy
+@item Username/GID/UID
+@item Hostname
+@item IP address (IPv4 and IPv6)
+@item Kernel version
+@item Keyboard indicators
+@item Keymap
+@item Load average
+@item Network speeds (RX and TX)
+@item Number of files in a directory (hint: Maildir)
+@item Memory status (free memory, percentage, total memory and used memory)
+@item Swap status (free swap, percentage, total swap and used swap)
+@item Temperature
+@item Uptime
+@item Volume percentage
+@item WiFi signal percentage and ESSID
+@end itemize")
+ (license license:isc))))
+
(define-public blind
(package
(name "blind")
--
2.32.0
R
R
Raghav Gururajan wrote on 16 Jun 2021 08:33
(no subject)
(address . 48996-done@debbugs.gnu.org)
9effc0f5-34a8-9b11-2bb3-8e4cbdf4c94d@raghavgururajan.name
Pushed as 7959aabbe1.
Attachment: OpenPGP_signature
Closed
?