(address . bug-guix@gnu.org)
Hello!
I've had this issue every since I enabled automatic login on my guix
system like so:
#+BEGIN_SRC scheme
(define %my-desktop-services
(modify-services
%desktop-services
(mingetty-service-type config =>
(mingetty-configuration
(inherit config)
;;auto login as joshua
(auto-login "joshua")))))
(operating-system
...
(services (list %my-desktop-services)))
#+END_SRC
This is the "error message"
#+BEGIN_SRC sh
This is the GNU system. Welcome
dobby login: joshua (automatic login)
This is the GNU operating system, welcome!
Cannot make/remove an entry for the specified session
#+END_SRC
Essentially, mingetty tries to auto log me in, but I am using desktop
services. So mingetty tries to log me in, before many of the desktop
services are started. However, I guess this doesn't work. Meaning,
my autostart sway script is NOT run, until AFTER all of the desktop
services are started. WHICH IS PROBABLY A GOOD IDEA. I would rather
log in, when my desktop services have started, not before.
BUT the minor issue is that after I log in, =users= reports:
#+BEGIN_SRC sh
joshua@dobby ~> users
joshua joshua joshua joshua joshua joshua
#+END_SRC
So it looks like 6 versions of myself are logged in by the time I am
officially logged in and I auto start sway via .bash_profile:
#+BEGING_SRC sh
# Honor per-interactive-shell startup file
if [ -f ~/.bashrc ]; then . ~/.bashrc; fi
# shepherd
if [[ -z $DISPLAY ]] && [[ $(tty) = /dev/tty1 ]]; then
export MOZ_ENABLE_WAYLAND=1
export GUIX_PACKAGE_PATH=/home/joshua/prog/gnu/guix/guix-packages/
XDG_DATA_DIRS=/var/lib/flatpak/exports/share:/home/joshua/.local/share/flatpak/exports/share:$XDG_DATA_DIRS
# this may fix a bug that I have with termite confusing backspace as space in guix environment
# export TERM=linux
shepherd -c /home/joshua/.config/shepherd/init.scm &
exec dbus-run-session sway
fi
#+END_SRC
I'm guessing the root cause is that the shepherd starts most services
sequentially at the moment. Anyway, I thought I'd share a minor issue
with you all!
Thanks!
Joshua Branson