(address . guix-patches@gnu.org)
* hydra/nginx/html/bordeaux/index.html: (Using These substitutes):
Fixed a typo, and added a how to code snippet for users of guix system.
---
hydra/nginx/html/bordeaux/index.html | 42 +++++++++++++++++++++++++++-
1 file changed, 41 insertions(+), 1 deletion(-)
Toggle diff (61 lines)
diff --git a/hydra/nginx/html/bordeaux/index.html b/hydra/nginx/html/bordeaux/index.html
index a74f2e2..89042af 100644
--- a/hydra/nginx/html/bordeaux/index.html
+++ b/hydra/nginx/html/bordeaux/index.html
@@ -36,7 +36,7 @@
<b>arm-linux-gnueabihf</b> availability is limited.
</p>
- <h2>Using these substiutes</h2>
+ <h2>Using these substitutes</h2>
<p>
The URL to use to fetch substitutes is <code>https://bordeaux.guix.gnu.org</code>,
and they're signed with the following key.
@@ -47,5 +47,45 @@
)
)</pre>
</p>
+ <p>
+ Users of Guix System can start using these substitutes with a
+ bit of scheme code that looks like:
+
+ <pre>
+(define %my-desktop-services
+ (modify-services
+ %desktop-services
+ (guix-service-type
+ config =>
+ (guix-configuration
+ (inherit config)
+ (substitute-urls
+ (append (list "https://bordeaux.guix.gnu.org/";)
+ %default-substitute-urls))
+ (authorized-keys
+ (append
+ (list
+ (plain-file
+ "bordeaux.guix.gnu.org.signing.key"
+ "
+(public-key
+ (ecc
+ (curve Ed25519)
+ (q #7D602902D3A2DBB83F8A0FB98602A754C5493B0B778C8D1DD4E0F41DE14DE34F#)
+ )
+ )"))
+ %default-authorized-guix-keys)))))))
+
+
+(operating-system
+ ...
+ (services (append (list (service dhcp-client-service-type)
+ (service openssh-service-type
+ (openssh-configuration
+ (openssh openssh-sans-x)
+ (port-number 2222))))
+ %my-desktop-services)))
+ </pre>
+ </p>
</body>
</html>
--
2.31.1