[PATCH] gnu: meld: Copy GTKSourceView styles.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Prikler
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
Leo Prikler
Severity
normal
L
L
Leo Prikler wrote on 15 May 2021 17:55
(address . guix-patches@gnu.org)
20210515155528.25736-1-leo.prikler@student.tugraz.at
This fixes a somewhat cryptic error, that pops up when gtksourceview-3 has not
been installed or propagated by any other package.

* gnu/packages/patchutils.scm (meld)[#:phases]: Add ‘copy-styles’.
---
gnu/packages/patchutils.scm | 7 +++++++
1 file changed, 7 insertions(+)

Toggle diff (20 lines)
diff --git a/gnu/packages/patchutils.scm b/gnu/packages/patchutils.scm
index f190fec1a2..8845942b8f 100644
--- a/gnu/packages/patchutils.scm
+++ b/gnu/packages/patchutils.scm
@@ -298,6 +298,13 @@ GiB).")
(invoke "py.test" "-v" "-k"
;; TODO: Those tests fail, why?
"not test_classify_change_actions")))
+ (add-after 'install 'copy-styles
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((styles "/share/gtksourceview-3.0/styles"))
+ (copy-recursively
+ (string-append (assoc-ref inputs "gtksourceview") styles)
+ (string-append (assoc-ref outputs "out") styles))
+ #t)))
(add-after 'wrap 'glib-or-gtk-wrap
(assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap))
(add-after 'wrap 'wrap-typelib
--
2.31.1
L
L
Liliana Marie Prikler wrote on 14 Sep 2021 23:58
(address . 48445-done@debbugs.gnu.org)
2a10f91c5561fae080fcbb0f4d8a9c011cb9d8b6.camel@gmail.com
Four months is bigger than two weeks, right? Anyway, pushed now.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 48445@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 48445
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch