[PATCH] Add font-montserrat.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Sergiu Ivanov
Owner
unassigned
Submitted by
Sergiu Ivanov
Severity
normal
S
S
Sergiu Ivanov wrote on 30 Apr 2021 22:47
(address . guix-patches@gnu.org)
87im43wlcl.fsf@colimite.fr
Dear Guix,

Here's a patch adding the font Montserrat.

I retrieve the release zipball from GitHub using a direct url-fetch
rather than git-fetch, because I've seen both in fonts.scm. If you think
git-fetch is more appropriate, I'll change the method.

Thank you!
From 6de396df2fa096e8ff3e27328c902fe789e12a13 Mon Sep 17 00:00:00 2001
From: Sergiu Ivanov <sivanov@colimite.fr>
Date: Fri, 30 Apr 2021 22:20:16 +0200
Subject: [PATCH] Add font-montserrat.

---
gnu/packages/fonts.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index b78c46b0f8..35f2398dc8 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -39,6 +39,7 @@
;;; Copyright © 2020 Tim Van den Langenbergh <tmt_vdl@gmx.com>
;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
;;; Copyright © 2021 Antoine Côté <antoine.cote@posteo.net>
+;;; Copyright © 2021 Sergiu Ivanov <sivanov@colimite.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2156,3 +2157,21 @@ suitable for a wide range of uses.")
(description "Cozette is a 6x13px (bounding box) bitmap font based on Dina
and heavily inspired by Creep.")
(license license:expat)))
+
+(define-public font-montserrat
+ (package
+ (name "font-montserrat")
+ (version "7.210")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/JulietaUla/Montserrat/archive/refs/tags/v" version ".zip"))
+ (sha256
+ (base32
+ "0k5jsb8hgya4ap80w5l4vxnx17kw482k3lm007awjyy5qzp982z3"))
+ ))
+ (build-system font-build-system)
+ (home-page "https://github.com/JulietaUla/Montserrat")
+ (synopsis "The Montserat font")
+ (description "The old posters and signs in the traditional Montserrat neighborhood of Buenos Aires inspired Julieta Ulanovsky to design this typeface and rescue the beauty of urban typography that emerged in the first half of the twentieth century.")
+ (license license:silofl1.1)))
--
2.31.1
L
L
Ludovic Courtès wrote on 3 May 2021 18:13
(name . Sergiu Ivanov)(address . sivanov@colimite.fr)(address . 48128@debbugs.gnu.org)
874kfjyeva.fsf@gnu.org
Hi Sergiu,

Sergiu Ivanov <sivanov@colimite.fr> skribis:

Toggle quote (5 lines)
> I retrieve the release zipball from GitHub using a direct url-fetch
> rather than git-fetch, because I've seen both in fonts.scm. If you think
> git-fetch is more appropriate, I'll change the method.


[...]

Toggle quote (4 lines)
> + (method url-fetch)
> + (uri (string-append
> + "https://github.com/JulietaUla/Montserrat/archive/refs/tags/v" version ".zip"))

This is a generated tarball that may change over time, which is why
‘guix lint’ warns about it. So yes, I think you should use ‘git-fetch’
instead.

You’ll also have to add a ‘file-name’ field to the origin, as ‘guix
lint’ suggests.

There are also a couple of ‘guix lint’ warnings that I’ll let you
check. :-)

Toggle quote (1 lines)
> + (synopsis "The Montserat font")
^
Missing ‘r’.

Could you send an updated patch?

Thanks in advance,
Ludo’.
L
L
Ludovic Courtès wrote on 5 May 2021 15:36
control message for bug #48128
(address . control@debbugs.gnu.org)
87h7jhjo92.fsf@gnu.org
tags 48128 + moreinfo
quit
S
S
Sergiu Ivanov wrote on 5 May 2021 22:17
Re: bug#48128: [PATCH] Add font-montserrat.
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 48128@debbugs.gnu.org)
87eeelszoq.fsf@colimite.fr
Hi Ludovic,

Thank you for taking the time to answer and giving me the opportunity
to learn!

Also, sorry for the delay.


Thus quoth Ludovic Courtès on Mon May 03 2021 at 18:13 (+0200):
Toggle quote (19 lines)
> Hi Sergiu,
>
> Sergiu Ivanov <sivanov@colimite.fr> skribis:
>
>> I retrieve the release zipball from GitHub using a direct url-fetch
>> rather than git-fetch, because I've seen both in fonts.scm. If you think
>> git-fetch is more appropriate, I'll change the method.
>
>
> [...]
>
>> + (method url-fetch)
>> + (uri (string-append
>> + "https://github.com/JulietaUla/Montserrat/archive/refs/tags/v" version ".zip"))
>
> This is a generated tarball that may change over time, which is why
> ‘guix lint’ warns about it. So yes, I think you should use ‘git-fetch’
> instead.

I changed that, thank you.

Toggle quote (3 lines)
> You’ll also have to add a ‘file-name’ field to the origin, as ‘guix
> lint’ suggests.

Indeed, I added that field.

Toggle quote (3 lines)
> There are also a couple of ‘guix lint’ warnings that I’ll let you
> check. :-)

I left closing parens on a separate line :O :O :O

I remember thinking how guix lint was wonderful when I read the Guix
Manual, and now I forgot to run it :D

Toggle quote (4 lines)
>> + (synopsis "The Montserat font")
> ^
> Missing ‘r’.

Fixed, thank you.

Toggle quote (2 lines)
> Could you send an updated patch?

I attach the update.

-
Sergiu
From fcec43e6a60081c2041f5827f22bcccec3c17bfd Mon Sep 17 00:00:00 2001
From: Sergiu Ivanov <sivanov@colimite.fr>
Date: Fri, 30 Apr 2021 22:20:16 +0200
Subject: [PATCH] Add font-montserrat.

---
gnu/packages/fonts.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index b78c46b0f8..8c9b4b68ce 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -39,6 +39,7 @@
;;; Copyright © 2020 Tim Van den Langenbergh <tmt_vdl@gmx.com>
;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
;;; Copyright © 2021 Antoine Côté <antoine.cote@posteo.net>
+;;; Copyright © 2021 Sergiu Ivanov <sivanov@colimite.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2156,3 +2157,25 @@ suitable for a wide range of uses.")
(description "Cozette is a 6x13px (bounding box) bitmap font based on Dina
and heavily inspired by Creep.")
(license license:expat)))
+
+(define-public font-montserrat
+ (package
+ (name "font-montserrat")
+ (version "7.210")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JulietaUla/Montserrat")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0jn1yvfamq5xazw85sfnxgriji60g7mkss9mkf8d0117vdk838bn"))))
+ (build-system font-build-system)
+ (home-page "https://github.com/JulietaUla/Montserrat")
+ (synopsis "The Montserrat font")
+ (description "The old posters and signs in the traditional Montserrat
+neighborhood of Buenos Aires inspired Julieta Ulanovsky to design this
+typeface and rescue the beauty of urban typography that emerged in the first
+half of the twentieth century.")
+ (license license:silofl1.1)))
--
2.31.1
L
L
Ludovic Courtès wrote on 8 May 2021 12:14
(name . Sergiu Ivanov)(address . sivanov@colimite.fr)(address . 48128-done@debbugs.gnu.org)
874kfda5xy.fsf@gnu.org
Hi Sergiu,

Sergiu Ivanov <sivanov@colimite.fr> skribis:

Toggle quote (3 lines)
> Thank you for taking the time to answer and giving me the opportunity
> to learn!

You’re welcome. :-)

Toggle quote (9 lines)
> From fcec43e6a60081c2041f5827f22bcccec3c17bfd Mon Sep 17 00:00:00 2001
> From: Sergiu Ivanov <sivanov@colimite.fr>
> Date: Fri, 30 Apr 2021 22:20:16 +0200
> Subject: [PATCH] Add font-montserrat.
>
> ---
> gnu/packages/fonts.scm | 23 +++++++++++++++++++++++
> 1 file changed, 23 insertions(+)

I added a ChangeLog-style commit message and committed it.

Thank you!

Ludo’.
Closed
?