[PATCH] gnu: Add xdo.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • WinterHound
Owner
unassigned
Submitted by
WinterHound
Severity
normal
W
W
WinterHound wrote on 20 Apr 2021 20:33
(address . guix-patches@gnu.org)(name . WinterHound)(address . winterhound@yandex.com)
20210420183304.31841-1-winterhound@yandex.com
---
gnu/packages/xdisorg.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 725ea0afd6..37f88f2766 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -510,6 +510,39 @@ manager supports it, you can use xdotool to switch desktops, move windows
between desktops, and change the number of desktops.")
(license license:bsd-3)))
+(define-public xdo
+ (package
+ (name "xdo")
+ (version "0.5.7")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/baskerville/xdo")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1h3jrygcjjbavdbkpx2hscsf0yf97gk487lzjdlvymd7dxdv9hy9"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:make-flags
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" %output))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (inputs
+ `(("libxcb" ,libxcb)
+ ("xcb-util-wm" ,xcb-util-wm)
+ ("xcb-util" ,xcb-util)))
+ (home-page "https://github.com/baskerville/xdo")
+ (synopsis "Small X utility to perform elementary actions on windows")
+ (description
+ "Apply the given action to the given windows.
+If no window IDs and no optioqqns are given, the action applies to the focused window.")
+ (license license:bsd-2)))
+
(define-public xeyes
(package
(name "xeyes")
--
2.31.1
L
L
Ludovic Courtès wrote on 6 Jun 2021 15:17
control message for bug #47915
(address . control@debbugs.gnu.org)
874kebku89.fsf@gnu.org
close 47915
quit
?