[PATCH] gnu: xfce4-settings: Add gsettings-desktop-schemas.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Brendan Tildesley
Owner
unassigned
Submitted by
Brendan Tildesley
Severity
normal
B
B
Brendan Tildesley wrote on 18 Apr 2021 08:23
(address . guix-patches@gnu.org)
20210418062326.15683-1-mail@brendan.scot
* gnu/packages/xfce.scm (xfce4-settings):[propagated-inputs]: Add
gsettings-desktop-schemas. This makes it appear in the system profile
via the xfce service. This fixes a bug where changing icon theme causes
xfce4-appearance-settings to crash with the error:

GLib-GIO-ERROR **: 15:41:45.828: Settings schema 'org.gnome.desktop.interface' is not installed
Trace/breakpoint trap
---
gnu/packages/xfce.scm | 2 ++
1 file changed, 2 insertions(+)

Toggle diff (15 lines)
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 38240d7b9f..ffac62af9e 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -755,6 +755,8 @@ allows you to shut down the computer from Xfce.")
("upower" ,upower) ;; TODO needs upower-glib
("python" ,python) ;; for xfce4-compose-mail
("xf86-input-libinput" ,xf86-input-libinput)))
+ (propagated-inputs
+ `(("gsettings-desktop-schemas" ,gsettings-desktop-schemas)))
(home-page "https://www.xfce.org/")
(synopsis "Xfce settings manager")
(description
--
2.31.1
L
L
Ludovic Courtès wrote on 29 Apr 2021 01:23
(name . Brendan Tildesley)(address . mail@brendan.scot)(address . 47863@debbugs.gnu.org)
8735vaoux5.fsf@gnu.org
Hi,

Brendan Tildesley <mail@brendan.scot> skribis:

Toggle quote (8 lines)
> * gnu/packages/xfce.scm (xfce4-settings):[propagated-inputs]: Add
> gsettings-desktop-schemas. This makes it appear in the system profile
> via the xfce service. This fixes a bug where changing icon theme causes
> xfce4-appearance-settings to crash with the error:
>
> GLib-GIO-ERROR **: 15:41:45.828: Settings schema 'org.gnome.desktop.interface' is not installed
> Trace/breakpoint trap

The patch LGTM but I can’t seem to reproduce the issue here. Namely, if
I go to Settings → Appearance and switch from “GNOME Theme” to
“Adwaita”, it just works.

Am I missing something?

Thanks,
Ludo’.
B
B
Brendan Tildesley wrote on 29 Apr 2021 07:53
(address . 47863@debbugs.gnu.org)(name . Ludovic Courtès)(address . ludo@gnu.org)
1673086833.87857.1619675585029@office.mailbox.org
Toggle quote (21 lines)
> On 04/29/2021 1:23 AM Ludovic Courtès <ludo@gnu.org> wrote:
>
>
> Hi,
>
> Brendan Tildesley <mail@brendan.scot> skribis:
>
> > * gnu/packages/xfce.scm (xfce4-settings):[propagated-inputs]: Add
> > gsettings-desktop-schemas. This makes it appear in the system profile
> > via the xfce service. This fixes a bug where changing icon theme causes
> > xfce4-appearance-settings to crash with the error:
> >
> > GLib-GIO-ERROR **: 15:41:45.828: Settings schema 'org.gnome.desktop.interface' is not installed
> > Trace/breakpoint trap
>
> The patch LGTM but I can’t seem to reproduce the issue here. Namely, if
> I go to Settings → Appearance and switch from “GNOME Theme” to
> “Adwaita”, it just works.
>
> Am I missing something?
>
If you also have GNOME installed then it will work. GNOME provides them via propagated inputs in many packages.
For me, the theme changes, but then the settings window crashes.

BTW do you think the way the gnome package is made with propagated inputs is better than how the xfce is made by union-ing everything?
B
B
Brendan Tildesley wrote on 29 Apr 2021 09:58
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 47863@debbugs.gnu.org)
928651470.89998.1619683138312@office.mailbox.org
Run
$(guix system vm ./xfce-os-test.scm) -m 1G
with this:

(use-modules (gnu)
(srfi srfi-1))
(use-service-modules desktop xorg)
(operating-system
(bootloader (grub-configuration))
(file-systems %base-file-systems)
(locale "en_AU.utf8")
(timezone "Australia/Hobart")
(keyboard-layout (keyboard-layout "us" "colemak"))
(host-name "jiu")
(users (cons* (user-account
(name "b")
(password (crypt "b" "$6$abc")) ;; password "b"
(comment "Brendan")
(group "users")
(home-directory "/home/b")
(supplementary-groups
'("wheel" "netdev" "audio" "video" "kvm")))
%base-user-accounts))
(packages
(append
(map specification->package '("nss-certs"
"gnome-themes-standard"))
%base-packages))
(services
(append
(list (set-xorg-configuration
(xorg-configuration
(keyboard-layout keyboard-layout)))

(service xfce-desktop-service-type))

(modify-services %desktop-services
(gdm-service-type
config => (gdm-configuration
(default-user "b")
(auto-login? #t)))))))
L
L
Ludovic Courtès wrote on 30 Apr 2021 18:20
(name . Brendan Tildesley)(address . mail@brendan.scot)(address . 47863-done@debbugs.gnu.org)
878s4zbv74.fsf_-_@gnu.org
Hi,

Brendan Tildesley <mail@brendan.scot> skribis:

Toggle quote (2 lines)
>> On 04/29/2021 1:23 AM Ludovic Courtès <ludo@gnu.org> wrote:

[...]

Toggle quote (9 lines)
>> The patch LGTM but I can’t seem to reproduce the issue here. Namely, if
>> I go to Settings → Appearance and switch from “GNOME Theme” to
>> “Adwaita”, it just works.
>>
>> Am I missing something?
>>
> If you also have GNOME installed then it will work. GNOME provides them via propagated inputs in many packages.
> For me, the theme changes, but then the settings window crashes.

OK. So actually what happens is that changing themes works, but the
thing crashes right after changing themes (which I didn’t notice when
spawning xfce4-appearance-settings by clicking in the menu).

Applied, thanks!

Toggle quote (2 lines)
> BTW do you think the way the gnome package is made with propagated inputs is better than how the xfce is made by union-ing everything?

No strong opinion, either way is fine with me.

Ludo’.
Closed
?