Incorrect code in the Guix manual, but only on the website

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Famulari
  • Mark H Weaver
Owner
unassigned
Submitted by
Mark H Weaver
Severity
normal
M
M
Mark H Weaver wrote on 16 Apr 2021 01:50
(address . bug-guix@gnu.org)
87r1jbgl8r.fsf@netris.org
In the Guix manual, as it appears on our website,


the manual entry for 'slim-service-type' suggests the following code to
remove the 'gdm' service from %desktop-services.

Toggle snippet (4 lines)
(modify-services %desktop-services
(delete gdm-service-type))

This code is incorrect. 'modify-services' does not support deleting
services.

The puzzling thing is that I can't find where this suggested code exists
in our git repository. The manual in our git repository is correct.
Instead of the code above, it suggests:

Toggle snippet (5 lines)
(remove (lambda (service)
(eq? (service-kind service) gdm-service-type))
%desktop-services)

M
M
Mark H Weaver wrote on 16 Apr 2021 02:12
(address . 47812@debbugs.gnu.org)
87o8efgk93.fsf@netris.org
Mark H Weaver <mhw@netris.org> writes:

Toggle quote (8 lines)
> The correct text was added about 2 years ago, in the following commit:
>
> https://git.sv.gnu.org/cgit/guix.git/commit/?id=dbef9015db107dd148133420b89af552ef08f8ee
>
> I see no evidence of it being changed since then.
>
> Any idea where the incorrect code on the website manual is coming from?

I see now that this new functionality was added to the 'staging' branch
3 days ago:


It seems inappropriate for our online website manual to be taken from
'staging'. It has already led to an experienced Guix developer
repeatedly suggesting (to a new user) a code snippet that cannot
possibly work on the 'master' branch:


Mark
L
L
Leo Famulari wrote on 16 Apr 2021 03:13
(name . Mark H Weaver)(address . mhw@netris.org)(address . 47812@debbugs.gnu.org)
YHjkn48T3Mr39PZ/@jasmine.lan
On Thu, Apr 15, 2021 at 08:12:13PM -0400, Mark H Weaver wrote:
Toggle quote (20 lines)
> Mark H Weaver <mhw@netris.org> writes:
>
> > The correct text was added about 2 years ago, in the following commit:
> >
> > https://git.sv.gnu.org/cgit/guix.git/commit/?id=dbef9015db107dd148133420b89af552ef08f8ee
> >
> > I see no evidence of it being changed since then.
> >
> > Any idea where the incorrect code on the website manual is coming from?
>
> I see now that this new functionality was added to the 'staging' branch
> 3 days ago:
>
> https://git.sv.gnu.org/cgit/guix.git/commit/?h=staging&id=a247f5c7537df7e0c09051ba22d5c95eb08f48b9
>
> It seems inappropriate for our online website manual to be taken from
> 'staging'. It has already led to an experienced Guix developer
> repeatedly suggesting (to a new user) a code snippet that cannot
> possibly work on the 'master' branch:

Hm, that's not supposed to happen. It's supposed to be based on the
'master' branch.
L
L
Leo Famulari wrote on 16 Apr 2021 03:32
(name . Mark H Weaver)(address . mhw@netris.org)(address . 47812@debbugs.gnu.org)
YHjpHsuqItrD6QsN@jasmine.lan
On Thu, Apr 15, 2021 at 08:12:13PM -0400, Mark H Weaver wrote:
Toggle quote (5 lines)
> I see now that this new functionality was added to the 'staging' branch
> 3 days ago:
>
> https://git.sv.gnu.org/cgit/guix.git/commit/?h=staging&id=a247f5c7537df7e0c09051ba22d5c95eb08f48b9

If I understand correctly, this commit is also on the master branch:


And I do see it in my local copy of the repo.

Can you double-check on your end? Or have I misunderstood?
M
M
Mark H Weaver wrote on 16 Apr 2021 05:38
(name . Leo Famulari)(address . leo@famulari.name)(address . 47812@debbugs.gnu.org)
87k0p2hp8z.fsf@netris.org
tags 47812 + notabug
close 47812
thanks

Hi Leo,

Leo Famulari <leo@famulari.name> writes:

Toggle quote (14 lines)
> On Thu, Apr 15, 2021 at 08:12:13PM -0400, Mark H Weaver wrote:
>> I see now that this new functionality was added to the 'staging' branch
>> 3 days ago:
>>
>> https://git.sv.gnu.org/cgit/guix.git/commit/?h=staging&id=a247f5c7537df7e0c09051ba22d5c95eb08f48b9
>
> If I understand correctly, this commit is also on the master branch:
>
> https://git.savannah.gnu.org/cgit/guix.git/commit/?h=master&id=a247f5c7537df7e0c09051ba22d5c95eb08f48b9
>
> And I do see it in my local copy of the repo.
>
> Can you double-check on your end? Or have I misunderstood?

No, you're right. When I first checked, I hadn't updated my local git
repo recently enough to have the commit. However, I'm not sure how I
managed to include (in my original report) a Savannah URL pointing to
the relevant code without noticing that it had the newly updated code.

I'm closing this bug now. Sorry for the noise.

Thanks,
Mark
?