[PATCH] gnu: Add python-mappy.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Famulari
  • Roel Janssen
Owner
unassigned
Submitted by
Roel Janssen
Severity
normal
R
R
Roel Janssen wrote on 15 Apr 2021 15:12
(address . guix-patches@gnu.org)
2e1eb9cd-ee87-32fb-c720-b0824441f54e@gnu.org
Hi Guix,

Here's a patch for python-mappy.

Cheers,
Roel
From d2df153a97eb326cbb72c556ffbd821877e9419a Mon Sep 17 00:00:00 2001
From: Roel Janssen <roel@gnu.org>
Date: Thu, 15 Apr 2021 15:09:59 +0200
Subject: [PATCH] gnu: Add python-mappy.

* gnu/packages/python-xyz.scm (python-mappy): New variable.
---
gnu/packages/python-xyz.scm | 24 +++++++++++++++++++++++-
1 file changed, 23 insertions(+), 1 deletion(-)

Toggle diff (44 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9d115790e1..5a4220541e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -39,7 +39,7 @@
;;; Copyright © 2017 Ben Sturmfels <ben@sturm.com.au>
;;; Copyright © 2017, 2018, 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2017 José Miguel Sánchez García <jmi2k@openmailbox.org>
-;;; Copyright © 2017, 2020 Roel Janssen <roel@gnu.org>
+;;; Copyright © 2017, 2020, 2021 Roel Janssen <roel@gnu.org>
;;; Copyright © 2017, 2018, 2019 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2017 Muriithi Frederick Muriuki <fredmanglis@gmail.com>
@@ -2020,6 +2020,28 @@ information created by most SVG editors. Optimization options are typically
lossless but can be tweaked for more aggressive cleaning.")
(license license:asl2.0)))
+(define-public python-mappy
+ (package
+ (name "python-mappy")
+ (version "2.18")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "mappy" version))
+ (sha256
+ (base32
+ "1a05p7rkmxa6qhm108na8flzj2v45jab06drk59kzk1ip2sgvzqq"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-cython" ,python-cython)))
+ (inputs
+ `(("zlib" ,zlib)))
+ (home-page "https://github.com/lh3/minimap2")
+ (synopsis "Python binding for minimap2")
+ (description "This package provides a convenient interface to minimap2,
+a fast and accurate C program to align genomic and transcribe nucleotide
+sequences.")
+ (license license:expat)))
+
(define-public python-mechanize
(package
(name "python-mechanize")
--
2.30.2
L
L
Leo Famulari wrote on 15 Apr 2021 19:09
(name . Roel Janssen)(address . roel@gnu.org)(address . 47796@debbugs.gnu.org)
YHhzR7PlykAq2evF@jasmine.lan
Toggle quote (7 lines)
> From d2df153a97eb326cbb72c556ffbd821877e9419a Mon Sep 17 00:00:00 2001
> From: Roel Janssen <roel@gnu.org>
> Date: Thu, 15 Apr 2021 15:09:59 +0200
> Subject: [PATCH] gnu: Add python-mappy.
>
> * gnu/packages/python-xyz.scm (python-mappy): New variable.

Thanks! LGTM
R
R
Roel Janssen wrote on 16 Apr 2021 11:26
(name . Leo Famulari)(address . leo@famulari.name)(address . 47796-done@debbugs.gnu.org)
747c4247f44c46ced095dc1586adf95a4f90e521.camel@gnu.org
On Thu, 2021-04-15 at 13:09 -0400, Leo Famulari wrote:
Toggle quote (11 lines)
> > From d2df153a97eb326cbb72c556ffbd821877e9419a Mon Sep 17 00:00:00
> > 2001
> > From: Roel Janssen <roel@gnu.org>
> > Date: Thu, 15 Apr 2021 15:09:59 +0200
> > Subject: [PATCH] gnu: Add python-mappy.
> >
> > * gnu/packages/python-xyz.scm (python-mappy): New variable.
>
> Thanks! LGTM
>

Thanks! Pushed in 44f9432705d04c069a8acf9e37e3ad856ac0bf82.
Closed
?