[PATCH core-updates 0/4] Update ibus

  • Done
  • quality assurance status badge
Details
2 participants
  • Maxime Devos
  • Raghav Gururajan
Owner
unassigned
Submitted by
Raghav Gururajan
Severity
normal
R
R
R
Raghav Gururajan wrote on 14 Apr 2021 13:53
[PATCH core-updates 1/4] gnu: ibus: Update to 1.5.24.
(address . 47770@debbugs.gnu.org)(name . Raghav Gururajan)(address . rg@raghavgururajan.name)
20210414115349.14040-1-rg@raghavgururajan.name
* gnu/packages/ibus.scm (ibus)[version]: Update to 1.5.24.
[inputs]: Add glib, libxkbcommon, libxtst and python-dbus. Move
ucd, unicode-cldr-common and unicode-emoji from ...
[native-inputs]: ... here. Add gnome-common, perl, python-wrapper
and which.
---
gnu/packages/ibus.scm | 35 +++++++++++++++++++++++------------
1 file changed, 23 insertions(+), 12 deletions(-)

Toggle diff (83 lines)
diff --git a/gnu/packages/ibus.scm b/gnu/packages/ibus.scm
index fc59ea1c6b..e566993b08 100644
--- a/gnu/packages/ibus.scm
+++ b/gnu/packages/ibus.scm
@@ -49,18 +49,21 @@
#:use-module (gnu packages gtk)
#:use-module (gnu packages iso-codes)
#:use-module (gnu packages logging)
+ #:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-xyz)
#:use-module (gnu packages serialization)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages textutils)
#:use-module (gnu packages unicode)
- #:use-module (gnu packages xorg))
+ #:use-module (gnu packages xorg)
+ #:use-module (gnu packages xdisorg))
(define-public ibus
(package
(name "ibus")
- (version "1.5.22")
+ (version "1.5.24")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/ibus/ibus/"
@@ -68,7 +71,7 @@
version "/ibus-" version ".tar.gz"))
(sha256
(base32
- "0jmy2w01phpmqnjnfnak7nvfna57mpgfnl87jwc4iai8ijjynw41"))))
+ "07s2ly75xv50bqg37mn37i9akqvcfd45k2mbplxrsqk3a2b3mwxb"))))
(build-system glib-or-gtk-build-system)
(arguments
`(#:tests? #f ; tests fail because there's no connection to dbus
@@ -138,26 +141,34 @@
(inputs
`(("dbus" ,dbus)
("dconf" ,dconf)
+ ("glib" ,glib)
("gtk2" ,gtk+-2)
("gtk+" ,gtk+)
+ ("iso-codes" ,iso-codes)
("json-glib" ,json-glib)
("libnotify" ,libnotify)
("libx11" ,libx11)
+ ("libxkbcommon" ,libxkbcommon)
+ ("libxtst" ,libxtst)
+ ("pygobject" ,python-pygobject)
+ ("python" ,python)
+ ("python-dbus" ,python-dbus)
("setxkbmap" ,setxkbmap)
+ ("ucd" ,ucd)
+ ("unicode-cldr-common" ,unicode-cldr-common)
+ ("unicode-emoji" ,unicode-emoji)
("wayland" ,wayland)
- ("xmodmap" ,xmodmap)
- ("iso-codes" ,iso-codes)
- ("pygobject2" ,python-pygobject)
- ("python" ,python)))
+ ("xmodmap" ,xmodmap)))
(native-inputs
- `(("glib" ,glib "bin") ; for glib-genmarshal
+ `(("glib" ,glib "bin") ; for glib-genmarshal
("gettext" ,gettext-minimal)
+ ("gnome-common" ,gnome-common)
("gobject-introspection" ,gobject-introspection) ; for g-ir-compiler
- ("ucd" ,ucd)
- ("unicode-emoji" ,unicode-emoji)
- ("unicode-cldr-common" ,unicode-cldr-common)
+ ("perl" ,perl)
+ ("pkg-config" ,pkg-config)
+ ("python-wrapper" ,python-wrapper)
("vala" ,vala)
- ("pkg-config" ,pkg-config)))
+ ("which" ,which)))
(native-search-paths
(list (search-path-specification
(variable "IBUS_COMPONENT_PATH")
--
2.31.1
R
R
Raghav Gururajan wrote on 14 Apr 2021 13:53
[PATCH core-updates 3/4] gnu: ibus: Enable memconf.
(address . 47770@debbugs.gnu.org)(name . Raghav Gururajan)(address . rg@raghavgururajan.name)
20210414115349.14040-3-rg@raghavgururajan.name
* gnu/packages/ibus.scm (ibus)[configure-flags](enable-memconf): New flag.
---
gnu/packages/ibus.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (14 lines)
diff --git a/gnu/packages/ibus.scm b/gnu/packages/ibus.scm
index b6687239df..3f151d9cd7 100644
--- a/gnu/packages/ibus.scm
+++ b/gnu/packages/ibus.scm
@@ -80,6 +80,7 @@
#:parallel-build? #f ; race condition discovered with emoji support
#:configure-flags (list "--enable-python-library"
"--enable-gtk-doc"
+ "--enable-memconf"
(string-append
"--with-unicode-emoji-dir="
(assoc-ref %build-inputs "unicode-emoji")
--
2.31.1
R
R
Raghav Gururajan wrote on 14 Apr 2021 13:53
[PATCH core-updates 4/4] gnu: ibus: Enable tests.
(address . 47770@debbugs.gnu.org)(name . Raghav Gururajan)(address . rg@raghavgururajan.name)
20210414115349.14040-4-rg@raghavgururajan.name
* gnu/packages/ibus.scm (ibus)[arguments](tests): Remove argument.
(parallel-tests): New argument.
[patches](disable-failing-tests): New phase.
(pre-check): New phase.
[native-inputs]: Add xorg-server-for-tests.
---
gnu/packages/ibus.scm | 30 +++++++++++++++++++++++++++---
1 file changed, 27 insertions(+), 3 deletions(-)

Toggle diff (76 lines)
diff --git a/gnu/packages/ibus.scm b/gnu/packages/ibus.scm
index 3f151d9cd7..7e7d6c64d1 100644
--- a/gnu/packages/ibus.scm
+++ b/gnu/packages/ibus.scm
@@ -76,7 +76,7 @@
(build-system glib-or-gtk-build-system)
(outputs '("out" "doc"))
(arguments
- `(#:tests? #f ; tests fail because there's no connection to dbus
+ `(#:parallel-tests? #f
#:parallel-build? #f ; race condition discovered with emoji support
#:configure-flags (list "--enable-python-library"
"--enable-gtk-doc"
@@ -95,6 +95,14 @@
"--enable-wayland")
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'disable-failing-tests
+ (lambda _
+ ;; These tests require /etc/machine-id.
+ (with-directory-excursion "src/tests"
+ (substitute* '("ibus-share.c" "ibus-compose.c"
+ "ibus-keypress.c")
+ (("[ \t]*return g_test_run \\(\\);") "")))
+ #t))
(add-after 'unpack 'patch-docbook-xml
(lambda* (#:key inputs #:allow-other-keys)
(with-directory-excursion "docs/reference/ibus"
@@ -102,7 +110,7 @@
(("http://www.oasis-open.org/docbook/xml/4.1.2/")
(string-append (assoc-ref inputs "docbook-xml")
"/xml/dtd/docbook/"))))
- #t))
+ #t))
(add-after 'unpack 'patch-python-target-directories
(lambda* (#:key outputs #:allow-other-keys)
(let ((root (string-append (assoc-ref outputs "out")
@@ -139,6 +147,20 @@
(("\"(setxkbmap|xmodmap)\"" _ prog)
(string-append "\"" (assoc-ref inputs prog) "/bin/" prog "\"")))
#t))
+ (add-before 'check 'pre-check
+ (lambda _
+ ;; Tests write to $HOME.
+ (setenv "HOME" (getcwd))
+ ;; Tests look for $XDG_RUNTIME_DIR.
+ (setenv "XDG_RUNTIME_DIR" (getcwd))
+ ;; For missing '/etc/machine-id'.
+ (setenv "DBUS_FATAL_WARNINGS" "0")
+ ;; Tests require a running X server.
+ (system "Xvfb :1 +extension GLX &")
+ (setenv "DISPLAY" ":1")
+ ;; Tests require running iBus daemon.
+ (system "./bus/ibus-daemon --daemonize")
+ #t))
(add-after 'install 'move-doc
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -186,12 +208,14 @@
("gettext" ,gettext-minimal)
("gnome-common" ,gnome-common)
("gobject-introspection" ,gobject-introspection) ; for g-ir-compiler
+ ("gtk+:bin" ,gtk+ "bin")
("gtk-doc" ,gtk-doc)
("perl" ,perl)
("pkg-config" ,pkg-config)
("python-wrapper" ,python-wrapper)
("vala" ,vala)
- ("which" ,which)))
+ ("which" ,which)
+ ("xorg-server" ,xorg-server-for-tests)))
(native-search-paths
(list (search-path-specification
(variable "IBUS_COMPONENT_PATH")
--
2.31.1
R
R
Raghav Gururajan wrote on 14 Apr 2021 13:53
[PATCH core-updates 2/4] gnu: ibus: Enable documentation.
(address . 47770@debbugs.gnu.org)(name . Raghav Gururajan)(address . rg@raghavgururajan.name)
20210414115349.14040-2-rg@raghavgururajan.name
* gnu/packages/ibus.scm (ibus)[outputs](doc): New output.
[configure-flags](enable-gtk-doc): New flag.
[phases](patch-docbook-xml): New phase.
(move-doc): New phase.
[native-inputs]: Add docbook-xml and gtk-doc.
---
gnu/packages/ibus.scm | 24 +++++++++++++++++++++++-
1 file changed, 23 insertions(+), 1 deletion(-)

Toggle diff (72 lines)
diff --git a/gnu/packages/ibus.scm b/gnu/packages/ibus.scm
index e566993b08..b6687239df 100644
--- a/gnu/packages/ibus.scm
+++ b/gnu/packages/ibus.scm
@@ -42,6 +42,7 @@
#:use-module (gnu packages databases)
#:use-module (gnu packages datastructures)
#:use-module (gnu packages dbm)
+ #:use-module (gnu packages docbook)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
@@ -73,10 +74,12 @@
(base32
"07s2ly75xv50bqg37mn37i9akqvcfd45k2mbplxrsqk3a2b3mwxb"))))
(build-system glib-or-gtk-build-system)
+ (outputs '("out" "doc"))
(arguments
`(#:tests? #f ; tests fail because there's no connection to dbus
#:parallel-build? #f ; race condition discovered with emoji support
#:configure-flags (list "--enable-python-library"
+ "--enable-gtk-doc"
(string-append
"--with-unicode-emoji-dir="
(assoc-ref %build-inputs "unicode-emoji")
@@ -91,6 +94,14 @@
"--enable-wayland")
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch-docbook-xml
+ (lambda* (#:key inputs #:allow-other-keys)
+ (with-directory-excursion "docs/reference/ibus"
+ (substitute* "ibus-docs.sgml.in"
+ (("http://www.oasis-open.org/docbook/xml/4.1.2/")
+ (string-append (assoc-ref inputs "docbook-xml")
+ "/xml/dtd/docbook/"))))
+ #t))
(add-after 'unpack 'patch-python-target-directories
(lambda* (#:key outputs #:allow-other-keys)
(let ((root (string-append (assoc-ref outputs "out")
@@ -127,6 +138,15 @@
(("\"(setxkbmap|xmodmap)\"" _ prog)
(string-append "\"" (assoc-ref inputs prog) "/bin/" prog "\"")))
#t))
+ (add-after 'install 'move-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (doc (assoc-ref outputs "doc")))
+ (mkdir-p (string-append doc "/share"))
+ (rename-file
+ (string-append out "/share/gtk-doc")
+ (string-append doc "/share/gtk-doc"))
+ #t)))
(add-after 'wrap-program 'wrap-with-additional-paths
(lambda* (#:key outputs #:allow-other-keys)
;; Make sure 'ibus-setup' runs with the correct PYTHONPATH and
@@ -160,10 +180,12 @@
("wayland" ,wayland)
("xmodmap" ,xmodmap)))
(native-inputs
- `(("glib" ,glib "bin") ; for glib-genmarshal
+ `(("docbook-xml" ,docbook-xml-4.1.2)
+ ("glib" ,glib "bin") ; for glib-genmarshal
("gettext" ,gettext-minimal)
("gnome-common" ,gnome-common)
("gobject-introspection" ,gobject-introspection) ; for g-ir-compiler
+ ("gtk-doc" ,gtk-doc)
("perl" ,perl)
("pkg-config" ,pkg-config)
("python-wrapper" ,python-wrapper)
--
2.31.1
M
M
Maxime Devos wrote on 14 Apr 2021 23:21
45ef6247d0c39df7be8e0fce23d9b608921c12f5.camel@telenet.be
On Wed, 2021-04-14 at 07:53 -0400, Raghav Gururajan via Guix-patches via wrote:
Toggle quote (11 lines)
> #:phases
> (modify-phases %standard-phases
> + (add-after 'unpack 'patch-docbook-xml
> + (lambda* (#:key inputs #:allow-other-keys)
> + (with-directory-excursion "docs/reference/ibus"
> + (substitute* "ibus-docs.sgml.in"
> + (("http://www.oasis-open.org/docbook/xml/4.1.2/")
> + (string-append (assoc-ref inputs "docbook-xml")
> + "/xml/dtd/docbook/"))))
> + #t))

Letting a phase return #t isn't required anymore, and the warning has
been removed on core-updates (which this patch series is targetting.
The #t can be dropped now.

Toggle quote (8 lines)
> (add-after 'unpack 'patch-python-target-directories
> (lambda* (#:key outputs #:allow-other-keys)
> (let ((root (string-append (assoc-ref outputs "out")
> @@ -127,6 +138,15 @@
> (("\"(setxkbmap|xmodmap)\"" _ prog)
> (string-append "\"" (assoc-ref inputs prog) "/bin/" prog "\"")))
> #t))

While you're modifying the package anyway, you might as well drop this one too.
Toggle quote (9 lines)
> + (add-after 'install 'move-doc
> + (lambda* (#:key outputs #:allow-other-keys)
> + (let* ((out (assoc-ref outputs "out"))
> + (doc (assoc-ref outputs "doc")))
> + (mkdir-p (string-append doc "/share"))
> + (rename-file
> + (string-append out "/share/gtk-doc")
> + (string-append doc "/share/gtk-doc"))
> + #t)))
Likewise.

Warning: I didn't test this patch series.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYHdc6BccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7haoAQDKmCyPWhWpqEc8wIYQsD5qEnPo
qtp2RbFDvdl8wpDkAQEA2+xZ7fVIB3qS9V9hVdZe/QP14Dw4KB3dGzAgDjxD+wE=
=zzFE
-----END PGP SIGNATURE-----


M
M
Maxime Devos wrote on 14 Apr 2021 23:24
Re: [bug#47770] [PATCH core-updates 4/4] gnu: ibus: Enable tests.
332d1b73d42007218d6ec1224141b66152000d70.camel@telenet.be
On Wed, 2021-04-14 at 07:53 -0400, Raghav Gururajan via Guix-patches via wrote:
Toggle quote (20 lines)
> * gnu/packages/ibus.scm (ibus)[arguments](tests): Remove argument.
> (parallel-tests): New argument.
> [patches](disable-failing-tests): New phase.
> (pre-check): New phase.
> [native-inputs]: Add xorg-server-for-tests.
> ---
> gnu/packages/ibus.scm | 30 +++++++++++++++++++++++++++---
> 1 file changed, 27 insertions(+), 3 deletions(-)
>
> diff --git a/gnu/packages/ibus.scm b/gnu/packages/ibus.scm
> index 3f151d9cd7..7e7d6c64d1 100644
> --- a/gnu/packages/ibus.scm
> +++ b/gnu/packages/ibus.scm
> @@ -76,7 +76,7 @@
> (build-system glib-or-gtk-build-system)
> (outputs '("out" "doc"))
> (arguments
> - `(#:tests? #f ; tests fail because there's no connection to dbus
> + `(#:parallel-tests? #f

Why are parallel tests disabled? Please document!
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYHddjhccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7us5AQChgjapilYmiEtkAVbGBz821JY9
PAVvf3Ml96fTi1eH9QD/eWlOndt5JzghnFQeAtGJ8pqpSaaGAP7y1I8NsKK5jQs=
=xQfI
-----END PGP SIGNATURE-----


R
R
Raghav Gururajan wrote on 15 Apr 2021 14:28
[PATCH core-updates v2 2/5] gnu: ibus: Enable documentation.
(address . 47770@debbugs.gnu.org)(name . Raghav Gururajan)(address . rg@raghavgururajan.name)
20210415122902.2608-2-rg@raghavgururajan.name
* gnu/packages/ibus.scm (ibus)[outputs](doc): New output.
[configure-flags](enable-gtk-doc): New flag.
[phases](patch-docbook-xml): New phase.
(move-doc): New phase.
[native-inputs]: Add docbook-xml and gtk-doc.
---
gnu/packages/ibus.scm | 24 +++++++++++++++++++++++-
1 file changed, 23 insertions(+), 1 deletion(-)

Toggle diff (72 lines)
diff --git a/gnu/packages/ibus.scm b/gnu/packages/ibus.scm
index e566993b08..b6687239df 100644
--- a/gnu/packages/ibus.scm
+++ b/gnu/packages/ibus.scm
@@ -42,6 +42,7 @@
#:use-module (gnu packages databases)
#:use-module (gnu packages datastructures)
#:use-module (gnu packages dbm)
+ #:use-module (gnu packages docbook)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
@@ -73,10 +74,12 @@
(base32
"07s2ly75xv50bqg37mn37i9akqvcfd45k2mbplxrsqk3a2b3mwxb"))))
(build-system glib-or-gtk-build-system)
+ (outputs '("out" "doc"))
(arguments
`(#:tests? #f ; tests fail because there's no connection to dbus
#:parallel-build? #f ; race condition discovered with emoji support
#:configure-flags (list "--enable-python-library"
+ "--enable-gtk-doc"
(string-append
"--with-unicode-emoji-dir="
(assoc-ref %build-inputs "unicode-emoji")
@@ -91,6 +94,14 @@
"--enable-wayland")
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch-docbook-xml
+ (lambda* (#:key inputs #:allow-other-keys)
+ (with-directory-excursion "docs/reference/ibus"
+ (substitute* "ibus-docs.sgml.in"
+ (("http://www.oasis-open.org/docbook/xml/4.1.2/")
+ (string-append (assoc-ref inputs "docbook-xml")
+ "/xml/dtd/docbook/"))))
+ #t))
(add-after 'unpack 'patch-python-target-directories
(lambda* (#:key outputs #:allow-other-keys)
(let ((root (string-append (assoc-ref outputs "out")
@@ -127,6 +138,15 @@
(("\"(setxkbmap|xmodmap)\"" _ prog)
(string-append "\"" (assoc-ref inputs prog) "/bin/" prog "\"")))
#t))
+ (add-after 'install 'move-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (doc (assoc-ref outputs "doc")))
+ (mkdir-p (string-append doc "/share"))
+ (rename-file
+ (string-append out "/share/gtk-doc")
+ (string-append doc "/share/gtk-doc"))
+ #t)))
(add-after 'wrap-program 'wrap-with-additional-paths
(lambda* (#:key outputs #:allow-other-keys)
;; Make sure 'ibus-setup' runs with the correct PYTHONPATH and
@@ -160,10 +180,12 @@
("wayland" ,wayland)
("xmodmap" ,xmodmap)))
(native-inputs
- `(("glib" ,glib "bin") ; for glib-genmarshal
+ `(("docbook-xml" ,docbook-xml-4.1.2)
+ ("glib" ,glib "bin") ; for glib-genmarshal
("gettext" ,gettext-minimal)
("gnome-common" ,gnome-common)
("gobject-introspection" ,gobject-introspection) ; for g-ir-compiler
+ ("gtk-doc" ,gtk-doc)
("perl" ,perl)
("pkg-config" ,pkg-config)
("python-wrapper" ,python-wrapper)
--
2.31.1
R
R
Raghav Gururajan wrote on 15 Apr 2021 14:29
[PATCH core-updates v2 3/5] gnu: ibus: Enable memconf.
(address . 47770@debbugs.gnu.org)(name . Raghav Gururajan)(address . rg@raghavgururajan.name)
20210415122902.2608-3-rg@raghavgururajan.name
* gnu/packages/ibus.scm (ibus)[configure-flags](enable-memconf): New flag.
---
gnu/packages/ibus.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (14 lines)
diff --git a/gnu/packages/ibus.scm b/gnu/packages/ibus.scm
index b6687239df..3f151d9cd7 100644
--- a/gnu/packages/ibus.scm
+++ b/gnu/packages/ibus.scm
@@ -80,6 +80,7 @@
#:parallel-build? #f ; race condition discovered with emoji support
#:configure-flags (list "--enable-python-library"
"--enable-gtk-doc"
+ "--enable-memconf"
(string-append
"--with-unicode-emoji-dir="
(assoc-ref %build-inputs "unicode-emoji")
--
2.31.1
R
R
Raghav Gururajan wrote on 15 Apr 2021 14:29
[PATCH core-updates v2 4/5] gnu: ibus: Enable tests.
(address . 47770@debbugs.gnu.org)(name . Raghav Gururajan)(address . rg@raghavgururajan.name)
20210415122902.2608-4-rg@raghavgururajan.name
* gnu/packages/ibus.scm (ibus)[arguments](tests): Remove argument.
(parallel-tests): New argument.
[patches](disable-failing-tests): New phase.
(pre-check): New phase.
[native-inputs]: Add xorg-server-for-tests.
---
gnu/packages/ibus.scm | 31 +++++++++++++++++++++++++++----
1 file changed, 27 insertions(+), 4 deletions(-)

Toggle diff (77 lines)
diff --git a/gnu/packages/ibus.scm b/gnu/packages/ibus.scm
index 3f151d9cd7..fa12499bb9 100644
--- a/gnu/packages/ibus.scm
+++ b/gnu/packages/ibus.scm
@@ -76,8 +76,7 @@
(build-system glib-or-gtk-build-system)
(outputs '("out" "doc"))
(arguments
- `(#:tests? #f ; tests fail because there's no connection to dbus
- #:parallel-build? #f ; race condition discovered with emoji support
+ `(#:parallel-build? #f ; race condition discovered with emoji support
#:configure-flags (list "--enable-python-library"
"--enable-gtk-doc"
"--enable-memconf"
@@ -95,6 +94,14 @@
"--enable-wayland")
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'disable-failing-tests
+ (lambda _
+ ;; These tests require /etc/machine-id.
+ (with-directory-excursion "src/tests"
+ (substitute* '("ibus-share.c" "ibus-compose.c"
+ "ibus-keypress.c")
+ (("[ \t]*return g_test_run \\(\\);") "")))
+ #t))
(add-after 'unpack 'patch-docbook-xml
(lambda* (#:key inputs #:allow-other-keys)
(with-directory-excursion "docs/reference/ibus"
@@ -102,7 +109,7 @@
(("http://www.oasis-open.org/docbook/xml/4.1.2/")
(string-append (assoc-ref inputs "docbook-xml")
"/xml/dtd/docbook/"))))
- #t))
+ #t))
(add-after 'unpack 'patch-python-target-directories
(lambda* (#:key outputs #:allow-other-keys)
(let ((root (string-append (assoc-ref outputs "out")
@@ -139,6 +146,20 @@
(("\"(setxkbmap|xmodmap)\"" _ prog)
(string-append "\"" (assoc-ref inputs prog) "/bin/" prog "\"")))
#t))
+ (add-before 'check 'pre-check
+ (lambda _
+ ;; Tests write to $HOME.
+ (setenv "HOME" (getcwd))
+ ;; Tests look for $XDG_RUNTIME_DIR.
+ (setenv "XDG_RUNTIME_DIR" (getcwd))
+ ;; For missing '/etc/machine-id'.
+ (setenv "DBUS_FATAL_WARNINGS" "0")
+ ;; Tests require a running X server.
+ (system "Xvfb :1 +extension GLX &")
+ (setenv "DISPLAY" ":1")
+ ;; Tests require running iBus daemon.
+ (system "./bus/ibus-daemon --daemonize")
+ #t))
(add-after 'install 'move-doc
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -186,12 +207,14 @@
("gettext" ,gettext-minimal)
("gnome-common" ,gnome-common)
("gobject-introspection" ,gobject-introspection) ; for g-ir-compiler
+ ("gtk+:bin" ,gtk+ "bin")
("gtk-doc" ,gtk-doc)
("perl" ,perl)
("pkg-config" ,pkg-config)
("python-wrapper" ,python-wrapper)
("vala" ,vala)
- ("which" ,which)))
+ ("which" ,which)
+ ("xorg-server" ,xorg-server-for-tests)))
(native-search-paths
(list (search-path-specification
(variable "IBUS_COMPONENT_PATH")
--
2.31.1
R
R
Raghav Gururajan wrote on 15 Apr 2021 14:28
[PATCH core-updates v2 1/5] gnu: ibus: Update to 1.5.24.
(address . 47770@debbugs.gnu.org)(name . Raghav Gururajan)(address . rg@raghavgururajan.name)
20210415122902.2608-1-rg@raghavgururajan.name
* gnu/packages/ibus.scm (ibus)[version]: Update to 1.5.24.
[inputs]: Add glib, libxkbcommon, libxtst and python-dbus. Move
ucd, unicode-cldr-common and unicode-emoji from ...
[native-inputs]: ... here. Add gnome-common, perl, python-wrapper
and which.
---
gnu/packages/ibus.scm | 35 +++++++++++++++++++++++------------
1 file changed, 23 insertions(+), 12 deletions(-)

Toggle diff (83 lines)
diff --git a/gnu/packages/ibus.scm b/gnu/packages/ibus.scm
index fc59ea1c6b..e566993b08 100644
--- a/gnu/packages/ibus.scm
+++ b/gnu/packages/ibus.scm
@@ -49,18 +49,21 @@
#:use-module (gnu packages gtk)
#:use-module (gnu packages iso-codes)
#:use-module (gnu packages logging)
+ #:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-xyz)
#:use-module (gnu packages serialization)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages textutils)
#:use-module (gnu packages unicode)
- #:use-module (gnu packages xorg))
+ #:use-module (gnu packages xorg)
+ #:use-module (gnu packages xdisorg))
(define-public ibus
(package
(name "ibus")
- (version "1.5.22")
+ (version "1.5.24")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/ibus/ibus/"
@@ -68,7 +71,7 @@
version "/ibus-" version ".tar.gz"))
(sha256
(base32
- "0jmy2w01phpmqnjnfnak7nvfna57mpgfnl87jwc4iai8ijjynw41"))))
+ "07s2ly75xv50bqg37mn37i9akqvcfd45k2mbplxrsqk3a2b3mwxb"))))
(build-system glib-or-gtk-build-system)
(arguments
`(#:tests? #f ; tests fail because there's no connection to dbus
@@ -138,26 +141,34 @@
(inputs
`(("dbus" ,dbus)
("dconf" ,dconf)
+ ("glib" ,glib)
("gtk2" ,gtk+-2)
("gtk+" ,gtk+)
+ ("iso-codes" ,iso-codes)
("json-glib" ,json-glib)
("libnotify" ,libnotify)
("libx11" ,libx11)
+ ("libxkbcommon" ,libxkbcommon)
+ ("libxtst" ,libxtst)
+ ("pygobject" ,python-pygobject)
+ ("python" ,python)
+ ("python-dbus" ,python-dbus)
("setxkbmap" ,setxkbmap)
+ ("ucd" ,ucd)
+ ("unicode-cldr-common" ,unicode-cldr-common)
+ ("unicode-emoji" ,unicode-emoji)
("wayland" ,wayland)
- ("xmodmap" ,xmodmap)
- ("iso-codes" ,iso-codes)
- ("pygobject2" ,python-pygobject)
- ("python" ,python)))
+ ("xmodmap" ,xmodmap)))
(native-inputs
- `(("glib" ,glib "bin") ; for glib-genmarshal
+ `(("glib" ,glib "bin") ; for glib-genmarshal
("gettext" ,gettext-minimal)
+ ("gnome-common" ,gnome-common)
("gobject-introspection" ,gobject-introspection) ; for g-ir-compiler
- ("ucd" ,ucd)
- ("unicode-emoji" ,unicode-emoji)
- ("unicode-cldr-common" ,unicode-cldr-common)
+ ("perl" ,perl)
+ ("pkg-config" ,pkg-config)
+ ("python-wrapper" ,python-wrapper)
("vala" ,vala)
- ("pkg-config" ,pkg-config)))
+ ("which" ,which)))
(native-search-paths
(list (search-path-specification
(variable "IBUS_COMPONENT_PATH")
--
2.31.1
R
R
Raghav Gururajan wrote on 15 Apr 2021 14:29
[PATCH core-updates v2 5/5] gnu: ibus: Remove trailing #t in phases.
(address . 47770@debbugs.gnu.org)(name . Raghav Gururajan)(address . rg@raghavgururajan.name)
20210415122902.2608-5-rg@raghavgururajan.name
* gnu/packages/ibus.scm (ibus)[phases]: Remove trailing #t.
---
gnu/packages/ibus.scm | 27 +++++++++------------------
1 file changed, 9 insertions(+), 18 deletions(-)

Toggle diff (91 lines)
diff --git a/gnu/packages/ibus.scm b/gnu/packages/ibus.scm
index fa12499bb9..cdd4708d22 100644
--- a/gnu/packages/ibus.scm
+++ b/gnu/packages/ibus.scm
@@ -100,16 +100,14 @@
(with-directory-excursion "src/tests"
(substitute* '("ibus-share.c" "ibus-compose.c"
"ibus-keypress.c")
- (("[ \t]*return g_test_run \\(\\);") "")))
- #t))
+ (("[ \t]*return g_test_run \\(\\);") "")))))
(add-after 'unpack 'patch-docbook-xml
(lambda* (#:key inputs #:allow-other-keys)
(with-directory-excursion "docs/reference/ibus"
(substitute* "ibus-docs.sgml.in"
(("http://www.oasis-open.org/docbook/xml/4.1.2/")
(string-append (assoc-ref inputs "docbook-xml")
- "/xml/dtd/docbook/"))))
- #t))
+ "/xml/dtd/docbook/"))))))
(add-after 'unpack 'patch-python-target-directories
(lambda* (#:key outputs #:allow-other-keys)
(let ((root (string-append (assoc-ref outputs "out")
@@ -120,13 +118,11 @@
(("(py2?overridesdir)=.*" _ var)
(string-append var "=" root "/gi/overrides/"))
(("(pkgpython2dir=).*" _ var)
- (string-append var root "/ibus"))))
- #t))
+ (string-append var root "/ibus"))))))
(add-before 'configure 'disable-dconf-update
(lambda _
(substitute* "data/dconf/Makefile.in"
- (("dconf update") "echo dconf update"))
- #t))
+ (("dconf update") "echo dconf update"))))
(add-after 'unpack 'delete-generated-files
(lambda _
(for-each (lambda (file)
@@ -134,8 +130,7 @@
(when (file-exists? c)
(format #t "deleting ~a\n" c)
(delete-file c))))
- (find-files "." "\\.vala"))
- #t))
+ (find-files "." "\\.vala"))))
(add-after 'unpack 'fix-paths
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "src/ibusenginesimple.c"
@@ -144,8 +139,7 @@
"/share/X11/locale")))
(substitute* "ui/gtk3/xkblayout.vala"
(("\"(setxkbmap|xmodmap)\"" _ prog)
- (string-append "\"" (assoc-ref inputs prog) "/bin/" prog "\"")))
- #t))
+ (string-append "\"" (assoc-ref inputs prog) "/bin/" prog "\"")))))
(add-before 'check 'pre-check
(lambda _
;; Tests write to $HOME.
@@ -158,8 +152,7 @@
(system "Xvfb :1 +extension GLX &")
(setenv "DISPLAY" ":1")
;; Tests require running iBus daemon.
- (system "./bus/ibus-daemon --daemonize")
- #t))
+ (system "./bus/ibus-daemon --daemonize")))
(add-after 'install 'move-doc
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -167,8 +160,7 @@
(mkdir-p (string-append doc "/share"))
(rename-file
(string-append out "/share/gtk-doc")
- (string-append doc "/share/gtk-doc"))
- #t)))
+ (string-append doc "/share/gtk-doc")))))
(add-after 'wrap-program 'wrap-with-additional-paths
(lambda* (#:key outputs #:allow-other-keys)
;; Make sure 'ibus-setup' runs with the correct PYTHONPATH and
@@ -178,8 +170,7 @@
`("GUIX_PYTHONPATH" ":" prefix (,(getenv "GUIX_PYTHONPATH")))
`("GI_TYPELIB_PATH" ":" prefix
(,(getenv "GI_TYPELIB_PATH")
- ,(string-append out "/lib/girepository-1.0")))))
- #t)))))
+ ,(string-append out "/lib/girepository-1.0"))))))))))
(inputs
`(("dbus" ,dbus)
("dconf" ,dconf)
--
2.31.1
R
R
Raghav Gururajan wrote on 15 Apr 2021 14:31
Re: [bug#47770] [PATCH core-updates 2/4] gnu: ibus: Enable documentation.
35231900-ce0c-5488-457a-87ed5f50d269@raghavgururajan.name
Hi Maxime!

Toggle quote (36 lines)
> On Wed, 2021-04-14 at 07:53 -0400, Raghav Gururajan via Guix-patches via wrote:
>> #:phases
>> (modify-phases %standard-phases
>> + (add-after 'unpack 'patch-docbook-xml
>> + (lambda* (#:key inputs #:allow-other-keys)
>> + (with-directory-excursion "docs/reference/ibus"
>> + (substitute* "ibus-docs.sgml.in"
>> + (("http://www.oasis-open.org/docbook/xml/4.1.2/")
>> + (string-append (assoc-ref inputs "docbook-xml")
>> + "/xml/dtd/docbook/"))))
>> + #t))
>
> Letting a phase return #t isn't required anymore, and the warning has
> been removed on core-updates (which this patch series is targetting.
> The #t can be dropped now.
>
>> (add-after 'unpack 'patch-python-target-directories
>> (lambda* (#:key outputs #:allow-other-keys)
>> (let ((root (string-append (assoc-ref outputs "out")
>> @@ -127,6 +138,15 @@
>> (("\"(setxkbmap|xmodmap)\"" _ prog)
>> (string-append "\"" (assoc-ref inputs prog) "/bin/" prog "\"")))
>> #t))
>
> While you're modifying the package anyway, you might as well drop this one too.
>> + (add-after 'install 'move-doc
>> + (lambda* (#:key outputs #:allow-other-keys)
>> + (let* ((out (assoc-ref outputs "out"))
>> + (doc (assoc-ref outputs "doc")))
>> + (mkdir-p (string-append doc "/share"))
>> + (rename-file
>> + (string-append out "/share/gtk-doc")
>> + (string-append doc "/share/gtk-doc"))
>> + #t)))
> Likewise.

I have removed #t in v2.

Regards,
RG.
Attachment: OpenPGP_signature
R
R
Raghav Gururajan wrote on 15 Apr 2021 14:33
Re: [bug#47770] [PATCH core-updates 4/4] gnu: ibus: Enable tests.
ee58e71f-cdff-d717-47f8-8551bb65c1c5@raghavgururajan.name
Hi Maxime!

Toggle quote (2 lines)
> Why are parallel tests disabled? Please document!

I was testing with it to see any difference, but forgot to remove it at
the end. Excluded it in v2.

Regards,
RG.
Attachment: OpenPGP_signature
R
Closed
?