[PATCH] gnu: Add seatd.

  • Done
  • quality assurance status badge
Details
3 participants
  • guixuser6392
  • Maxime Devos
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
guixuser6392
Severity
normal
Merged with
G
G
guixuser6392 wrote on 13 Apr 2021 15:45
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
kg70plrfIYk953CSJvLS-mK18mf3Fct93nx9fLjUB2CZvhfRfWfnYOa2MtLBPpmvNDBePVSxZtPTAZfg8E-W_w2fMZnzMU5jAf_ANmDub_0=@protonmail.com
Hello, Guix!

This patch adds a single package definition for a minimal seat management daemon (seatd), and a universal seat management library (libseat), under the name of `seatd'.

Regards,
pineapples
From 6dce6e93197bd911e136e345a7d6acfe711ecef3 Mon Sep 17 00:00:00 2001
From: pineapples <guixuser6392@protonmail.com>
Date: Tue, 13 Apr 2021 15:12:53 +0200
Subject: [PATCH] gnu: Add seatd.

* gnu/packages/freedesktop.scm (seatd): New variable.
---
gnu/packages/freedesktop.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 40d41350ac..36002fcf04 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -23,6 +23,7 @@
;;; Copyright © 2020 Anders Thuné <asse.97@gmail.com>
;;; Copyright © 2020 Raghav Gururajan <raghavgururajan@disroot.org>
;;; Copyright © 2021 Brendan Tildesley <mail@brendan.scot>
+;;; Copyright © 2021 pineapples <guixuser6392@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -825,6 +826,36 @@ GNOME Shell. The @command{localectl} command-line tool allows you to interact
with localed. This package is extracted from the broader systemd package.")
(license license:lgpl2.1+)))
+(define-public seatd
+ (package
+ (name "seatd")
+ (version "0.5.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~kennylevinsen/seatd")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1kglq8v4rnr3415mfaghyv2s2f8mxsy5s881gmm2908ig4n4j297"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:configure-flags '("-Dlogind=enabled")))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("scdoc" ,scdoc)))
+ (inputs
+ `(("elogind" ,elogind)))
+ (home-page "https://sr.ht/~kennylevinsen/seatd")
+ (synopsis "Seat management daemon and library")
+ (description
+ "This package provides a minimal seat management daemon whose task is to
+mediate access to shared devices, such as graphics and input, for applications
+that require it. It also provides a universal seat management library that
+allows applications to use whatever seat management is available.")
+ (license license:expat)))
+
(define-public packagekit
(package
(name "packagekit")
--
2.31.1
G
G
guixuser6392 wrote on 13 Apr 2021 15:57
(name . 47751@debbugs.gnu.org)(address . 47751@debbugs.gnu.org)
rHcIL2gL6epxhr1AMqorTUHS-sTDY-Zp5kZaW18qs5Zj2KDopwaRZ9seDM39JKiDgHkrhgWQDSdEuGITcvil_ZVHQFBcw4uaxzXphvV9dKk=@protonmail.com
Hello,

I have accidentally sent my patch twice. May someone please close this duplicate ticket?

I am sorry for this.

Regards,
pineapples
T
T
Tobias Geerinckx-Rice wrote on 13 Apr 2021 16:45
(no subject)
(address . control@debbugs.gnu.org)
87y2dmdyzo.fsf@nckx
merge 47750 47751
M
M
Maxime Devos wrote on 13 Apr 2021 19:57
Re: [bug#47751] [PATCH] gnu: Add seatd.
(name . 47751-done@debbugs.gnu.org)(address . 47751-done@debbugs.gnu.org)
28f87b48a63a4cf3df3afe72f6e667bdeb4e1698.camel@telenet.be
On Tue, 2021-04-13 at 13:57 +0000, guixuser6392 via Guix-patches via wrote:
Toggle quote (3 lines)
> Hello,
>
> I have accidentally sent my patch twice. May someone please close this duplicate ticket?
Closed. You can close issues yourself by writing
a mail to BUGNUMBER-done@debbugs.gnu.org

There's information on debbugs here: https://debbugs.gnu.org/server-control.html

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYHXbmxccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7rVWAQD02al+gJtpbK5KJ4Eejfpf9ITa
13BlQCLtG2LHYm81GwEAxevwNjUS2GHdyBdTCdXaL6+XALuCkooWNm9/eE5vOA0=
=4A9i
-----END PGP SIGNATURE-----


Closed
T
T
Tobias Geerinckx-Rice wrote on 13 Apr 2021 20:15
Re: bug#47751: [PATCH] gnu: Add seatd.
(name . Maxime Devos)(address . maximedevos@telenet.be)
87sg3udpar.fsf@nckx
Hi,

It's better to merge identical bugs than to keep duplicates in
potentially different states (‘is The Seatd Bug open or closed?’
‘both’).

I merged them by sending

merge 47750 47751

to control@debbugs.gnu.org.

Both numbers effectively refer to the same bug after that, so
closing 47751 did not have the effect you expected. I've reopened
it.

Kind regards,

T G-R
-----BEGIN PGP SIGNATURE-----

iIMEARYKACsWIQT12iAyS4c9C3o4dnINsP+IT1VteQUCYHXfrA0cbWVAdG9iaWFz
LmdyAAoJEA2w/4hPVW15v9YBALID5rbLOJlRx5SH2WK6hDWdoqYodH7vLblvyrmv
hIpmAQD0EhCVhBTqciSh1EBP/64nczw5Dd68jRWQvt5Smu7vAw==
=J4nn
-----END PGP SIGNATURE-----

M
M
Maxime Devos wrote on 13 Apr 2021 21:45
(name . Tobias Geerinckx-Rice)(address . me@tobias.gr)(name . 47751@debbugs.gnu.org)(address . 47751-done@debbugs.gnu.org)
3ed0191f2c14a2ddac898689b989c0dfc5bb5ac2.camel@telenet.be
On Tue, 2021-04-13 at 20:15 +0200, Tobias Geerinckx-Rice wrote:
Toggle quote (15 lines)
> Hi,
>
> It's better to merge identical bugs than to keep duplicates in
> potentially different states (‘is The Seatd Bug open or closed?’
> ‘both’).
>
> I merged them by sending
>
> merge 47750 47751
>
> to control@debbugs.gnu.org.
>
> Both numbers effectively refer to the same bug after that, so
> closing 47751 did not have the effect you expected.

I noticed, and tried to reopen the bug, but I sent the mail to the
reopened the wrong bug (#47551) -- actually a no-op, since that bug
was already open.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYHX00xccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7sK8AP0WZcJZ8b3LJR6n0CrvP4lcrMNs
8AEnMvxmits7dcMkowEAmyEh+ROEP4yvDXCpvPI/bRds0jlv0Acv2DZGBdmwyQc=
=sitP
-----END PGP SIGNATURE-----


Closed
T
T
Tobias Geerinckx-Rice wrote on 13 Apr 2021 21:54
(name . Maxime Devos)(address . maximedevos@telenet.be)(name . 47751@debbugs.gnu.org)(address . 47751@debbugs.gnu.org)
87k0p6dkop.fsf@nckx
Maxime,

Thanks for clearing that up!

Make sure to remove -done from the bug address when replying[0].

Kind regards,

T G-R

-----BEGIN PGP SIGNATURE-----

iIMEARYKACsWIQT12iAyS4c9C3o4dnINsP+IT1VteQUCYHX3Bg0cbWVAdG9iaWFz
LmdyAAoJEA2w/4hPVW151lQBAIAXRSPlWP2M2kjuvqLZHCAcP6616h3oHLRnmtEX
xEt9AP4vQJk9X4a9CzBhj3E5kM0vwtCZvLSnnnJTOUkxEVIpBg==
=kk50
-----END PGP SIGNATURE-----

G
G
guixuser6392 wrote on 1 May 2021 15:22
Re: [PATCH] gnu: Add seatd.
(name . 47751@debbugs.gnu.org)(address . 47751@debbugs.gnu.org)
UtCR4gfKM1Pp7SfZclZLMyZBZ8mTexjI4yWmhwfVfCc4aRuM1URUT-9pcYVrT9-ecnf7BXluIqRKmsRlo2JAZOi__V7wqrabKNdHHA7sTOU=@protonmail.com
I would like to ask patch reviewers and those with commit access to not accept this patch as-is, as I will be migrating to an email-driven git workflow friendly email provider in the upcoming days, and I want the new email address to be used instead.

I will update the patch as soon as the migration is complete.

Regards,
pineapples
?