[PATCH] gnu: Add sbcl-bodge-queue.

  • Done
  • quality assurance status badge
Details
3 participants
  • Guillaume Le Vaillant
  • Adam Kandur
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Adam Kandur
Severity
normal
A
A
Adam Kandur wrote on 12 Apr 2021 16:37
(name . Guix Patches)(address . guix-patches@gnu.org)
MY5W6tU--3-2@tuta.io
From 5ad8fb5f87ab91feaf99a30f8a823857feabfb63 Mon Sep 17 00:00:00 2001
From: Adam Kandur <rndd@tuta.io>
Date: Mon, 12 Apr 2021 17:35:19 +0300
Subject: [PATCH] gnu: Add sbcl-bodge-queue.

* gnu/packages/lisp-xyz.scm (sbcl-bodge-queue): New variable.
---
 gnu/packages/lisp-xyz.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 1d8e0b4..8fdea54 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -161,6 +161,34 @@ collection.")
 (define-public cl-bodge-utilities
   (sbcl-package->cl-source-package sbcl-bodge-utilities))
 
+(define-public sbcl-bodge-queue
+  (package
+    (name "sbcl-bodge-queue")
+    (version "stable")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/borodust/bodge-queue")
+             (commit version)))
+       (file-name (git-file-name "bodge-queue" version))
+       (sha256
+        (base32 "0f4252i8pfy5s4v7w1bpjawysn4cw7di405mqsx2h7skv27hvpz6"))))
+    (build-system asdf-build-system/sbcl)
+    (arguments
+     `(#:asd-files '("bodge-queue.asd")
+       #:asd-systems '("bodge-queue")))
+    (home-page "https://github.com/borodust/bodge-queue")
+    (synopsis "FIFO, not FIFA")
+    (description "Simple FIFO implementation with no external dependencies")
+    (license license:expat)))
+
+(define-public cl-bodge-queue
+  (sbcl-package->cl-source-package sbcl-bodge-queue))
+
+(define-public ecl-bodge-queue
+  (sbcl-package->ecl-package sbcl-bodge-queue))
+
 (define-public sbcl-golden-utils
   (let ((commit "62a5cb948a011eb26e7a89f56d5839a3334b4100")
         (revision "2"))
--
2.31.1
G
G
Guillaume Le Vaillant wrote on 12 Apr 2021 17:09
(name . Adam Kandur)(address . rndd@tuta.io)(address . 47728-done@debbugs.gnu.org)
87y2dn4k05.fsf@yamatai
Patch pushed as c1ed3b048d6644b70221eac2dc9b67420a999462 with some
modifications.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYHRiug8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j/hbwEAl3rgkIInE47V3lfGirOxRmF76aOJLHKR2Zk+
Idk1+QQA/iXl8FJM4bHHPo87jFNoz7uUBGmMy6rcEr4/65es010v
=P5G/
-----END PGP SIGNATURE-----

Closed
A
A
Adam Kandur wrote on 12 Apr 2021 17:31
newbe question
(address . 47728@debbugs.gnu.org)
MY5hP7v--3-2@tuta.io
why you have added sbcl-fiveam to native inputs?
G
G
Guillaume Le Vaillant wrote on 12 Apr 2021 18:39
(name . Adam Kandur)(address . rndd@tuta.io)(address . 47728@debbugs.gnu.org)
87v98r4fu3.fsf@yamatai
Adam Kandur via Guix-patches via <guix-patches@gnu.org> skribis:

Toggle quote (2 lines)
> why you have added sbcl-fiveam to native inputs?

In the asd file, the "bodge-queue/tests" system for the tests depends on
fiveam. As the tests are run only at build time, their dependencies are
only required at build time and not at run time, so we put them in
'native-inputs' instead of 'inputs'.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYHR31A8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j8MzwEAngp4NesGZ+0WsQzi4UEkxNuK3MPBU+/dlC+L
kHK3Df8A/RGiS+5GvVobNolDouTm7gbRngJwhP8QjK2ccn+ge8F8
=SEoP
-----END PGP SIGNATURE-----

S
S
Sharlatan Hellseher wrote on 12 Apr 2021 21:41
(address . 47728@debbugs.gnu.org)
CAO+9K5q8ukkFqRjwsTb2LFcBrxznsmvKS9w+zvosMzB==J24qw@mail.gmail.com
@Adam Kandur
Are you planning to pack https://github.com/borodust/bodge-concurrencyas well?
I put to my queue to pack https://github.com/borodust/cl-bodge,if you
are on the same way let's distribute efforts :)
I update my progress her
--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
G
G
Guillaume Le Vaillant wrote on 12 Apr 2021 22:38
(name . Adam Kandur)(address . rndd@tuta.io)(address . 47728@debbugs.gnu.org)
87sg3v44t0.fsf@yamatai
Adam Kandur <rndd@tuta.io> skribis:

Toggle quote (4 lines)
> also, you wrote "fiveam" ,sbcl-fiveam
>
> why not "sbcl-fiveam" ,sbcl-fiveam

It's because of the cl-xxx and ecl-xxx packages that are created by
transforming the definition of the sbcl-xxx package to use cl-* or ecl-*
packages as inputs instead of sbcl-*.

If the sbcl-xxx package has '("sbcl-fiveam" ,sbcl-fiveam)' as input,
after transformation the ecl-xxx package will have
'("sbcl-fiveam" ,ecl-fiveam)' as inputs, which looks strange (but it
will work anyway as the string is just used to reference an input in
custom phases using something like '(assoc-ref inputs "sbcl-xxx")').

By using just "fiveam" as string, the sbcl-xxx package has
'("fiveam" ,sbcl-fiveam)' as input, and the ecl-xxx package will have
'("fiveam" ,ecl-fiveam)'.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYHSvqw8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j82BQD9Fso1wfVwQzOYeeBC8GDIm73LQKRfXcvjbl9c
EFA2u+kBAKeqkALjJL7PqzVCB3JFvju+/cMkwDZgibjZAjfrdgq7
=uCNx
-----END PGP SIGNATURE-----

?