guix on foreign distro won't upgrade, stuck on old commits

  • Done
  • quality assurance status badge
Details
2 participants
  • Brian Zwahr
  • Leo Famulari
Owner
unassigned
Submitted by
Brian Zwahr
Severity
normal
B
B
Brian Zwahr wrote on 7 Apr 2021 22:19
(address . bug-guix@gnu.org)
65N7RQ.W0VO8QJ1XR662@echosa.net
Hi! It was suggested I email this in by someone in the IRC channel. I'm
having an issue where guix always tells me it is "X days old" and that
I should run guix pull/guix upgrade. However, running these commands
does not fix the issue.

guix describe shows:

```
$ guix describe
Generation 9 Mar 25 2021 08:36:11 (current)
guix 3f1b2bd
branch: master
commit: 3f1b2bd322b6cdba99a43d08e5e8464f7424cbc5
```

Which is, indeed, out of date. IRC folks recommended checking the git
status, so I did:

```
~/.cache/guix/checkouts/pjmkglp4t7znuugeurpurzikxq3tnlaywmisyr27shj7apsnalwq
(master) $ git status
On branch master
Your branch is behind 'origin/master' by 474 commits, and can be
fast-forwarded.
(use "git pull" to update your local branch)

nothing to commit, working tree clean
```

It is, indeed, out of date, but after a guix pull:

```
$ guix pull
Updating channel 'guix' from Git repository at
Building from this channel:
Computing Guix derivation for 'x86_64-linux'... |
nothing to be done
```

It doesn't update and still tells me I'm out of date:

```
$ guix upgrade
guix upgrade: warning: Your Guix installation is 13 days old.
guix upgrade: warning: Consider running 'guix pull' followed by
'guix package -u' to get up-to-date packages and security updates.
```

It was suggested that I should run this command:

```
guix pull --commit=02297d3fe680371a4b97b9c1b770932cbdd55615
```

and after doing so, I was then only 1 commit behind instead:

```
~/.cache/guix/checkouts/pjmkglp4t7znuugeurpurzikxq3tnlaywmisyr27shj7apsnalwq
(master) $ git status
On branch master
Your branch is behind 'origin/master' by 1 commit, and can be
fast-forwarded.
(use "git pull" to update your local branch)

nothing to commit, working tree clean
```

However, `guix pull` now gives me a new error about needing to
downgrade:

```
$ guix pull
Updating channel 'guix' from Git repository at
guix pull: error: aborting update of channel 'guix' to commit
3f1b2bd322b6cdba99a43d08e5e8464f7424cbc5, which is not a descendant of
02297d3fe680371a4b97b9c1b770932cbdd55615
hint: Use `--allow-downgrades' to force this downgrade.
```

and for some reason, I'm back to being almost 500 commits behind again:

```
~/.cache/guix/checkouts/pjmkglp4t7znuugeurpurzikxq3tnlaywmisyr27shj7apsnalwq
(master) $ git status
On branch master
Your branch is behind 'origin/master' by 477 commits, and can be
fast-forwarded.
(use "git pull" to update your local branch)

nothing to commit, working tree clean
```

even though `guix describe` now seems to be more up-to-date (apr 7
instead or mar 25)

```
$ guix describe
Generation 10 Apr 07 2021 14:38:16 (current)
guix 02297d3
commit: 02297d3fe680371a4b97b9c1b770932cbdd55615
```

As a final attempt to solve this, it was suggested that I run `guix
pull -l 2>&1 | tee pull-generations.log` and email it to this list. I'm
attaching that file here.

Also, after running that command, I'm back to being only 1 commit
behind and still get the downgrade error from `guix pull`:

```
~/.cache/guix/checkouts/pjmkglp4t7znuugeurpurzikxq3tnlaywmisyr27shj7apsnalwq
(master) $ git status
On branch master
Your branch is behind 'origin/master' by 1 commit, and can be
fast-forwarded.
(use "git pull" to update your local branch)

nothing to commit, working tree clean
```

```
$ guix pull
Updating channel 'guix' from Git repository at
guix pull: error: aborting update of channel 'guix' to commit
3f1b2bd322b6cdba99a43d08e5e8464f7424cbc5, which is not a descendant of
02297d3fe680371a4b97b9c1b770932cbdd55615
hint: Use `--allow-downgrades' to force this downgrade.
```

For now, I'm trying to avoid doing anything else guix-related, so that
my system is in the same state and can hopefully be diagnosed and fixed.
Attachment: file
B
B
Brian Zwahr wrote on 9 Apr 2021 03:43
Re: bug#47644: Acknowledgement (guix on foreign distro won't upgrade, stuck on old commits)
(address . 47644@debbugs.gnu.org)
VRW9RQ.6FW2POB4TT591@echosa.net
Well, I figured out my issue. I had created backup files manifest.scm
and channels.scm and put them in the ~/.config/guix directory for
storage. Turns out that these files, or at least the channels one, get
read and used automatically by `guix pull`. I have moved those files
to a different directory for storage and backup, and now everything
seems fine.

Turns out the commit that `guix pull` was stuck on was the one defined
in my channels.scm file.

If anyone else experiences the same issue, perhaps this will help.

On Wed, Apr 7 2021 at 08:21:02 PM +0000, GNU bug Tracking System
<help-debbugs@gnu.org> wrote:
Toggle quote (23 lines)
> Thank you for filing a new bug report with debbugs.gnu.org.
>
> This is an automatically generated reply to let you know your message
> has been received.
>
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due course.
>
> Your message has been sent to the package maintainer(s):
> bug-guix@gnu.org <mailto:bug-guix@gnu.org>
>
> If you wish to submit further information on this problem, please
> send it to 47644@debbugs.gnu.org <mailto:47644@debbugs.gnu.org>.
>
> Please do not send mail to help-debbugs@gnu.org
> <mailto:help-debbugs@gnu.org> unless you wish
> to report a problem with the Bug-tracking system.
>
> --
> 47644: <http://debbugs.gnu.org/cgi/bugreport.cgi?bug=47644>
> GNU Bug Tracking System
> Contact help-debbugs@gnu.org <mailto:help-debbugs@gnu.org> with
> problems
Attachment: file
L
L
Leo Famulari wrote on 9 Apr 2021 21:39
(no subject)
(address . control@debbugs.gnu.org)
YHCti3+9I/HbQARW@jasmine.lan
close 47644
?