[PATCH 1/1] Add node-global-gradle-clean

  • Done
  • quality assurance status badge
Details
2 participants
  • Dhruvin Gandhi
  • Jelle Licht
Owner
unassigned
Submitted by
Dhruvin Gandhi
Severity
normal
D
D
Dhruvin Gandhi wrote on 19 Mar 2021 20:21
(address . guix-patches@gnu.org)(name . Dhruvin Gandhi)(address . contact@dhruvin.dev)
20210319192144.17799-2-contact@dhruvin.dev
---
gnu/packages/node-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index b1d6d4ce59..d27df783dc 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -98,6 +98,28 @@ multiple node.js files, while providing useful information about output and exit
codes.")
(license license:expat)))
+(define-public node-global-gradle-clean
+ (package
+ (name "node-global-gradle-clean")
+ (version "1.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/VarunBarad/global-gradle-clean")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1fhm4jimnf7bl5drgwg39mjh8x4rns15hl0fz3bnxi9ikc6dm02y"))))
+ (build-system node-build-system)
+ (arguments '(#:tests? #f))
+ (home-page "https://github.com/VarunBarad/global-gradle-clean")
+ (synopsis "Global gradle clean")
+ (description
+ "This package is used to clean all gradle projects residing under given directory.")
+ (license license:expat)))
+
(define-public node-long-stack-traces
(package
(name "node-long-stack-traces")
--
2.31.0
J
J
Jelle Licht wrote on 29 May 2023 16:24
(name . Dhruvin Gandhi)(address . contact@dhruvin.dev)
87o7m3mczp.fsf@fsfe.org
Pushed to master as cf78f5b54975679df97c3015a541114d8278f417 with some
stylistic changes, with a modest delay. Thanks again!

- Jelle
Closed
?