[PATCH] gnu: mumble: Update to 1.3.4.

  • Done
  • quality assurance status badge
Details
2 participants
  • jgart
  • Leo Prikler
Owner
unassigned
Submitted by
jgart
Severity
normal
J
(address . guix-patches@gnu.org)
039c316d735faa0a21cdacd1a28296cf@dismail.de
Hi Guix,

Raghav Gururajan and I updated mumble to 1.3.4. The patch is attached.

Thank you,

jgart

libremiami.org
search.libremiami.org
L
L
Leo Prikler wrote on 22 Feb 2021 17:18
88fad40b7a501a43517bce0d85509fb271a2026f.camel@student.tugraz.at
Hi jgart and all the others listening from LibreMiami,

Am Montag, den 22.02.2021, 00:59 +0000 schrieb jgart:
Toggle quote (2 lines)
> Co-author: jgart <jgart@dismail.de>
> Co-author: Raghav Gururajan <rg@raghavgururajan.name>
IIRC, the correct tag would be Co-authored-by.

Toggle quote (1 lines)
> * gnu/packages/telephony.scm (mumble): Update to 1.3.4.
This is not enough of a ChangeLog for the changes made here.

Toggle quote (44 lines)
> - `(#:tests? #f ; no "check" target
> + `(#:tests? #f ; no "check" target

> - "no-oss" ; use pulse
> - "no-alsa" ; use pulse
> + "no-oss" ; use
> pulse
> + "no-alsa" ; use
> pulse

> - (with-output-to-file "scripts/mumble-overlay"
> - (lambda ()
> - (format #t "#!~a~%" (which "bash"))
> - (format #t "export LD_PRELOAD=\"~a
> $LD_PRELOAD\"~%"
> - (string-append (assoc-ref outputs "out")
> - "/lib/mumble/libmumble.so.1
> "))
> - (format #t "exec \"${@}\"")))
> - #t))
> + (with-output-to-file "scripts/mumble-overlay"
> + (lambda ()
> + (format #t "#!~a~%" (which "bash"))
> + (format #t "export LD_PRELOAD=\"~a $LD_PRELOAD\"~%"
> + (string-append (assoc-ref outputs "out")
> + "/lib/mumble/libmumble.so.1"
> ))
> + (format #t "exec \"${@}\"")))
> + #t))

> - (replace 'install ; install phase does not exist
> + (replace 'install ; install phase does not
> exist

> - ("mesa" ,mesa) ; avoid bundled
> + ("mesa" ,mesa) ; avoid bundled
> ("openssl" ,openssl)
> - ("opus" ,opus) ; avoid bundled
> + ("opus" ,opus) ; avoid bundled

> - ("speex" ,speex) ; avoid bundled
> - ("speexdsp" ,speexdsp))) ; avoid bundled
> + ("speex" ,speex) ; avoid bundled
> + ("speexdsp" ,speexdsp))) ; avoid bundled
These lines appear to be noise, some of them definitely are.

Toggle quote (8 lines)
> - `(("pkg-config" ,pkg-config)
> - ("python" ,python)
> - ("qttools" ,qttools)))
> + `(("perl" ,perl)
> + ("pkg-config" ,pkg-config)
> + ("python" ,python-wrapper)
> + ("qttools" ,qttools)
> + ("ruby" ,ruby)))
Are perl and ruby really required? If so, what for?

Regards,
Leo
L
L
Leo Prikler wrote on 22 Feb 2021 20:28
78b3b851db5f4b2057ef8216697138744822fb2b.camel@student.tugraz.at
Hi jgart,

Am Montag, den 22.02.2021, 19:09 +0000 schrieb jgart:
Toggle quote (11 lines)
> Hi Leo,
>
> > IIRC, the correct tag would be Co-authored-by.
>
> I attached the updated patch with your suggestions.
>
> > These lines appear to be noise, some of them definitely are.
>
> Raghav thinks these might have been introduced by indent.el
>
> How would you suggest to remove them?
You can select the lines you actually wish to commit through `git
commit -p` or use any other tool to do the trick (e.g. Magit or gitg).
indent.el is a bit of a hammer. If you don't actively edit code, that
has wrong indentation, it's wiser to just indent your portions with
Emacs.

Toggle quote (3 lines)
> > Are perl and ruby really required? If so, what for?
>
> They are for the 'patch-shebangs phase.
And why do you care about those shebangs? Are any of those programs
patched by that phase run at any point during build?

Regards,
Leo
J
2cc84bcd0e2e150ceab659ad818bbb57@dismail.de
Hi Leo,

Toggle quote (2 lines)
> IIRC, the correct tag would be Co-authored-by.

I attached the updated patch with your suggestions.

Toggle quote (2 lines)
> These lines appear to be noise, some of them definitely are.

Raghav thinks these might have been introduced by indent.el

How would you suggest to remove them?

Toggle quote (2 lines)
> Are perl and ruby really required? If so, what for?

They are for the 'patch-shebangs phase.

Thank you for taking the time to review these patches,

jgart

libremiami.org
search.libremiami.org




February 22, 2021 11:18 AM, "Leo Prikler" <leo.prikler@student.tugraz.at> wrote:

Toggle quote (71 lines)
> Hi jgart and all the others listening from LibreMiami,
>
> Am Montag, den 22.02.2021, 00:59 +0000 schrieb jgart:
>
>> Co-author: jgart <jgart@dismail.de>
>> Co-author: Raghav Gururajan <rg@raghavgururajan.name>
>
>
>> * gnu/packages/telephony.scm (mumble): Update to 1.3.4.
>
> This is not enough of a ChangeLog for the changes made here.
>
>> - `(#:tests? #f ; no "check" target
>> + `(#:tests? #f ; no "check" target
>>
>> - "no-oss" ; use pulse
>> - "no-alsa" ; use pulse
>> + "no-oss" ; use
>> pulse
>> + "no-alsa" ; use
>> pulse
>>
>> - (with-output-to-file "scripts/mumble-overlay"
>> - (lambda ()
>> - (format #t "#!~a~%" (which "bash"))
>> - (format #t "export LD_PRELOAD=\"~a
>> $LD_PRELOAD\"~%"
>> - (string-append (assoc-ref outputs "out")
>> - "/lib/mumble/libmumble.so.1
>> "))
>> - (format #t "exec \"${@}\"")))
>> - #t))
>> + (with-output-to-file "scripts/mumble-overlay"
>> + (lambda ()
>> + (format #t "#!~a~%" (which "bash"))
>> + (format #t "export LD_PRELOAD=\"~a $LD_PRELOAD\"~%"
>> + (string-append (assoc-ref outputs "out")
>> + "/lib/mumble/libmumble.so.1"
>> ))
>> + (format #t "exec \"${@}\"")))
>> + #t))
>>
>> - (replace 'install ; install phase does not exist
>> + (replace 'install ; install phase does not
>> exist
>>
>> - ("mesa" ,mesa) ; avoid bundled
>> + ("mesa" ,mesa) ; avoid bundled
>> ("openssl" ,openssl)
>> - ("opus" ,opus) ; avoid bundled
>> + ("opus" ,opus) ; avoid bundled
>>
>> - ("speex" ,speex) ; avoid bundled
>> - ("speexdsp" ,speexdsp))) ; avoid bundled
>> + ("speex" ,speex) ; avoid bundled
>> + ("speexdsp" ,speexdsp))) ; avoid bundled
>
> These lines appear to be noise, some of them definitely are.
>
>> - `(("pkg-config" ,pkg-config)
>> - ("python" ,python)
>> - ("qttools" ,qttools)))
>> + `(("perl" ,perl)
>> + ("pkg-config" ,pkg-config)
>> + ("python" ,python-wrapper)
>> + ("qttools" ,qttools)
>> + ("ruby" ,ruby)))
>
>
> Regards,
> Leo
J
J
jgart wrote on 6 Mar 2021 17:22
Re: [PATCH 1/2] gnu: mumble: Update to 1.3.4.
388092c3804024dcadf16fb392b7c02c@dismail.de
Hi Leo,

These two patches change the logic in the snippet block from list of directories to delete to list of directories to keep as well as add indentation to the mumble package. This is an addition to commit ea13b3a14cb079e33b59cf60cdabf500ecc51cf1.

best regards,

jgart

February 22, 2021 2:09 PM, "jgart" <jgart@dismail.de> wrote:

Toggle quote (94 lines)
> Hi Leo,
>
>> IIRC, the correct tag would be Co-authored-by.
>
> I attached the updated patch with your suggestions.
>
>> These lines appear to be noise, some of them definitely are.
>
> Raghav thinks these might have been introduced by indent.el
>
> How would you suggest to remove them?
>
>> Are perl and ruby really required? If so, what for?
>
> They are for the 'patch-shebangs phase.
>
> Thank you for taking the time to review these patches,
>
> jgart
>
> libremiami.org
> search.libremiami.org
>
> February 22, 2021 11:18 AM, "Leo Prikler" <leo.prikler@student.tugraz.at> wrote:
>
>> Hi jgart and all the others listening from LibreMiami,
>>
>> Am Montag, den 22.02.2021, 00:59 +0000 schrieb jgart:
>>
>>> Co-author: jgart <jgart@dismail.de>
>>> Co-author: Raghav Gururajan <rg@raghavgururajan.name>
>>
>>> * gnu/packages/telephony.scm (mumble): Update to 1.3.4.
>>
>> This is not enough of a ChangeLog for the changes made here.
>>
>>> - `(#:tests? #f ; no "check" target
>>> + `(#:tests? #f ; no "check" target
>>>
>>> - "no-oss" ; use pulse
>>> - "no-alsa" ; use pulse
>>> + "no-oss" ; use
>>> pulse
>>> + "no-alsa" ; use
>>> pulse
>>>
>>> - (with-output-to-file "scripts/mumble-overlay"
>>> - (lambda ()
>>> - (format #t "#!~a~%" (which "bash"))
>>> - (format #t "export LD_PRELOAD=\"~a
>>> $LD_PRELOAD\"~%"
>>> - (string-append (assoc-ref outputs "out")
>>> - "/lib/mumble/libmumble.so.1
>>> "))
>>> - (format #t "exec \"${@}\"")))
>>> - #t))
>>> + (with-output-to-file "scripts/mumble-overlay"
>>> + (lambda ()
>>> + (format #t "#!~a~%" (which "bash"))
>>> + (format #t "export LD_PRELOAD=\"~a $LD_PRELOAD\"~%"
>>> + (string-append (assoc-ref outputs "out")
>>> + "/lib/mumble/libmumble.so.1"
>>> ))
>>> + (format #t "exec \"${@}\"")))
>>> + #t))
>>>
>>> - (replace 'install ; install phase does not exist
>>> + (replace 'install ; install phase does not
>>> exist
>>>
>>> - ("mesa" ,mesa) ; avoid bundled
>>> + ("mesa" ,mesa) ; avoid bundled
>>> ("openssl" ,openssl)
>>> - ("opus" ,opus) ; avoid bundled
>>> + ("opus" ,opus) ; avoid bundled
>>>
>>> - ("speex" ,speex) ; avoid bundled
>>> - ("speexdsp" ,speexdsp))) ; avoid bundled
>>> + ("speex" ,speex) ; avoid bundled
>>> + ("speexdsp" ,speexdsp))) ; avoid bundled
>>
>> These lines appear to be noise, some of them definitely are.
>>
>>> - `(("pkg-config" ,pkg-config)
>>> - ("python" ,python)
>>> - ("qttools" ,qttools)))
>>> + `(("perl" ,perl)
>>> + ("pkg-config" ,pkg-config)
>>> + ("python" ,python-wrapper)
>>> + ("qttools" ,qttools)
>>> + ("ruby" ,ruby)))
>>
>> Regards,
>> Leo
L
L
Leo Prikler wrote on 6 Mar 2021 17:35
695fe773c328b886e69b7790cfcac7f622a54a1e.camel@student.tugraz.at
Am Samstag, den 06.03.2021, 16:22 +0000 schrieb jgart:
Toggle quote (10 lines)
> Hi Leo,
>
> These two patches change the logic in the snippet block from list of
> directories to delete to list of directories to keep as well as add
> indentation to the mumble package. This is an addition to commit
> ea13b3a14cb079e33b59cf60cdabf500ecc51cf1.
>
> best regards,
>
> jgart
Hi jgart,

0001 suffers from similar issues as your previous patch set. In
particular, it adds a spurious level of indentation in arguments!
0002 LGTM, I'll push it after some testing. On that note, could
someone investigate why we keep ancient versions of CELT around? It
seems newer ones have been merged into opus.

Regards,
Leo
L
L
Leo Prikler wrote on 6 Mar 2021 18:38
65482f4bdf27e820e180928f8955f1e11c24efea.camel@student.tugraz.at
Am Samstag, den 06.03.2021, 17:35 +0100 schrieb Leo Prikler:
Toggle quote (22 lines)
> Am Samstag, den 06.03.2021, 16:22 +0000 schrieb jgart:
> > Hi Leo,
> >
> > These two patches change the logic in the snippet block from list
> > of
> > directories to delete to list of directories to keep as well as add
> > indentation to the mumble package. This is an addition to commit
> > ea13b3a14cb079e33b59cf60cdabf500ecc51cf1.
> >
> > best regards,
> >
> > jgart
> Hi jgart,
>
> 0001 suffers from similar issues as your previous patch set. In
> particular, it adds a spurious level of indentation in arguments!
> 0002 LGTM, I'll push it after some testing. On that note, could
> someone investigate why we keep ancient versions of CELT around? It
> seems newer ones have been merged into opus.
>
> Regards,
> Leo
I've now pushed 0002. As far as keeping ancient CELT, it seems version
1.4.0 will at least drop 0.11, while keeping 0.7 for backwards
compatibility.

Do you want to keep this bug open for more indentation adjustments or
is it fine to close?

Regards,
Leo
J
J
jgart wrote on 7 Mar 2021 05:22
fe5dd646139573b0b2013c23e3ec89c8@dismail.de
Hi Leo,

It is fine to close this bug.

Thank you for taking the time to review these changes and for merging the other patch.

We'll keep CELT in mind going forward. Thank you for pointing that out.

all the best,

jgart

libremiami.org

March 6, 2021 12:38 PM, "Leo Prikler" <leo.prikler@student.tugraz.at> wrote:

Toggle quote (34 lines)
> Am Samstag, den 06.03.2021, 17:35 +0100 schrieb Leo Prikler:
>
>> Am Samstag, den 06.03.2021, 16:22 +0000 schrieb jgart:
>> Hi Leo,
>>
>> These two patches change the logic in the snippet block from list
>> of
>> directories to delete to list of directories to keep as well as add
>> indentation to the mumble package. This is an addition to commit
>> ea13b3a14cb079e33b59cf60cdabf500ecc51cf1.
>>
>> best regards,
>>
>> jgart
>> Hi jgart,
>>
>> 0001 suffers from similar issues as your previous patch set. In
>> particular, it adds a spurious level of indentation in arguments!
>> 0002 LGTM, I'll push it after some testing. On that note, could
>> someone investigate why we keep ancient versions of CELT around? It
>> seems newer ones have been merged into opus.
>>
>> Regards,
>> Leo
>
> I've now pushed 0002. As far as keeping ancient CELT, it seems version
> 1.4.0 will at least drop 0.11, while keeping 0.7 for backwards
> compatibility.
>
> Do you want to keep this bug open for more indentation adjustments or
> is it fine to close?
>
> Regards,
> Leo
L
L
Leo Prikler wrote on 7 Mar 2021 09:09
ffb07fe62c7c0c713602a0216f2d0750ea8076c8.camel@student.tugraz.at
Hi jgart,

Am Sonntag, den 07.03.2021, 04:22 +0000 schrieb jgart:
Toggle quote (3 lines)
> Hi Leo,
>
> It is fine to close this bug.
Very well, doing so.

Toggle quote (5 lines)
> Thank you for taking the time to review these changes and for merging
> the other patch.
>
> We'll keep CELT in mind going forward. Thank you for pointing that
> out.
Thank you for submitting the patches.

Regards,
Leo
Closed
?