[PATCH] Added syscall_intercept.

  • Done
  • quality assurance status badge
Details
2 participants
  • Gerd Heber
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Gerd Heber
Severity
normal
G
G
Gerd Heber wrote on 21 Feb 2021 23:42
(address . guix-patches@gnu.org)(name . Gerd Heber)(address . gheber@hdfgroup.org)
20210221224210.6557-1-gheber@hdfgroup.org
---
gnu/packages/engineering.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 034dabc3f9..626338b868 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2996,3 +2996,35 @@ and drilling of PCBs. It takes Gerber files as input and outputs G-code files
for the milling of PCBs. It also includes an autoleveller for the automatic
dynamic calibration of the milling depth.")
(license license:gpl3+)))
+
+(define-public syscall_intercept
+ (package
+ (name "syscall_intercept")
+ (version "0.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/pmem/syscall_intercept/")
+ (commit "304404581c57d43478438d175099d20260bae74e")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "17sw78xp5wjzv25adpbq3khl8fi0avj7bgpi57q3jnvl3c68xy5z"))))
+ (inputs
+ `(("capstone" ,capstone)))
+ (native-inputs
+ `(("perl" ,perl)
+ ("pkg-config" ,pkg-config)))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:build-type "Release"
+ #:tests? #f))
+ (synopsis "The system call intercepting library")
+ (description "The system call intercepting library provides a low-level
+interface for hooking Linux system calls in user space. This is achieved by
+hotpatching the machine code of the standard C library in the memory of a
+process.")
+ (home-page "https://github.com/pmem/syscall_intercept")
+ (license license:bsd-2)))
--
2.30.1
N
N
Nicolas Goaziou wrote on 13 Mar 2021 15:14
(name . Gerd Heber)(address . gerd.heber@gmail.com)
87ft0zw382.fsf@nicolasgoaziou.fr
Hello,

Gerd Heber <gerd.heber@gmail.com> writes:

Toggle quote (2 lines)
> +(define-public syscall_intercept

Thank you.

I added a comment explaining why we are using a specific untagged
commit, and another one explaining there is currently a test failing.

I also added a copyright line for you and a proper commit message.

Note that I renamed the package as syscall-intercept, as we usually do
not use underscore in package names.

Regards,
--
Nicolas Goaziou
Closed
?