[PATCH] gnu: Add dstask.

  • Done
  • quality assurance status badge
Details
2 participants
  • Léo Le Bouter
  • Stefan Reichör
Owner
unassigned
Submitted by
Stefan Reichör
Severity
normal
S
S
Stefan Reichör wrote on 21 Feb 2021 21:55
(address . guix-patches@gnu.org)(name . Stefan Reichör)(address . stefan@xsteve.at)
20210221205558.166912-1-stefan@xsteve.at
* gnu/packages/task-management.scm (dstask): New variable.
---
gnu/packages/task-management.scm | 48 ++++++++++++++++++++++++++++++++
1 file changed, 48 insertions(+)

Toggle diff (75 lines)
diff --git a/gnu/packages/task-management.scm b/gnu/packages/task-management.scm
index 6bd033ba2b..e6b9e33c3d 100644
--- a/gnu/packages/task-management.scm
+++ b/gnu/packages/task-management.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2015 Tomáš ?ech <sleep_walker@suse.cz>
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2021 Eric Bavier <bavier@posteo.net>
+;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -36,6 +37,7 @@
#:use-module (guix git-download)
#:use-module (guix utils)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system go)
#:use-module (guix build-system meson))
(define-public taskwarrior
@@ -66,6 +68,52 @@ Done time management method. It supports network synchronization, filtering
and querying data, exposing task data in multiple formats to other tools.")
(license license:expat)))
+(define-public dstask
+ (package
+ (name "dstask")
+ (version "0.24.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/naggie/dstask")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "03rl2wh58xd6a80ji43c7ak3h0ysi3ddg570pn8ry24s7s45zsz2"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/naggie/dstask"
+ #:install-source? #f
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'build
+ (lambda* (#:key import-path #:allow-other-keys)
+ (with-directory-excursion (string-append "src/" import-path)
+ (invoke "go" "build" "-o" "dstask" "cmd/dstask/main.go")
+ (invoke "go" "build" "-o" "dstask-import"
+ "cmd/dstask-import/main.go"))))
+ (replace 'install
+ (lambda* (#:key import-path outputs #:allow-other-keys)
+ (with-directory-excursion (string-append "src/" import-path)
+ (let* ((out (assoc-ref outputs "out"))
+ (bindir (string-append out "/bin"))
+ (zsh-completion (string-append
+ out "/share/zsh/site-functions/_dstask"))
+ (bash-completion
+ (string-append
+ out "/share/bash-completion/completions/_dstask")))
+ (install-file "dstask" bindir)
+ (install-file "dstask-import" bindir)
+ (install-file ".dstask-bash-completions.sh" bash-completion)
+ (install-file ".dstask-zsh-completions.sh" zsh-completion))))))))
+ (synopsis "CLI-based TODO manager with git-based sync + markdown notes per task")
+ (description "dstask is a personal task tracker that uses git for
+synchronization. It offers a note command to attach a Markdown based note to
+a task.")
+ (home-page "https://github.com/naggie/dstask")
+ (license license:expat)))
+
(define-public blanket
(package
(name "blanket")
--
2.25.1
L
L
Léo Le Bouter wrote on 22 Feb 2021 20:01
(address . 46694-done@debbugs.gnu.org)
d445273cca35656c60b501c1ef5b48de400da5cf.camel@zaclys.net
Adapted 'install phase so it returns #t to silence GNU Guile warning.

Pushed as 515f561370ec0674f0484d074b53887c82e81d97

Thank you!
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEFIvLi9gL+xax3g6RRaix6GvNEKYFAmAz/4kACgkQRaix6GvN
EKb3fg/9EKULNR5gm3XWKVuineZcMCYxZeLzF0AyjH277qrsMWpmnh6BPrrpYM/k
7Y5JhofbhPZ7hV0gfbO16bHgmVuo3si1sJBPYM+1jway0ekaxsVL638Ygg+jQpYD
eIu4o2UQFOMGJ3d1EsFL1euA2t2ND6GQ72NK9aQkeStTsyL7d4LGPUVyDPaGTcaW
QVFRh7dXuCnZmlrA4WZPD2G6VBFkk0d4LLZb4wN0ORijUfRjKzkcmM95GiGNoJiu
77FzOPYekOkCuUxGkcxXDx40GY86aRI1kh13n0nkmY1oaxBE/90iwTwIr8/8YVhl
hd0/UcufJq6HUR/sFb+FUM5tQqfDYfRKRuRCJPlV2wCwn0PzwYnxiL4FEpUCEn9o
UNUSWR9l4wWA7QnF0CNl1GJrKoFjW9vpzEl2EcWB80pJglwItpsu5wPqFwYBaER4
4x7h/l3DWh55sCVx6p8B2Cnt9KNkzBqmHW4/r8QXLgHNGQriJX6IdrDpy6zEeMrl
zMf6WCo2q/QoHu54OK35tchtoKgArlVcB2Zas11J4a8+9vKZ+dGaFw98ippEjEq8
ridt6hy9WsBXoujnBMyuAkwTnuFuwzwGKGOQzvHYPn5At/EdGZCJ6EBwpU91DvXe
/GMSMn6xwNPeXVqzF/39JrNvKFdhw3xYZO6pay+03I8TCFsxttw=
=iOvx
-----END PGP SIGNATURE-----


Closed
?