[PATCH] gnu: mesa: Update to 20.3.4.

  • Done
  • quality assurance status badge
Details
4 participants
  • Brice Waegeneire
  • Léo Le Bouter
  • Milkey Mouse
  • Vincent Legoll
Owner
unassigned
Submitted by
Milkey Mouse
Severity
normal
M
M
Milkey Mouse wrote on 20 Feb 2021 23:50
(address . guix-patches@gnu.org)
20210220225047.682956-1-milkeymouse@meme.institute
* gnu/packages/patches/X: Adjust.
* gnu/packages/gl.scm (mesa): Update to 20.3.4.
[arguments]<#:configure-flags>: Remove deprecated platforms.
---
gnu/packages/gl.scm | 6 +++---
gnu/packages/patches/mesa-skip-tests.patch | 10 +++++-----
2 files changed, 8 insertions(+), 8 deletions(-)

Toggle diff (68 lines)
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index e378474147..7eb47db4fc 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -235,7 +235,7 @@ also known as DXTn or DXTC) for Mesa.")
(define-public mesa
(package
(name "mesa")
- (version "20.2.4")
+ (version "20.3.4")
(source
(origin
(method url-fetch)
@@ -247,7 +247,7 @@ also known as DXTn or DXTC) for Mesa.")
version "/mesa-" version ".tar.xz")))
(sha256
(base32
- "14m09bk7akj0k02lg8fhvvzbdsashlbdsgl2cw7wbqfj2mhdqwh5"))
+ "1120kf280hg4h0a2505vxf6rdw8r2ydl3cg4iwkmpx0zxj3sj8fw"))
(patches
(search-patches "mesa-skip-tests.patch"))))
(build-system meson-build-system)
@@ -301,7 +301,7 @@ also known as DXTn or DXTC) for Mesa.")
'("-Dgallium-drivers=iris,nouveau,r300,r600,radeonsi,svga,swrast,virgl")))
;; Enable various optional features. TODO: opencl requires libclc,
;; omx requires libomxil-bellagio
- "-Dplatforms=x11,drm,surfaceless,wayland"
+ "-Dplatforms=x11,wayland"
"-Dglx=dri" ;Thread Local Storage, improves performance
;; "-Dopencl=true"
;; "-Domx=true"
diff --git a/gnu/packages/patches/mesa-skip-tests.patch b/gnu/packages/patches/mesa-skip-tests.patch
index 2622d5d312..9c0c531189 100644
--- a/gnu/packages/patches/mesa-skip-tests.patch
+++ b/gnu/packages/patches/mesa-skip-tests.patch
@@ -5,7 +5,7 @@ for now.
--- a/src/compiler/glsl/tests/cache_test.c
+++ b/src/compiler/glsl/tests/cache_test.c
-@@ -170,11 +170,6 @@
+@@ -212,11 +212,6 @@ test_disk_cache_create(void)
unsetenv("MESA_GLSL_CACHE_DIR");
unsetenv("XDG_CACHE_HOME");
@@ -14,9 +14,9 @@ for now.
-
- disk_cache_destroy(cache);
-
- /* Test with XDG_CACHE_HOME set */
- setenv("XDG_CACHE_HOME", CACHE_TEST_TMP "/xdg-cache-home", 1);
- cache = disk_cache_create("test", "make_check", 0);
+ #ifdef ANDROID
+ /* Android doesn't try writing to disk (just calls the cache callbacks), so
+ * the directory tests below don't apply.
This test fails on i686-linux. I couldn't come up with a regex that
could be used to disable it just on i686-linux, so we disable it
@@ -28,7 +28,7 @@ diff --git a/src/util/meson.build b/src/util/meson.build
index 0893f64..909b3e0 100644
--- a/src/util/meson.build
+++ b/src/util/meson.build
-@@ -289,18 +289,6 @@ if with_tests
+@@ -320,18 +320,6 @@ if with_tests
suite : ['util'],
)
--
2.30.1
L
L
Léo Le Bouter wrote on 25 Feb 2021 18:10
Re: [PATCH] gnu: Add usync.
(address . 46672@debbugs.gnu.org)
bf3e489e0476c14683f8587e3777203a6161d3c5.camel@zaclys.net
Hello!

Somehow after applying your patch and running "$ ./pre-inst-env guix
lint usync" the following error appears, probably syntax error
somewhere, can't figure it out though, can you take a look?

I ran something like this to apply the patch on current GNU Guix master
(a2ece4da1fdccb9e94681e38a3f3a79b0d43e061):


Backtrace:
In ice-9/boot-9.scm:
1736:10 19 (with-exception-handler _ _ #:unwind? _ # _)
In guix/store.scm:
636:37 18 (thunk)
1305:8 17 (call-with-build-handler #<procedure 7f72e83a5360 at i…>
…)
In guix/scripts/build.scm:
499:2 16 (_)
In srfi/srfi-1.scm:
673:15 15 (append-map _ _ . _)
586:17 14 (map1 ((argument . "usync") (build-mode . 0) (# . #t) …))
In guix/scripts/build.scm:
519:30 13 (_ _)
In gnu/packages.scm:
477:2 12 (%find-package "usync" "usync" #f)
362:6 11 (find-best-packages-by-name _ _)
292:55 10 (_ "usync" _)
In unknown file:
9 (force #<promise #<procedure 7f72e82e9fc0 at gnu/packag…>)
In gnu/packages.scm:
239:33 8 (fold-packages #<procedure 7f72e414cf18 at gnu/package…>
…)
In guix/discovery.scm:
153:11 7 (all-modules _ #:warn _)
In srfi/srfi-1.scm:
460:18 6 (fold #<procedure 7f72e83aa760 at guix/discovery.scm:1…>
…)
In guix/discovery.scm:
143:19 5 (_ _ ())
In srfi/srfi-1.scm:
691:23 4 (filter-map #<procedure 7f72e83aa740 at guix/discove…> .
#)
In guix/discovery.scm:
118:22 3 (_ . _)
In ice-9/eval.scm:
619:8 2 (_ #(#(#<directory (guix ui) 7f72e9e08500> (# "re…" …))))
In ice-9/boot-9.scm:
1669:16 1 (raise-exception _ #:continuable? _)
1669:16 0 (raise-exception _ #:continuable? _)

ice-9/boot-9.scm:1669:16: In procedure raise-exception:
Throw to key `match-error' with args `("match" "no matching pattern"
(unbound-variable "resolve-interface" "no binding `~A' in module ~A"
(python (gnu packages python)) #f))'.

Thank you!
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEFIvLi9gL+xax3g6RRaix6GvNEKYFAmA32gYACgkQRaix6GvN
EKYUuA/+MJ16LrDpWdvLmes4o9r+i6kwu5A/dmxSy9E+MsT/+h2clNFrg+ZMlG0L
7GxKL6+BDz79jDuL+jHN3umZFk86t0v4KTa8wS9c9du4IFK4ifS8pUOAqMe0Vxww
UYDqWQRo+4eP/1fM/kIiAyqTEMn9OF7kA08WRc3ScDkXQDkfB3zU5YK0ctWP8DOc
4682TI3QNGhsSgTJu9bvBn7I7uU+DIBKYiQlUJYPC+8hCIwNYTSAM3A9Eb5Chyqw
2N4EooSp4wTPBZW17+5BZ0bRhPu1S7G+pq+mv4k4bFNd38uqx8uaVuy8cMbi8IRV
GkoTczxu5Yz2MKeVPyEsiXXl1n2M6Cpu6c5we9JJkLVuK44rEfy8lGCRN29qzk89
9hKdW+dcvYnEneSIjf5g/OQAmFD/vThrFE6utBiP5ctkJZV77APGuBb9Wx5TmvVQ
KzO6mlXTwRrzYnsuV9dQfI1xAqpQJ/h3YeHItDwUamjNVT2mcyYrLOxYv4o4HUlU
XKMkLWO43MnUkM9qQhwGrJQLMETs5Sp8TtbX1JJZimsCaW4J1E7lGmrG25uBpXO0
UP7d6L+Zmwde03bHXWLeatVczlonMyrPgEe47+8+ZbW2/fOeMp9U11c6mcwcTtoF
VHf/DxGPof8l72ZODQEBLElTGNDPSFWQEUXUVkZgR6rOIviuToI=
=oI06
-----END PGP SIGNATURE-----


L
L
Léo Le Bouter wrote on 26 Feb 2021 14:30
[PATCH] gnu: mesa: Update to 20.3.4.
(address . 46672@debbugs.gnu.org)
c707301e71581af4dfd52ab848fc27823a781ebf.camel@zaclys.net
Sorry, ignore the previous email that was sent for here by mistake due
to typing out (wrong) bug number manually.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEFIvLi9gL+xax3g6RRaix6GvNEKYFAmA49/4ACgkQRaix6GvN
EKZfPRAAhk0Eakp4bQqu+3NtCo8EZdHbo/9KteeoszLxMvZUfJua3IZ7Ym5dWrZ8
wRfTgzNjhdDvjHYTEhz42ljlT0I7kz8gOFyEmSODEhiVOdJmCLs5yCW8ugZH+SRK
Lc0sHlcnBEW1CM4P0F1ePPXghFLP1t6tUST9RNT9hYOLa76V9UdFVBXR7MoeO8Uh
dFacoG4ONfF9Q55H/14GKpgKX90uhFs9cwajMZRb56xwgZp+QfTAcqje93NoWN8w
F+LrortRD1FukLsTdD/wrt8/1HHESKFEJIQkvuOIzIu+L00RF6wpwfgum5Xkyj91
XKZkUqBtaIJqcf09ut2VaaAIf9tbRPZxv6cmtBzpeCJzMkAUz4XoBdFK3wbHYs9v
dY+IyzQNoSFdRyU2c2O1Fd03if8Uit0tGGQZPfdJMZtiavMOv07iU2V3fLqgXbrP
rNSNglYLcdMRl2OTHoS6Yptls66WnOkzPB3FQ9XH626xh0lYv1XMMGu2Cm0Rlc+u
kY80A98G80gNSuU4CfsgMHffmKl1ygASQ20yM/QRzoOKRsxcffVtmKs39bUxJHVt
XnZuqG2+EmOlNjWoxVvekpraDcOjPbsDEsmhdIuOGoAPLo2Gz66BqWoBIQAfmvTM
nB3wHEHgbvXh5QUfd+aVn4AIGWBshNpM9P5YSiQj/awQ6gntkto=
=1p5s
-----END PGP SIGNATURE-----


V
V
Vincent Legoll wrote on 8 Apr 2021 23:26
mesa 20.3.4
(address . 46672@debbugs.gnu.org)
CAEwRq=pN+XwfRBOXEQiV-Pp+CdGOTk8FDQf9vvEjNMX-+8h0Mg@mail.gmail.com
This still builds OK on master, and following
this, I'll send 20.3.5 update that also builds
OK on current master.

But guix refresh -l tells me it's for core-updates.

Which is a kind of freeze now I think...

I'll revisit later then

--
Vincent Legoll
V
V
Vincent Legoll wrote on 8 Apr 2021 23:26
[PATCH] gnu: mesa: Update to 20.3.5.
(address . 46672@debbugs.gnu.org)(name . Vincent Legoll)(address . vincent.legoll@gmail.com)
20210408212638.6480-1-vincent.legoll@gmail.com
* gnu/packages/gl.scm (mesa): Update to 20.3.5.
---
gnu/packages/gl.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 437d270f05..b86f879465 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -235,7 +235,7 @@ also known as DXTn or DXTC) for Mesa.")
(define-public mesa
(package
(name "mesa")
- (version "20.3.4")
+ (version "20.3.5")
(source
(origin
(method url-fetch)
@@ -247,7 +247,7 @@ also known as DXTn or DXTC) for Mesa.")
version "/mesa-" version ".tar.xz")))
(sha256
(base32
- "1120kf280hg4h0a2505vxf6rdw8r2ydl3cg4iwkmpx0zxj3sj8fw"))
+ "1klifqyr54q8ar8sncykgqllil98q1ma4i6g9j2c18yzcggp56lh"))
(patches
(search-patches "mesa-skip-tests.patch"))))
(build-system meson-build-system)
--
2.31.0
B
B
Brice Waegeneire wrote on 4 Sep 2021 15:39
Re: bug#46672: [PATCH] gnu: mesa: Update to 20.3.4.
(name . Vincent Legoll)(address . vincent.legoll@gmail.com)
87fsukqx29.fsf_-_@waegenei.re
Hello Vincent and Milkey,

Vincent Legoll <vincent.legoll@gmail.com> writes:

Toggle quote (2 lines)
> * gnu/packages/gl.scm (mesa): Update to 20.3.5.

Thank for updating mesa! Unfortunatly this patch as been supserseeded by the
commit 2c0013916e87acc90562dea167a6ff3e1dfee58e (curently on
corer-update-frozen) which update mesa to 21.1.6. So I'm closing this issue.

Cheers,
- Brice
?