[PATCH] gnu: emacs-company: Update to 0.9.13-0.5c25e11.

  • Done
  • quality assurance status badge
Details
4 participants
  • Noah Evans
  • Nicolas Goaziou
  • Michael Rohleder
  • Sergey Trofimov
Owner
unassigned
Submitted by
Noah Evans
Severity
normal
N
N
Noah Evans wrote on 12 Feb 2021 07:36
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
4rLoB-Vmcz_QuoVbH_qU-sqg3Wbv06NptE_gTH2C4bOE7ZUotH2poVy11H2bWm9Pxq38UxJQTH2aOxTm5w0fYmJd1CITCGQVEX_GLHJ_q50=@protonmail.com
The version of emacs-evil-collection in guix relies on the company-tng-mode, which isn't in the most recent release of emacs-company, so I'm submitting this patch to bump emacs-company to the latest git commit.

From 28e2b3fbf46684ce8b3b53cf59b1495d9e162b97 Mon Sep 17 00:00:00 2001
From: Noah Evans <noah@nevans.me>
Date: Fri, 12 Feb 2021 01:21:22 -0500
Subject: [PATCH] gnu: emacs-company: Update to 0.9.13-0.5c25e11.

---
gnu/packages/emacs-xyz.scm | 39 ++++++++++++++++++++++----------------
1 file changed, 23 insertions(+), 16 deletions(-)

Toggle diff (53 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a89568f43d..dab8e870c4 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -5225,25 +5225,32 @@ build jobs.")
(license license:gpl3+)))

(define-public emacs-company
- (package
- (name "emacs-company")
- (version "0.9.13")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://elpa.gnu.org/packages/"
- "company-" version ".tar"))
- (sha256
- (base32 "1c9x9wlzzsn7vrsm57l2l44nqx455saa6wrm853szzg09qn8dlnw"))))
- (build-system emacs-build-system)
- (home-page "https://company-mode.github.io/")
- (synopsis "Modular text completion framework")
- (description
- "Company is a modular completion mechanism. Modules for retrieving
+ ;; 0.9.13 is almost a year old and is incompatible with
+ ;; emacs-evil-collection
+ (let ((commit "5c25e114c3ac1bee3671abd47f46592a3151d549")
+ (revision "0"))
+ (package
+ (name "emacs-company")
+ (version (git-version "0.9.13" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/company-mode/company-mode")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0y6gqc9w4zw1048hlyx0l46gcngbyrmdvzk30flwfphg1ancmcrj"))))
+ (build-system emacs-build-system)
+ (home-page "https://company-mode.github.io/")
+ (synopsis "Modular text completion framework")
+ (description
+ "Company is a modular completion mechanism. Modules for retrieving
completion candidates are called back-ends, modules for displaying them are
front-ends. Company comes with many back-ends, e.g., @code{company-elisp}.
These are distributed in separate files and can be used individually.")
- (license license:gpl3+)))
+ (license license:gpl3+))))

(define-public emacs-company-box
;; There is no release yet. Version is extracted from the main
--
2.30.0
Attachment: file
M
M
Michael Rohleder wrote on 12 Feb 2021 17:31
(address . 46458@debbugs.gnu.org)(name . Noah Evans)(address . clonex100@protonmail.com)
87tuqh6ydn.fsf@rohleder.de
Hey Noah,

Noah Evans via Guix-patches via <guix-patches@gnu.org> writes:
Toggle quote (5 lines)
> The version of emacs-evil-collection in guix relies on the
> company-tng-mode, which isn't in the most recent release of
> emacs-company, so I'm submitting this patch to bump emacs-company to
> the latest git commit.

I noticed that too, but the check (and error) could also be avoided with
(setq evil-collection-company-use-tng nil)
before loading company.

--
Man kann nicht nicht kommunizieren. - Paul Watzlawick
-----BEGIN PGP SIGNATURE-----

iQFFBAEBCAAvFiEEdV4t5dDVhcUueCgwfHr/vv7yyyUFAmAmrXURHG1pa2VAcm9o
bGVkZXIuZGUACgkQfHr/vv7yyyWE3wf+LE9YHbPPMCZHQxey71VMju2YMNveAqby
ZUuGrZby2025yNwg9UJ6iCe1sA5ISyFs5wpgN2gA7P5cuVwiH7fiGP6YWLH/0AaO
kXxsOCiJyE9iuUktyApwbgWVjr8p7gfIj3zvOmi0EMKCQkqpwFs6CbZ0SHALb95W
XzyyPZ4jLAkuBqeik5W5FNwux5nbugBbw20M3b+luz9/cIxIexSBv99ywTirZNbJ
3zscoDkl6+Jyr6OjwKMxvUuXAh1zF+IiICM9e76EcFLdes0NtvFLddH9Z8HzNi8m
grw3vzXUeSjToeRYTYrlYAsKlb2yKoi1NLAS+J7Z613J/jiceGtKTg==
=YOJz
-----END PGP SIGNATURE-----

N
N
Nicolas Goaziou wrote on 15 Feb 2021 11:30
(name . Michael Rohleder)(address . mike@rohleder.de)
87r1lhlj2j.fsf@nicolasgoaziou.fr
Hello,

Michael Rohleder <mike@rohleder.de> writes:

Toggle quote (4 lines)
> I noticed that too, but the check (and error) could also be avoided with
> (setq evil-collection-company-use-tng nil)
> before loading company.

So, what is the way forward? I admit I'm a bit reluctant to move Company
out of GNU ELPA repository because it makes easier updates.

WDYT?

Regards,
--
Nicolas Goaziou
S
S
Sergey Trofimov wrote on 10 Nov 2023 07:10
control message for bug #46458
(address . control@debbugs.gnu.org)
32c3c1f00a9698cc1cc5156c54e96a0f@sarg.org.ru
close 46458
quit
?