[PATCH 2/3] gnu: Add go-github-com-shazow-rateio.

  • Open
  • quality assurance status badge
Details
2 participants
  • Stefan Reichör
  • zimoun
Owner
unassigned
Submitted by
Stefan Reichör
Severity
normal
Merged with
S
S
Stefan Reichör wrote on 10 Feb 2021 22:54
(address . guix-patches@gnu.org)(name . Stefan Reichör)(address . stefan@xsteve.at)
20210210215404.209053-2-stefan@xsteve.at
* gnu/packages/golang.scm (go-github-com-shazow-rateio): New variable.
---
gnu/packages/golang.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 7c0d373a8b..897a5d0d35 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1926,6 +1926,30 @@ applications as well as a program to generate applications and command files.")
(description "Several logging packages for Go")
(license license:expat))))
+(define-public go-github-com-shazow-rateio
+ (let ((commit "4461efc8bdc4508e5ec6ac78fa2ff26d062ae678")
+ (revision "0"))
+ (package
+ (name "go-github-com-shazow-rateio")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/shazow/rateio")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1isy75cmm71q18mvs6xaizgdjqnn6pllkj4yvd42brfgfj84qz0w"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/shazow/rateio"))
+ (home-page "https://github.com/shazow/rateio")
+ (synopsis "Ratelimiting for io-style interfaces in Go")
+ (description "Ratelimiting for io-style interfaces in Go")
+ (license license:expat))))
+
(define-public go-github-com-spf13-pflag
(package
(name "go-github-com-spf13-pflag")
--
2.25.1
Z
Z
zimoun wrote on 20 Sep 2021 13:47
control message for bug #46432
(address . control@debbugs.gnu.org)
87y27rfozo.fsf@gmail.com
merge 46432 46431
quit
Z
Z
zimoun wrote on 20 Sep 2021 13:47
control message for bug #46430
(address . control@debbugs.gnu.org)
87wnnbfoz8.fsf@gmail.com
merge 46430 46431
quit
?