[PATCH 1/2] gnu: opencolorio: Update to 2.0.0.

  • Done
  • quality assurance status badge
Details
3 participants
  • Efraim Flashner
  • Evan Straw
  • Vinicius Monego
Owner
unassigned
Submitted by
Evan Straw
Severity
normal
E
E
Evan Straw wrote on 1 Feb 2021 06:48
(address . guix-patches@gnu.org)
875z3c49ts.fsf@gmail.com
Hello Guix!

This is a series of two patches that will update OpenColorIO to v2.0.0,
which was released 3 days ago. The first, in this message, will add a
dependency for OCIO 2.0.0 and the second, which will be sent soon, will
actually update the package.

Please let me know if I should make any changes.

Thanks,
-- Evan Straw <evan.straw99@gmail.com>
From 3f90b2b1c0e2a1f5266522bdee393a91dba902ac Mon Sep 17 00:00:00 2001
From: Evan Straw <evan.straw99@gmail.com>
Date: Sun, 31 Jan 2021 17:07:44 -0800
Subject: [PATCH 1/2] gnu: Add pystring.

* gnu/packages/cpp.scm (pystring): New variable.
---
gnu/packages/cpp.scm | 55 ++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 55 insertions(+)

Toggle diff (72 lines)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index ae47490755..9c5269d354 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2020 Alexandros Theodotou <alex@zrythm.org>
;;; Copyright © 2020, 2021 Greg Hogan <code@greghogan.com>
;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
+;;; Copyright © 2021 Evan Straw <evan.straw99@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -899,3 +900,57 @@ provides a number of utilities to make coding with expected cleaner.")
(description "Magic Enum offers static reflection of enums, with
conversions to and from strings, iteration and related functionality.")
(license license:expat)))
+
+(define-public pystring
+ (package
+ (name "pystring")
+ (version "1.1.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/imageworks/pystring")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1w31pjiyshqgk6zd6m3ab3xfgb0ribi77r6fwrry2aw8w1adjknf"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:test-target "test"
+ #:phases
+ (modify-phases %standard-phases
+ ;; pystring does not have a configure script
+ (delete 'configure)
+ ;; Makefile attempts to install to /usr/lib; change this to the
+ ;; proper output path
+ (add-before 'install 'fix-install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (lib (string-append out "/lib")))
+ (substitute* "Makefile"
+ (("LIBDIR = /usr/lib")
+ (string-append "LIBDIR = " lib)))
+ (mkdir-p lib)
+ #t)))
+ ;; Makefile does not install the header files for the library;
+ ;; install them to an "include" directory under the proper output
+ ;; path
+ (add-after 'install 'install-header
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (inc (string-append out "/include/pystring")))
+ (mkdir-p inc)
+ (copy-file "pystring.h"
+ (string-append inc "/pystring.h"))
+ #t))))))
+ (native-inputs `(("libtool" ,libtool)))
+ (home-page "https://github.com/imageworks/pystring")
+ (synopsis "C++ functions matching the interface and behavior of Python
+string methods")
+ (description "Pystring is a collection of C++ functions which match the
+interface and behavior of python's string class methods using std::string.
+Implemented in C++, it does not require or make use of a python interpreter.
+It provides convenience and familiarity for common string operations not
+included in the standard C++ library. It's also useful in environments where
+both C++ and python are used.")
+ (license license:bsd-3)))
--
2.25.1
-----BEGIN PGP SIGNATURE-----

iQJLBAEBCAA1FiEE6f/SZXb4DLdwy+VR9TDDtKKp8G0FAmAXlj8XHGV2YW4uc3Ry
YXc5OUBnbWFpbC5jb20ACgkQ9TDDtKKp8G2FVA/9HPkxT9n5kxRndu4TaNJPpKxB
2y5qqvc4bs/vnsGVdHTyUAPjr/Skd2mbSOWrlMsTTyg6VhTezXiGhbwQm1Y/pKMe
4vt/pckLzZ62acPuKnuFky4YRk851IhmZPFxax7Oa+oTNITx9aYxmm+B41HMDvFn
7WVP6lCU5RPf1alMpwtmjyya/JUU2ihuR0ujYkJnrNWFp375xdR0lLb2Uqa2Ynih
nc1EBuTNCs1YaG0yA311ahHlzNK+9Efo8heeWOAunQsf4+71Jp6JvixmGPSNoXDh
36SXGtI4taiomLVnDoMBw9YhlBsweJIef1s2frgcc9R5g2e4arfaoX5H/prbRwu7
fmKVc8XU5XQvs//uLKnhFUYPldInAKYaLT/I2bJ2saj1CplsEVKEgU4lrWOVh/xR
cHRN+fGXm3KMzgIlU2Tm3cEXM0Q1PN+5mBl6jcebncGbRjoYF0FAVAXQ+D6ktJFn
rSlIFguSS1agJ/sUNYuzm87/mdrdbwc/gm5+0d4URpNoZSqpcnT4sB5Ni1CV6A0X
H8KrpzP3Te/tBL3Cpi6MZO0dqFrs9H4OEt/akSqWLb9KBtR0ezrXO4kS9a6XSTvo
ITsTBY28zv7PZ4R3N/5q+KfL1wT9UuBTH2waT0rLLRkyVIiBgm6w/jJUycfZBEfp
z8S2u1iB6dOOZMM8onw=
=/CO/
-----END PGP SIGNATURE-----

E
E
Evan Straw wrote on 1 Feb 2021 06:49
[PATCH 2/2] gnu: opencolorio: Update to 2.0.0.
(address . 46223@debbugs.gnu.org)
8735yg49sg.fsf@gmail.com
From f981dc8fda53e116097f662c62cb2f1e7d740742 Mon Sep 17 00:00:00 2001
From: Evan Straw <evan.straw99@gmail.com>
Date: Sun, 31 Jan 2021 18:38:54 -0800
Subject: [PATCH 2/2] gnu: opencolorio: Update to 2.0.0.

* gnu/packages/image-processing.scm (opencolorio): Update to 2.0.0.
---
gnu/packages/image-processing.scm | 57 +++++++++----------------------
1 file changed, 17 insertions(+), 40 deletions(-)

Toggle diff (106 lines)
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index c3ea8491d9..9f3a420eea 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -44,6 +44,7 @@
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages cpp)
#:use-module (gnu packages curl)
#:use-module (gnu packages docbook)
#:use-module (gnu packages documentation)
@@ -70,6 +71,7 @@
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
#:use-module (gnu packages serialization)
+ #:use-module (gnu packages sphinx)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages tbb)
#:use-module (gnu packages tls)
@@ -173,7 +175,7 @@ of external libraries that provide additional functionality.")
(define-public opencolorio
(package
(name "opencolorio")
- (version "1.1.1")
+ (version "2.0.0")
(source
(origin
(method git-fetch)
@@ -181,51 +183,27 @@ of external libraries that provide additional functionality.")
(url "https://github.com/AcademySoftwareFoundation/OpenColorIO")
(commit (string-append "v" version))))
(sha256
- (base32 "12srvxca51czpfjl0gabpidj9n84mw78ivxy5w75qhq2mmc798sb"))
- (file-name (git-file-name name version))
- (modules '((guix build utils)))
- (snippet
- `(begin
- ;; Remove bundled tarballs, patches, and .jars(!). XXX: Upstream
- ;; claims to have fixed USE_EXTERNAL_YAML, but it still fails with:
- ;; https://github.com/AcademySoftwareFoundation/OpenColorIO/issues/517
- ;; When removing it, also remove it from the licence field comment.
- (for-each delete-file-recursively
- (filter
- (lambda (full-name)
- (let ((file (basename full-name)))
- (not (or (string-prefix? "yaml-cpp-0.3" file)
- (string=? "unittest.h" file)))))
- (find-files "ext" ".*")))
-
- #t))))
+ (base32 "0888fca8wa5zdc6f7lmh1wi7ljw75ql0rlzaslk2zffd08ij0s38"))
+ (file-name (git-file-name name version))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags
- (list (string-append "-DCMAKE_CXX_FLAGS="
- "-Wno-error=deprecated-declarations "
- "-Wno-error=unused-function")
- "-DOCIO_BUILD_STATIC=OFF"
- ;; "-DUSE_EXTERNAL_YAML=ON"
- "-DUSE_EXTERNAL_TINYXML=ON"
- "-DUSE_EXTERNAL_LCMS=ON")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-test-suite
- (lambda _
- (substitute* "src/core_tests/CMakeLists.txt"
- (("/bin/sh") (which "bash")))
- #t)))))
+ (list "-DOCIO_INSTALL_EXT_PACKAGES=NONE"
+ (string-append "-Dpystring_ROOT="
+ (assoc-ref %build-inputs "pystring")))))
(native-inputs
`(("git" ,git)
- ("pkg-config" ,pkg-config)))
+ ("pkg-config" ,pkg-config)
+ ("python" ,python)))
(inputs
- ;; XXX Adding freeglut, glew, ilmbase, mesa, and openimageio for
- ;; ocioconvert fails: error: conflicting declaration ?typedef void
- ;; (* PFNGLGETFRAGMENTMATERIALFVSGIXPROC)(GLenum, GLenum, GLfloat*)
`(("lcms" ,lcms)
("openexr" ,openexr)
- ("tinyxml" ,tinyxml)))
+ ("tinyxml" ,tinyxml)
+ ("expat" ,expat)
+ ("pybind11" ,pybind11)
+ ("yaml-cpp" ,yaml-cpp)
+ ("ilmbase" ,ilmbase)
+ ("pystring" ,pystring)))
(home-page "https://opencolorio.org")
(synopsis "Color management for visual effects and animation")
(description
@@ -238,8 +216,7 @@ back-end configuration options suitable for high-end production usage.
OCIO is compatible with the @acronym{ACES, Academy Color Encoding
Specification} and is @acronym{LUT, look-up table}-format agnostic, supporting
many popular formats.")
- (license (list license:expat ; docs/ociotheme/static, ext/yaml-cpp-*
- license:zlib ; src/core/md5
+ (license (list license:zlib ; src/OpenColorIO/md5
license:bsd-3)))) ; the rest
(define-public vtk
--
2.25.1
-----BEGIN PGP SIGNATURE-----

iQJLBAEBCAA1FiEE6f/SZXb4DLdwy+VR9TDDtKKp8G0FAmAXlm8XHGV2YW4uc3Ry
YXc5OUBnbWFpbC5jb20ACgkQ9TDDtKKp8G2sCxAAgfNHFUXr861I3XcpKHIqJpXW
v+BfTxXyAc6mvlAWaT67ri4TBpx+MAIynHpJ0/w2WP9/DszH93vjaVeeMupzPSd2
a9PZeZ+Y/J+YWeeXqTrIVRWm0e23at5UUlclzb6qpeOpfPoKQ93Q5CO+ITgSeSoN
tGJloCJpMp2FX4uJVIcxNqvTlOXaohqaCAZ5G4lAWNyGQSrOq9ThCTjiAc57mgBS
fwHp/7n9QYUrl6vm9gnVPrx/0S4ICOQqCu0+VA7pVXxfddGwLrNiBDK+VGX6ic04
10YdgzrDaRqa1qc4+y88CnPtwAKnaqc421tK1n5hVj20ybIDRExDCvFabUjK2ubc
2NTAMc4/iwdf5aENGDOLjfUF8cv+k4w2aJAFW9jc61Eq3mKUjUk6hxOUvGyQn1Jb
PsTXkRFzyLhWLUTLLQT5oqaNSQGQXk6nJmWAcvlV1IbExi1sVJLCRNNPQofNU0En
lNhPuXzcC+ARyMrHg5XNUoPa8NvPrMDprfmLp12Qf5ULCiQbA4GogrNcHjyfEIxj
A6s/L0fHlVi1iV7K+174cSxMufe1/6tBX0QABccP3CHPsMsFsPGNcC3UYGn8F9Jb
nEpH7DuZxiHebiF6Cg70lzlv8NbF+k7u3ZVb3ogd2b+zyuRwtKwqyMQST5nV8fPk
5eZx9cphS0K6oCoHbbc=
=YI/o
-----END PGP SIGNATURE-----

E
E
Efraim Flashner wrote on 1 Feb 2021 09:35
Re: [bug#46223] [PATCH 1/2] gnu: opencolorio: Update to 2.0.0.
(name . Evan Straw)(address . evan.straw99@gmail.com)(address . 46223@debbugs.gnu.org)
YBe9Nq/FPx05wcR7@3900XT
On Sun, Jan 31, 2021 at 09:48:47PM -0800, Evan Straw wrote:
Toggle quote (9 lines)
> Hello Guix!
>
> This is a series of two patches that will update OpenColorIO to v2.0.0,
> which was released 3 days ago. The first, in this message, will add a
> dependency for OCIO 2.0.0 and the second, which will be sent soon, will
> actually update the package.
>
> Please let me know if I should make any changes.

Well, you asked for it :)

Toggle quote (72 lines)
> Thanks,
> -- Evan Straw <evan.straw99@gmail.com>

> From 3f90b2b1c0e2a1f5266522bdee393a91dba902ac Mon Sep 17 00:00:00 2001
> From: Evan Straw <evan.straw99@gmail.com>
> Date: Sun, 31 Jan 2021 17:07:44 -0800
> Subject: [PATCH 1/2] gnu: Add pystring.
>
> * gnu/packages/cpp.scm (pystring): New variable.
> ---
> gnu/packages/cpp.scm | 55 ++++++++++++++++++++++++++++++++++++++++++++
> 1 file changed, 55 insertions(+)
>
> diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
> index ae47490755..9c5269d354 100644
> --- a/gnu/packages/cpp.scm
> +++ b/gnu/packages/cpp.scm
> @@ -16,6 +16,7 @@
> ;;; Copyright © 2020 Alexandros Theodotou <alex@zrythm.org>
> ;;; Copyright © 2020, 2021 Greg Hogan <code@greghogan.com>
> ;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
> +;;; Copyright © 2021 Evan Straw <evan.straw99@gmail.com>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -899,3 +900,57 @@ provides a number of utilities to make coding with expected cleaner.")
> (description "Magic Enum offers static reflection of enums, with
> conversions to and from strings, iteration and related functionality.")
> (license license:expat)))
> +
> +(define-public pystring
> + (package
> + (name "pystring")
> + (version "1.1.3")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/imageworks/pystring")
> + (commit (string-append "v" version))))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "1w31pjiyshqgk6zd6m3ab3xfgb0ribi77r6fwrry2aw8w1adjknf"))))
> + (build-system gnu-build-system)
> + (arguments
> + `(#:test-target "test"
> + #:phases
> + (modify-phases %standard-phases
> + ;; pystring does not have a configure script
> + (delete 'configure)
> + ;; Makefile attempts to install to /usr/lib; change this to the
> + ;; proper output path
> + (add-before 'install 'fix-install
> + (lambda* (#:key outputs #:allow-other-keys)
> + (let* ((out (assoc-ref outputs "out"))
> + (lib (string-append out "/lib")))
> + (substitute* "Makefile"
> + (("LIBDIR = /usr/lib")
> + (string-append "LIBDIR = " lib)))
> + (mkdir-p lib)
> + #t)))
> + ;; Makefile does not install the header files for the library;
> + ;; install them to an "include" directory under the proper output
> + ;; path
> + (add-after 'install 'install-header
> + (lambda* (#:key outputs #:allow-other-keys)
> + (let* ((out (assoc-ref outputs "out"))
> + (inc (string-append out "/include/pystring")))
> + (mkdir-p inc)
> + (copy-file "pystring.h"
> + (string-append inc "/pystring.h"))

The source file is pystring.h and the target file is pystring.h, so you
can use install-file instead of mkdir-p and copy-file
(install-file "pystring.h" inc)

A couple of other things: if we don't need the static library
(libpystring.a) then we can drop the install size by quite a bit by not
installing it. For bonus points, if you want, you can replace the calls
to g++ with (cxx-for-target) so it will cross-compile correctly. The
chances that someone will want to cross compile blender is low though.

Toggle quote (8 lines)
> + #t))))))
> + (native-inputs `(("libtool" ,libtool)))
> + (home-page "https://github.com/imageworks/pystring")
> + (synopsis "C++ functions matching the interface and behavior of Python
> +string methods")
> + (description "Pystring is a collection of C++ functions which match the
> +interface and behavior of python's string class methods using std::string.

@code{std::string} Also Python is a proper noun so it should be
capitalized

Toggle quote (12 lines)
> +Implemented in C++, it does not require or make use of a python interpreter.
> +It provides convenience and familiarity for common string operations not
> +included in the standard C++ library. It's also useful in environments where
> +both C++ and python are used.")
> + (license license:bsd-3)))
> --
> 2.25.1
>




--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmAXvTMACgkQQarn3Mo9
g1GDExAAn57aiSJezPKXDqLhetgBYiiWgkCI6X9shSV6gGx+5aThfLP/pyZev+QO
6eBt7xEJugTsqV8M9zyyJdRsagHTWb4sD2epYce7xVAi2DDG71Yj/AvzmwF20CDM
qOtmvb9kz9cBSqAJquNpfRcTqfY+GyYYpGzkIJMkJZFYpEMhXcE9Hr4iOmdOatQM
kbKR32FpEnEjiJ1pOfYo8UKLDkKu2INgPXbKZITAAYnZbJLfumBkvxQEtCSArp1R
KwKh69WKeyylwpvXms3Uvv3l1XMaS4Ux82NHJu3/s60ybBYV4Jt1zGt9PNHk/r2F
HSPo0EtGv8Iatn+N/aMjXZ6Ujrwl6M8RfKifNu67tWoGUSuX/nepzipC+1BShVaZ
tj4vmWoAOZeJoO69k8exyoSEHJURQA9lcE5+3hph9TqWoGe5a5QHiXSqvsm6Rfpu
dSkjbJsNRL5gXiro2hgLxGOe6wxeXPiqBVXUOUo70nFCegNOFpH9p14pBcFj4CNp
ROilbZj6VWUJJ5fwe427qfvRTq80cHAI5vMGReBn+HNVsoIvN14jjWd7uLMHu1sg
LuP4McHvlQyjUUVhwWTwIOmgUHadeMoMaIKJa8+2/XY9OJKPlZLcff/oqdrAiQGc
YLsJgNi3eJDR5rXXw9ALMJ7oNEX+re3KI0kWMhvHbiM2+f4qPoI=
=NTzz
-----END PGP SIGNATURE-----


E
E
Efraim Flashner wrote on 1 Feb 2021 09:37
Re: [bug#46223] [PATCH 2/2] gnu: opencolorio: Update to 2.0.0.
(name . Evan Straw)(address . evan.straw99@gmail.com)(address . 46223@debbugs.gnu.org)
YBe91KRrGD1YcoV6@3900XT
Attachment: file
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmAXvdQACgkQQarn3Mo9
g1FLwBAApcY+g1VZUTKdwo1dbocbqO8CGzweOv95j9UrgMjO9Ka9SESpeOvoYXB6
XKpG4UC/eG7Ah3djf9N+Ik/GqJyAlBkGf4WC7pa2y1gveSo/c196vrsZgmRZWD4O
eZFBVaRUOpc5astRUus5ENImvNKIBOYF0+xqv3DvU/Cg9AkHV8idlG/4J1W9P1Bw
R1ow2ppIEZ6iYLvWdII8zviCs8qH4YAsRGkyX9BmOnYokZi40VGlbdmBPHkK3O6v
W4xBP+xlXIPAJUAQqSdxiBKOitP9HX/nOxYLSIhhCfkcp5SDnYmBlugBXYxZjYB7
ATKZx/QsDagZx8bH0g52oYFXrQob+A9JTXzt/TJHnKWGxXzpVCB4tzdOp7hm4Sx6
ef2UlqTP9Xu4dEeyvQUeDhb6M/s1z/osRib8MaHwIc5MaZE/UcXcixv5EqYDr+nS
rtiYgBJ75xgQC3t4mvl16AdZzFuycoteWt13HdnHzqpcKpWBEgm3yu9Mtp9gpYQv
6+OhTBbUA5vIE0SWcbpvETPV4HCrxWv0ZWBNOc3u1M2Wtt+QJjMYZrcXpFPtCtup
NqfzS5kDhnzxnHuKhaOhkQY663CCWmGm5m4vcpvP/5qGw0y6bUCKaiLUn1ntlCqO
Z5sspQbcKc21R7a1a/X8wJJ4+oM7ixxzjJP6FpRPtvgXtbpwTKs=
=fZQ/
-----END PGP SIGNATURE-----


V
V
Vinicius Monego wrote on 6 Apr 17:53 +0200
[PATCH 1/2] gnu: opencolorio: Update to 2.0.0.
(address . 46223-done@debbugs.gnu.org)
cdb16b7e-7476-4923-a418-6c23dcc8e874@posteo.net
Hi,

I pushed another update to opencolorio as part of a larger series.
Closing this one.

Vinicius
Closed
?