[PATCH] gnu: Add bpytop.

  • Done
  • quality assurance status badge
Details
2 participants
  • Z572
  • ???
Owner
unassigned
Submitted by
Z572
Severity
normal
Z
(address . guix-patches@gnu.org)
tencent_5525B52A6BF38F4D07A0BCB224B856653305@qq.com
From 8ea646c76f87e33734bdeafec18ee13a13d282c5 Mon Sep 17 00:00:00 2001
From: Zheng Junjie <873216071@qq.com>
Date: Thu, 21 Jan 2021 22:08:06 +0800
Subject: [PATCH] gnu: Add bpytop.

---
gnu/packages/admin.scm | 38 ++++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (58 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index b476a90de9..4e1ddc95e3 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -35,6 +35,7 @@
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2020 Morgan Smith <Morgan.J.Smith@outlook.com>
+;;; Copyright © 2021 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -563,6 +564,43 @@ application (for console or X terminals) and requires ncurses.")
memory, disks, network and processes.")
(license license:asl2.0)))
+(define-public bpytop
+ (package
+ (name "bpytop")
+ (version "1.0.59")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "bpytop" version))
+ (sha256
+ (base32
+ "0901a4lfq931lpl59r99kjc2dhh5scj3gqpxkq7c72psf3kpi9dz"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-psutil" ,python-psutil)))
+ (home-page
+ "https://github.com/aristocratos/bpytop")
+ (synopsis "Resource monitor")
+ (description "Resource monitor that shows usage and stats for processor,
+memory, disks, network and processes.
+
+Features:
+@itemize
+@item Easy to use, with a game inspired menu system.
+@item Full mouse support, all buttons with a highlighted key is clickable and
+mouse scroll works in process list and menu boxes.
+@item Fast and responsive UI with UP, DOWN keys process selection.
+@item Function for showing detailed stats for selected process.
+@item Ability to filter processes, multiple filters can be entered.
+@item Easy switching between sorting options.
+@item Send SIGTERM, SIGKILL, SIGINT to selected process.
+@item UI menu for changing all config file options.
+@item Auto scaling graph for network usage.
+@item Shows message in menu if new version is available.
+@item Shows current read and write speeds for disks.
+@end itemize")
+ (license license:asl2.0)))
+
(define-public pies
(package
(name "pies")
--
2.30.0
?
(name . Z572)(address . 873216071@qq.com)(address . 46020-done@debbugs.gnu.org)
OSZP286MB0664C81399CAA6F5F2A5D6C9A38B9@OSZP286MB0664.JPNP286.PROD.OUTLOOK.COM
Z572 <873216071@qq.com> writes:

Toggle quote (5 lines)
>>From 8ea646c76f87e33734bdeafec18ee13a13d282c5 Mon Sep 17 00:00:00 2001
> From: Zheng Junjie <873216071@qq.com>
> Date: Thu, 21 Jan 2021 22:08:06 +0800
> Subject: [PATCH] gnu: Add bpytop.

Hello, thank you for this patch!

I update it to the current version '1.0.61', and remove the features
section in description, pushed!
Closed
?