[PATCH] Add dwl.

  • Done
  • quality assurance status badge
Details
3 participants
  • Z572
  • ???
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Z572
Severity
normal
Z
(address . guix-patches@gnu.org)
tencent_6FCA5F4BAA6AA7376B526DB3FAFEC674F609@qq.com
From fa60adfd7b2b48ea12a1ed66e7da9db94412e3af Mon Sep 17 00:00:00 2001
From: Zheng Junjie <873216071@qq.com>
Date: Thu, 21 Jan 2021 20:12:13 +0800
Subject: [PATCH] gnu: Add dwl.

---
gnu/packages/wm.scm | 48 +++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 48 insertions(+)

Toggle diff (68 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 084822f2c7..682fc69dbe 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -41,6 +41,7 @@
;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
;; Copyright © 2020 Niklas Eklund <niklas.eklund@posteo.net>
;;; Copyright © 2020 Robert Smith <robertsmith@posteo.net>
+;;; Copyright © 2021 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1258,6 +1259,53 @@ It is inspired by Xmonad and dwm. Its major features include:
project derived from the original Calm Window Manager.")
(license license:isc)))
+(define-public dwl
+ (package
+ (name "dwl")
+ (version "0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/djpohly/dwl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "18g2sx8cv54zl5iw5m9lzngrp6ra2pyp7c68qps2ava3brw9m0j2"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:make-flags
+ (list
+ "CC=gcc"
+ (string-append "PREFIX=" %output))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; no configure
+ (replace 'install ; no install targer
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ (install-file "dwl" bin)))))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("wlroots" ,wlroots)))
+ (home-page "https://github.com/djpohly/dwl")
+ (synopsis "Dwm for Wayland")
+ (description
+ "A compact, hackable compositor for Wayland based on wlroots. It is
+intended to fill the same space in the Wayland world that dwm does in X11,
+primarily in terms of philosophy, and secondarily in terms of functionality.
+Like dwm, dwl is:
+@itemize
+@item Easy to understand, hack on, and extend with patches
+@item One C source file (or a very small number) configurable via config.h
+@item Limited to 2000 SLOC to promote hackability
+@item Tied to as few external dependencies as possible
+@end itemize") ;; LICENSE LICENSE.dwm LICENSE.tinywl
+ (license (list license:gpl3+ license:expat license:cc0))))
+
(define-public nitrogen
(package
(name "nitrogen")
--
2.30.0
N
N
Nicolas Goaziou wrote on 23 Jan 2021 12:15
(name . Z572)(address . 873216071@qq.com)(address . 46018@debbugs.gnu.org)
874kj7gb04.fsf@nicolasgoaziou.fr
Hello,

Z572 <873216071@qq.com> writes:

Toggle quote (2 lines)
> Subject: [PATCH] gnu: Add dwl.

Thank you! Some comments follow.

Toggle quote (20 lines)
> +(define-public dwl
> + (package
> + (name "dwl")
> + (version "0.1")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/djpohly/dwl")
> + (commit (string-append "v" version))))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "18g2sx8cv54zl5iw5m9lzngrp6ra2pyp7c68qps2ava3brw9m0j2"))))
> + (build-system gnu-build-system)
> + (arguments
> + `(#:tests? #f ; no tests
> + #:make-flags
> + (list
> + "CC=gcc"

Instead of "CC=gcc", you should use

(string-append "CC=" ,(cc-for-target))

for cross-compilation.

Toggle quote (2 lines)
> + (string-append "PREFIX=" %output))

Here, I think it is preferable to use

(string-append "PREFIX=" (assoc-ref %outputs "out"))

Toggle quote (5 lines)
> + #:phases
> + (modify-phases %standard-phases
> + (delete 'configure) ; no configure
> + (replace 'install ; no install targer

Typo: ";no install target"

Toggle quote (11 lines)
> + (lambda* (#:key outputs #:allow-other-keys)
> + (let* ((out (assoc-ref outputs "out"))
> + (bin (string-append out "/bin")))
> + (install-file "dwl" bin)))))))
> + (native-inputs
> + `(("pkg-config" ,pkg-config)))
> + (inputs
> + `(("wlroots" ,wlroots)))
> + (home-page "https://github.com/djpohly/dwl")
> + (synopsis "Dwm for Wayland")

It would be nice to expound Dwm, e.g.,

"Dynamic window manager for Wayland"

Toggle quote (3 lines)
> + (description
> + "A compact, hackable compositor for Wayland based on wlroots. It is

This should be a complete sentence, e.g.,

Dwl is a compact, hackable...
Toggle quote (9 lines)
> +intended to fill the same space in the Wayland world that dwm does in X11,
> +primarily in terms of philosophy, and secondarily in terms of functionality.
> +Like dwm, dwl is:
> +@itemize
> +@item Easy to understand, hack on, and extend with patches
> +@item One C source file (or a very small number) configurable via config.h
> +@item Limited to 2000 SLOC to promote hackability
> +@item Tied to as few external dependencies as possible

I suggest rewrite so it doesn't include a list. For example:

Like dwm, dwl is easy to understand and hack on, due to a limited
size and a few external dependencies. It is configurable via @file{config.h}.

Could you send an updated patch?

Regards,
--
Nicolas Goaziou
Z
Re: bug#46018: [PATCH] Add dwl.
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 46018@debbugs.gnu.org)
tencent_EAF64F5007A1DCAB44AC1674B325553DCB05@qq.com
From 19ea34ad94d10453e0b6697a835217df50a34d45 Mon Sep 17 00:00:00 2001
From: Zheng Junjie <873216071@qq.com>
Date: Thu, 21 Jan 2021 20:12:13 +0800
Subject: [PATCH] gnu: Add dwl.

---
gnu/packages/wm.scm | 44 ++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 44 insertions(+)

Toggle diff (64 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 084822f2c7..38e0d5ea98 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -41,6 +41,7 @@
;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
;; Copyright © 2020 Niklas Eklund <niklas.eklund@posteo.net>
;;; Copyright © 2020 Robert Smith <robertsmith@posteo.net>
+;;; Copyright © 2021 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1258,6 +1259,49 @@ It is inspired by Xmonad and dwm. Its major features include:
project derived from the original Calm Window Manager.")
(license license:isc)))
+(define-public dwl
+ (package
+ (name "dwl")
+ (version "0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/djpohly/dwl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "18g2sx8cv54zl5iw5m9lzngrp6ra2pyp7c68qps2ava3brw9m0j2"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:make-flags
+ (list
+ (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; no configure
+ (replace 'install ; no install target
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ (install-file "dwl" bin)))))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("wlroots" ,wlroots)))
+ (home-page "https://github.com/djpohly/dwl")
+ (synopsis "Dynamic window manager for Wayland")
+ (description
+ "A compact, hackable compositor for Wayland based on wlroots. It is
+intended to fill the same space in the Wayland world that dwm does in X11,
+primarily in terms of philosophy, and secondarily in terms of functionality.
+Like dwm, dwl is easy to understand and hack on, due to a limited size and
+ a few external dependencies. It is configurable via @file{config.h}.")
+ ;; LICENSE LICENSE.dwm LICENSE.tinywl
+ (license (list license:gpl3+ license:expat license:cc0))))
+
(define-public nitrogen
(package
(name "nitrogen")
--
2.30.0
?
Re: [bug#46018] [PATCH] Add dwl.
(name . Z572)(address . 873216071@qq.com)
OSZP286MB06645C48558F37C4C4900EFFA38B9@OSZP286MB0664.JPNP286.PROD.OUTLOOK.COM
Pushed, thank you for the patch, and Nicolas Goaziou for the review!
Closed
?