[PATCH] Add xkeysnail.

  • Done
  • quality assurance status badge
Details
3 participants
  • Z572
  • ???
  • Ludovic Courtès
Owner
unassigned
Submitted by
Z572
Severity
normal
Z
(address . guix-patches@gnu.org)
tencent_CA5EFF487438CA654A766B4736755333B309@qq.com
From c8ffb0e96851e5642fa872f5ffc20d9e56d30fb7 Mon Sep 17 00:00:00 2001
From: Zheng Junjie <873216071@qq.com>
Date: Thu, 21 Jan 2021 18:36:16 +0800
Subject: [PATCH 1/2] gnu: Add python-inotify-simple.

---
gnu/packages/python-xyz.scm | 33 ++++++++++++++++++++++++++++++++-
1 file changed, 32 insertions(+), 1 deletion(-)

Toggle diff (53 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d08e23936c..81d7eb48c7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -93,7 +93,7 @@
;;; Copyright © 2020 Diego N. Barbato <dnbarbato@posteo.de>
;;; Copyright © 2020 Leo Prikler <leo.prikler@student.tugraz.at>
;;; Copyright © 2019 Kristian Trandem <kristian@devup.no>
-;;; Copyright © 2020 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2020, 2021 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -6726,6 +6726,37 @@ need to use the older and less efficient @code{pkg_resources} package.")
finding unresolved symbols in Python code and their corresponding imports.")
(license license:bsd-3)))
+(define-public python-inotify-simple
+ (package
+ (name "python-inotify-simple")
+ (version "1.3.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/chrisjbillington/inotify_simple")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1dv9svrcz31acyq9smjlnw75xv3x5wpn5h6s8j8h0vrqyl3d7l05"))))
+ (build-system python-build-system)
+ (home-page
+ "https://github.com/chrisjbillington/inotify_simple")
+ (synopsis "Simple wrapper around inotify library")
+ (description
+ "@code{inotify-simple} is a simple wrapper around inotify library.")
+ (license license:bsd-3)
+ (properties `((python2-variant . ,(delay python2-inotify-simple))))))
+
+(define-public python2-inotify-simple
+ (let ((base (package-with-python2
+ (strip-python2-variant python-inotify-simple))))
+ (package
+ (inherit base)
+ (propagated-inputs
+ `(("python2-enum34" ,python2-enum34)
+ ,@(package-propagated-inputs base))))))
+
(define-public python-jaraco-packaging
(package
(name "python-jaraco-packaging")
--
2.30.0
From ff3e5c516f7cae4cff3037cde5d36d7f415727dd Mon Sep 17 00:00:00 2001
From: Zheng Junjie <873216071@qq.com>
Date: Thu, 21 Jan 2021 18:37:33 +0800
Subject: [PATCH 2/2] gnu: Add xkeysnail.

---
gnu/packages/xdisorg.scm | 31 ++++++++++++++++++++++++++++++-
1 file changed, 30 insertions(+), 1 deletion(-)

Toggle diff (51 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 26660b8bfa..9522a2ae23 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -42,7 +42,7 @@
;;; Copyright © 2020 Gabriel Arazas <foo.dogsquared@gmail.com>
;;; Copyright © 2020 James Smith <jsubuntuxp@disroot.org>
;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
-;;; Copyright © 2020 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2020, 2021 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -326,6 +326,35 @@ application.")
(home-page "https://hluk.github.io/CopyQ/")
(license license:gpl3+)))
+(define-public xkeysnail
+ (package
+ (name "xkeysnail")
+ (version "0.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "xkeysnail" version))
+ (sha256
+ (base32
+ "1xyqp6yqxcwmxaqj86qcsiz0ly7bwr0a2w835myz909irhip3ngf"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ;test need /dev/uinput
+ (propagated-inputs
+ `(("python-six" ,python-six)
+ ("python-appdirs" ,python-appdirs)
+ ("python-evdev" ,python-evdev)
+ ("python-inotify-simple" ,python-inotify-simple)
+ ("python-xlib" ,python-xlib)))
+ (home-page "https://github.com/mooz/xkeysnail")
+ (synopsis
+ "Keyboard remapping tool for X environment")
+ (description
+ "A X environment keyboard remapping tool. high-level and flexible remapping
+mechanisms. Runs in low-level layer (evdev and uinput), making remapping work
+in almost all the places.")
+ (license license:gpl3)))
+
(define-public xclip
(package
(name "xclip")
--
2.30.0
L
L
Ludovic Courtès wrote on 29 Jan 2021 12:03
(name . Z572)(address . 873216071@qq.com)(address . 46015@debbugs.gnu.org)
87mtwshunc.fsf@gnu.org
Hi,

Z572 <873216071@qq.com> skribis:

Toggle quote (9 lines)
>>From c8ffb0e96851e5642fa872f5ffc20d9e56d30fb7 Mon Sep 17 00:00:00 2001
> From: Zheng Junjie <873216071@qq.com>
> Date: Thu, 21 Jan 2021 18:36:16 +0800
> Subject: [PATCH 1/2] gnu: Add python-inotify-simple.
>
> ---
> gnu/packages/python-xyz.scm | 33 ++++++++++++++++++++++++++++++++-
> 1 file changed, 32 insertions(+), 1 deletion(-)

Applied with a commit log and without the Python 2 variant (we no longer
add them).

Toggle quote (9 lines)
>>From ff3e5c516f7cae4cff3037cde5d36d7f415727dd Mon Sep 17 00:00:00 2001
> From: Zheng Junjie <873216071@qq.com>
> Date: Thu, 21 Jan 2021 18:37:33 +0800
> Subject: [PATCH 2/2] gnu: Add xkeysnail.
>
> ---
> gnu/packages/xdisorg.scm | 31 ++++++++++++++++++++++++++++++-
> 1 file changed, 30 insertions(+), 1 deletion(-)

[...]

Toggle quote (7 lines)
> + (propagated-inputs
> + `(("python-six" ,python-six)
> + ("python-appdirs" ,python-appdirs)
> + ("python-evdev" ,python-evdev)
> + ("python-inotify-simple" ,python-inotify-simple)
> + ("python-xlib" ,python-xlib)))

Please use ‘wrap-script’ around the ‘xkeysnail’ executable instead of
propagating inputs. That way, installing xkeysnail won’t “pollute” the
user profile with all these Python libraries.

Toggle quote (2 lines)
> + (license license:gpl3)))

Is it version-3-only or version-3-or-any-later-version?

Could you send an updated patch?

Thanks,
Ludo’.
L
L
Ludovic Courtès wrote on 29 Jan 2021 12:04
(name . Z572)(address . 873216071@qq.com)(address . 46015@debbugs.gnu.org)
87im7ghulx.fsf@gnu.org
Also, suggested synopsis/description, with full sentences:

(synopsis "Keyboard remapping tool for the X11 environment")
(description
"Xkeysnail is an X environment keyboard remapping tool, featuring
high-level and flexible remapping mechanisms. It affects the low-level
layers (evdev and uinput), making remapping work in almost all the places.")
Z
(name . bug#46015)(address . 46015@debbugs.gnu.org)
tencent_986545FDA5E938967B96ACD5626F4AA58E0A@qq.com
From e1e02b411e6314ecb491fd0980fdfbb94b6466ff Mon Sep 17 00:00:00 2001
From: Zheng Junjie <873216071@qq.com>
Date: Fri, 29 Jan 2021 23:06:25 +0800
Subject: [PATCH] gnu: Add xkeysnail.

* gnu/packages/xdisorg.scm (xkeysnail): New variable.
---
gnu/packages/xdisorg.scm | 30 +++++++++++++++++++++++++++++-
1 file changed, 29 insertions(+), 1 deletion(-)

Toggle diff (50 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 26660b8bfa..a08eae247a 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -42,7 +42,7 @@
;;; Copyright © 2020 Gabriel Arazas <foo.dogsquared@gmail.com>
;;; Copyright © 2020 James Smith <jsubuntuxp@disroot.org>
;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
-;;; Copyright © 2020 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2020, 2021 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -326,6 +326,34 @@ application.")
(home-page "https://hluk.github.io/CopyQ/")
(license license:gpl3+)))
+(define-public xkeysnail
+ (package
+ (name "xkeysnail")
+ (version "0.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "xkeysnail" version))
+ (sha256
+ (base32
+ "1xyqp6yqxcwmxaqj86qcsiz0ly7bwr0a2w835myz909irhip3ngf"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ;tests need /dev/uinput
+ (inputs
+ `(("python-appdirs" ,python-appdirs)
+ ("python-evdev" ,python-evdev)
+ ("python-inotify-simple" ,python-inotify-simple)
+ ("python-xlib" ,python-xlib)
+ ("python-six" ,python-six)))
+ (home-page "https://github.com/mooz/xkeysnail")
+ (synopsis "Keyboard remapping tool for the X11 environment")
+ (description
+ "Xkeysnail is an X environment keyboard remapping tool, featuring
+high-level and flexible remapping mechanisms. It affects the low-level
+layers (evdev and uinput), making remapping work in almost all the places.")
+ (license license:gpl3+))) ; see README.md (no licence headers)
+
(define-public xclip
(package
(name "xclip")
--
2.30.0
?
Re: [bug#46015] [PATCH] Add xkeysnail.
(name . Z572)(address . 873216071@qq.com)(name . bug#46015)(address . 46015-done@debbugs.gnu.org)
OSZP286MB06642AD628B5A630B2E61025A38B9@OSZP286MB0664.JPNP286.PROD.OUTLOOK.COM
Z572 <873216071@qq.com> writes:

Toggle quote (2 lines)
> Subject: [PATCH] gnu: Add xkeysnail.

Pushed, thank you!
Closed
?