[PATCH] gnu: Add sbcl-claw-utils.

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Adam Kandur
Owner
unassigned
Submitted by
Adam Kandur
Severity
normal
A
A
Adam Kandur wrote on 21 Jan 2021 01:04
(name . Guix Patches)(address . guix-patches@gnu.org)
MRXFLct--3-2@tuta.io
From 4f2d2866690fa00b5fccc6cab15b97aabd4b8416 Mon Sep 17 00:00:00 2001
From: Adam Kandur <rndd@tuta.io>
Date: Thu, 21 Jan 2021 03:02:32 +0300
Subject: [PATCH] gnu: Add sbcl-claw-utils.

* gnu/packages/lisp-xyz.scm (sbcl-claw-utils): New variable.
---
 gnu/packages/lisp-xyz.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 36725eb..f4eeaed 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -12231,6 +12231,42 @@ and lean bindings to C libraries.")
 (define-public ecl-claw
   (sbcl-package->ecl-package sbcl-claw))
 
+(define-public sbcl-claw-utils
+  (let ((revision "0")
+        (commit "efe25016501973dc369f067a64c7d225802bc56f"))
+    (package
+      (name "sbcl-claw-utils")
+      ;; version is not specified
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/borodust/claw-utils")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "01df3kyf2qs3czi332dnz2s35x2j0fq46vgmsw7wjrrvnqc22mk5"))))
+      (build-system asdf-build-system/sbcl)
+      (arguments
+       '(#:asd-files '("claw-utils.asd")
+         #:asd-systems '("claw-utils")))
+      (inputs
+       `(("alexandria" ,sbcl-alexandria)
+     ("cffi" ,sbcl-cffi)
+     ("sbcl-claw" ,sbcl-claw)
+     ("sbcl-cl-autowrap" ,sbcl-cl-autowrap)))
+      (home-page "https://github.com/borodust/claw-utils")
+      (synopsis "Utilities for easier autowrapping.")
+      (description "Various handy utilties to help autowrapping with @code{:claw}.")
+      (license license:expat))))
+
+(define-public cl-claw-utils
+  (sbcl-package->cl-source-package sbcl-claw-utils))
+
+(define-public ecl-claw-utils
+  (sbcl-package->ecl-package sbcl-claw-utils))
+
 (define-public sbcl-array-operations
   (let ((commit "75cbc3b1adb2e3ce2109489753d0f290b071e81b")
         (revision "0"))
--
2.30.0
G
G
Guillaume Le Vaillant wrote on 21 Jan 2021 11:51
(name . Adam Kandur)(address . rndd@tuta.io)(address . 46011@debbugs.gnu.org)
87o8hid0lc.fsf@yamatai
guix-patches--- via <guix-patches@gnu.org> skribis:

Toggle quote (12 lines)
> +(define-public sbcl-claw-utils
> + (let ((revision "0")
> + (commit "efe25016501973dc369f067a64c7d225802bc56f"))
> + (package
> + (name "sbcl-claw-utils")
> ...
> + (inputs
> + `(("alexandria" ,sbcl-alexandria)
> + ("cffi" ,sbcl-cffi)
> + ("sbcl-claw" ,sbcl-claw)
> + ("sbcl-cl-autowrap" ,sbcl-cl-autowrap)))

Is the cl-autowrap package really necessary here? It is not in the
dependency list of the asd file, and it looks like the package compiles
fine without it. Or is there a case where it is required at runtime?
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYAlcvw8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j+gWAD9FlJTY2pEOu9PjCLZ/57vwUqB62XDMxrKsVRB
vmNAFCcA/iOBoPEoAqr8l53kQ4Dj+bCQVBOu7MwW77LJT4udL0Bp
=Y4FY
-----END PGP SIGNATURE-----

A
A
Adam Kandur wrote on 21 Jan 2021 14:01
well, not really, here is a new commit
(address . 46011@debbugs.gnu.org)
MR_1Bt1--3-2@tuta.io
From cc450bb85b138bcb72915a32bfeb9eab27481c40 Mon Sep 17 00:00:00 2001
From: Adam Kandur <rndd@tuta.io>
Date: Thu, 21 Jan 2021 15:57:09 +0300
Subject: [PATCH] gnu: Add sbcl-claw-utils.

* gnu/packages/lisp-xyz.scm (sbcl-claw-utils): New variable.
---
 gnu/packages/lisp-xyz.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 36725eb..e2a208a 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -12225,6 +12225,35 @@ package.")
 and lean bindings to C libraries.")
       (license license:bsd-2))))
 
+(define-public sbcl-claw-utils
+  (let ((revision "0")
+        (commit "efe25016501973dc369f067a64c7d225802bc56f"))
+    (package
+      (name "sbcl-claw-utils")
+      ;; version is not specified
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/borodust/claw-utils")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "01df3kyf2qs3czi332dnz2s35x2j0fq46vgmsw7wjrrvnqc22mk5"))))
+      (build-system asdf-build-system/sbcl)
+      (arguments
+       '(#:asd-files '("claw-utils.asd")
+         #:asd-systems '("claw-utils")))
+      (inputs
+       `(("alexandria" ,sbcl-alexandria)
+     ("cffi" ,sbcl-cffi)
+     ("sbcl-claw" ,sbcl-claw)))
+      (home-page "https://github.com/borodust/claw-utils")
+      (synopsis "Utilities for easier autowrapping.")
+      (description "Various handy utilties to help autowrapping with @code{:claw}.")
+      (license license:expat))))
+
 (define-public cl-claw
   (sbcl-package->cl-source-package sbcl-claw))
 
--
2.30.0
G
G
Guillaume Le Vaillant wrote on 21 Jan 2021 14:36
Re: [bug#46011] [PATCH] gnu: Add sbcl-claw-utils.
(name . Adam Kandur)(address . rndd@tuta.io)(address . 46011-done@debbugs.gnu.org)
87lfcmcsz3.fsf@yamatai
Patch pushed as ef9c5247a34580d82a1675eea6242bbe065440cd.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYAmDUA8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j+lJAD9G3Q/p6APDAkzUvmexo4Ip2ETHdQCMQ1AUHRs
zvYtz7wA/0OBkG4TeDNRnvoze2ZR7cP0fA4lTrk+Nu4SHSTqD8Yy
=2hnu
-----END PGP SIGNATURE-----

Closed
?