[PATCH] gnu: linux-libre: Allow disk encryption by default.

  • Done
  • quality assurance status badge
Details
3 participants
  • Caliph Nomble
  • Leo Famulari
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
Caliph Nomble
Severity
normal
C
C
Caliph Nomble wrote on 19 Jan 2021 23:47
(address . guix-patches@gnu.org)(name . Caliph Nomble)(address . calnomble@protonmail.com)
sFlfGNISaiqJk8AqOo81yNYZMVTJTUHfQClgSsY@cp4-web-037.plabs.ch
* gnu/packages/linux.scm (%default-extra-linux-options): Enable CONFIG_DM_CRYPT
as a module.
---
gnu/packages/linux.scm | 2 ++
1 file changed, 2 insertions(+)

Toggle diff (15 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 7ed71e9d8f..26b3035518 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -641,6 +641,8 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
("CONFIG_MEMCG_KMEM" . #t)
("CONFIG_CPUSETS" . #t)
("CONFIG_PROC_PID_CPUSET" . #t)
+ ;; Allow disk encryption by default
+ ("CONFIG_DM_CRYPT" . m)
;; Modules required for initrd:
("CONFIG_NET_9P" . m)
("CONFIG_NET_9P_VIRTIO" . m)
--
2.26.2
L
L
Leo Famulari wrote on 20 Jan 2021 02:54
(name . guix-patches--- via)(address . guix-patches@gnu.org)
YAeNWwXMvJegam6z@jasmine.lan
On Tue, Jan 19, 2021 at 10:47:19PM +0000, guix-patches--- via wrote:
Toggle quote (3 lines)
> * gnu/packages/linux.scm (%default-extra-linux-options): Enable CONFIG_DM_CRYPT
> as a module.

This option is already enabled in the kernel configs. Can you say why we
should put it in %default-extra-linux-options as well? Is there some use
case that isn't being served currently?
C
C
Caliph Nomble wrote on 20 Jan 2021 04:28
(name . Leo Famulari)(address . leo@famulari.name)(name . 45998@debbugs.gnu.org)(address . 45998@debbugs.gnu.org)
LGZCU3ai8gZTIbhMjl_QyLx65PIywQJV38VebLjqxMnu3JwbkCrOXAJ_gUp_E1UmP3SK_Wu6JeWtDq9FUwwDv7Dv4q-Ksw4q3cUeAcjL-zQ=@protonmail.com
Hi,

I know at least linux-libre-arm64-generic doesn't have the option already set,
and a quick glance through mainline kernel defconfigs made it seem like it'd be
better as a general option. I could have been wrong in thinking it'd do best as
a general option, but it needs to be in linux-libre-arm64-generic, at least.

Thanks.
L
L
Leo Famulari wrote on 20 Jan 2021 18:08
(name . Caliph Nomble)(address . calnomble@protonmail.com)(name . 45998@debbugs.gnu.org)(address . 45998@debbugs.gnu.org)
YAhjoaAgzIfzdNwi@jasmine.lan
On Wed, Jan 20, 2021 at 03:28:28AM +0000, Caliph Nomble wrote:
Toggle quote (7 lines)
> Hi,
>
> I know at least linux-libre-arm64-generic doesn't have the option already set,
> and a quick glance through mainline kernel defconfigs made it seem like it'd be
> better as a general option. I could have been wrong in thinking it'd do best as
> a general option, but it needs to be in linux-libre-arm64-generic, at least.

Okay, let's do it!

Your patch applies with an author of "guix-patches--- via
<guix-patches@gnu.org>".

Shall I change it to "Caliph Nomble <calnomble@protonmail.com>"?
C
C
Caliph Nomble wrote on 21 Jan 2021 23:21
(name . 45998@debbugs.gnu.org)(address . 45998@debbugs.gnu.org)(name . Leo Famulari)(address . leo@famulari.name)
UCh1NWBNzWYC5N7u1KQ-EeX-eG-vVisqqf1lYXhZPt-nqUL_IrTp5FqyXGpf_PXwQcC0INPOD9bwjkO2dIkCwdcnqWx-Yjwkk1Ya_ofmLwo=@protonmail.com
Hi,

Toggle quote (2 lines)
> Shall I change it to "Caliph Nomble <calnomble@protonmail.com>"?

Yes, that would be very much appreciated. I have no idea why that happens; I
know the same thing occured for a previous patch I submitted. If you know of
any way to prevent that in the future, too, please tell me.

Thanks!
L
L
Leo Famulari wrote on 22 Jan 2021 20:08
(name . Caliph Nomble)(address . calnomble@protonmail.com)(name . 45998@debbugs.gnu.org)(address . 45998@debbugs.gnu.org)
YAsitWxCIdhIzmyI@jasmine.lan
On Thu, Jan 21, 2021 at 10:21:16PM +0000, Caliph Nomble wrote:
Toggle quote (4 lines)
> Yes, that would be very much appreciated. I have no idea why that happens; I
> know the same thing occured for a previous patch I submitted. If you know of
> any way to prevent that in the future, too, please tell me.

Alright, I've queued up your patch for the next kernel update.

Regarding your name not being included in your patch submissions, what
commands are you using to create and submit your patches?
T
T
Tobias Geerinckx-Rice wrote on 22 Jan 2021 21:25
87lfckvhve.fsf@nckx
Caliph,

guix-patches--- via ???
Toggle quote (7 lines)
>> Shall I change it to "Caliph Nomble
>> <calnomble@protonmail.com>"?
>
> Yes, that would be very much appreciated. I have no idea why
> that happens; I
> know the same thing occured for a previous patch I submitted.

I doubt there's fault with your patch workflow.

Your non-patch listmails lack a name as well. For example[0]:

Toggle quote (2 lines)
> From: guix-patches--- via <guix-patches@gnu.xxx>

Whilst[1]:

Toggle quote (2 lines)
> From: Leo Famulari <xxx@famulari.xxx> [2]

-----BEGIN PGP SIGNATURE-----

iIMEARYKACsWIQT12iAyS4c9C3o4dnINsP+IT1VteQUCYAs0xQ0cbWVAdG9iaWFz
LmdyAAoJEA2w/4hPVW15foEBAOe3IU7rjXG+zrCw04h97jD+yLJU5RY0cLr9nqKj
nkGhAP9ot4HGa1NTynuwaJX1RlAMcnwKNCA9CpkJYiFeVd7uAA==
=2dk7
-----END PGP SIGNATURE-----

T
T
Tobias Geerinckx-Rice wrote on 22 Jan 2021 21:38
87im7ovhao.fsf@nckx
guix-patches--- via ???
Toggle quote (5 lines)
> From: guix-patches--- via <guix-patches@gnu.org>
> [...]
>
> Caliph,

Hmmm.

Kind regards,

T G-R
-----BEGIN PGP SIGNATURE-----

iIMEARYKACsWIQT12iAyS4c9C3o4dnINsP+IT1VteQUCYAs3rw0cbWVAdG9iaWFz
LmdyAAoJEA2w/4hPVW159SIA/0dd6mAyVho3vaeHZQFdyW7Q9ogDhb1OpuykB/8B
QGkxAQDjdVHhO6A5zTALziq79ZDtt8StdXQaBYf2/iuscpmUCA==
=Tmwj
-----END PGP SIGNATURE-----

C
C
Caliph Nomble wrote on 23 Jan 2021 18:21
(name . 45998@debbugs.gnu.org)(address . 45998@debbugs.gnu.org)
zDaElZ-hDYcOkyPOk7IKykIusq42xjA_XroLnde4gdQNKuT_BQkEPOnoV1A-NSmBtKzSijRG_-pzhKZ3YwhplZhIcMgN2okhUzst5voF_E8=@protonmail.com
Hi,

Leo Famulari:
Toggle quote (3 lines)
> Regarding your name not being included in your patch submissions, what
> commands are you using to create and submit your patches?

I'm just using git format-patch and send-email (with --from manually set to
this email address), though I do use hydroxide as an smtp bridge to ProtonMail.
Headers are all correct in the send-email confirm interface before sending.

Tobias Geerinckx-Rice:
Toggle quote (2 lines)
> Hmmm.

Might be an issue with emails being forwarded through the mailing list and thus
replacing their original address, then? With this not happening in other cases
due to CCs.

Thanks!
L
L
Leo Famulari wrote on 24 Jan 2021 20:07
(name . guix-patches--- via)(address . guix-patches@gnu.org)
YA3FbNjKwE2e2u6M@jasmine.lan
On Tue, Jan 19, 2021 at 10:47:19PM +0000, guix-patches--- via wrote:
Toggle quote (3 lines)
> * gnu/packages/linux.scm (%default-extra-linux-options): Enable CONFIG_DM_CRYPT
> as a module.

Pushed as 82fd2eeed3335116cac6bd198420da7ba36cbc52
?