[PATCH 0/2] gnu: python-invoke: Patch reference to bash.

  • Done
  • quality assurance status badge
Details
2 participants
  • ???
  • Tanguy Le Carrour
Owner
unassigned
Submitted by
Tanguy Le Carrour
Severity
normal
T
T
Tanguy Le Carrour wrote on 19 Jan 2021 19:22
(address . guix-patches@gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
20210119182257.15116-1-tanguy@bioneland.org
Hi Guix,

Invoke's code contains a reference to `/bin/bash`. This path does not exist
in the build environment of another package I am working on. I don't
know why it seems to work for some other packages, thought !?

Best regards

Tanguy Le Carrour (2):
gnu: python-invoke: Patch reference to bash.
gnu: python-invoke: Update to 1.5.0.

gnu/packages/python-xyz.scm | 18 +++++++++++++++---
1 file changed, 15 insertions(+), 3 deletions(-)

--
2.30.0
T
T
Tanguy Le Carrour wrote on 19 Jan 2021 19:25
[PATCH 1/2] gnu: python-invoke: Patch reference to bash.
(address . 45989@debbugs.gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
20210119182542.16812-1-tanguy@bioneland.org
* gnu/packages/python-xyz.scm (python-invoke)[arguments]: Patch
the reference to 'bash' in the source.
[inputs]: Add bash.
---
gnu/packages/python-xyz.scm | 14 +++++++++++++-
1 file changed, 13 insertions(+), 1 deletion(-)

Toggle diff (27 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d08e23936c..de36222bba 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15129,7 +15129,19 @@ projects.")
(build-system python-build-system)
(arguments
;; XXX: Requires many dependencies that are not yet in Guix.
- `(#:tests? #f))
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-bash-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((bash (assoc-ref inputs "bash")))
+ (substitute* "invoke/config.py"
+ (("shell = \"/bin/bash\"")
+ (string-append "shell = \"" bash "/bin/bash\""))
+ )
+ #t))))))
+ (inputs
+ `(("bash" ,bash-minimal)))
(synopsis "Pythonic task execution")
(description
"Invoke is a Python task execution tool and library, drawing inspiration
--
2.30.0
T
T
Tanguy Le Carrour wrote on 19 Jan 2021 19:25
[PATCH 2/2] gnu: python-invoke: Update to 1.5.0.
(address . 45989@debbugs.gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
20210119182542.16812-2-tanguy@bioneland.org
* gnu/packages/python-xyz.scm (python-invoke): Update to 1.5.0.
---
gnu/packages/python-xyz.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index de36222bba..3f83c877b4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15119,13 +15119,13 @@ projects.")
(package
(name "python-invoke")
(home-page "https://www.pyinvoke.org/")
- (version "1.4.1")
+ (version "1.5.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "invoke" version))
(sha256
(base32
- "0pg1lpl4583z83i12262v72y1a4cxdcxi7vqhl8dpqv9wszj6gyy"))))
+ "0l16v7zcbgi36z6pvmdrs5q4ks8lalcafi5d9nhrpcjzbc3n1igh"))))
(build-system python-build-system)
(arguments
;; XXX: Requires many dependencies that are not yet in Guix.
--
2.30.0
?
Re: [bug#45989] [PATCH 0/2] gnu: python-invoke: Patch reference to bash.
(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)(address . 45989-done@debbugs.gnu.org)
OSZP286MB0664CF9114580F54F3675C3DA38B9@OSZP286MB0664.JPNP286.PROD.OUTLOOK.COM
Tanguy Le Carrour <tanguy@bioneland.org> writes:

Toggle quote (5 lines)
> Hi Guix,
>
> Invoke's code contains a reference to `/bin/bash`. This path does not exist
> in the build environment of another package I am working on. I don't
> know why it seems to work for some other packages, thought !?
I think they'll failed too unless they configured the shell somehow...

Pushed, thank you!
Closed
T
T
Tanguy LE CARROUR wrote on 12 Feb 2021 14:46
(name . ???)(address . iyzsong@outlook.com)(address . 45989-done@debbugs.gnu.org)
1613137426.y6x5wzz6yv.astroid@melmoth.none
Hi,


Excerpts from ???'s message of February 12, 2021 1:16 pm:
Toggle quote (9 lines)
> Tanguy Le Carrour <tanguy@bioneland.org> writes:
>
>> Hi Guix,
>>
>> Invoke's code contains a reference to `/bin/bash`. This path does not exist
>> in the build environment of another package I am working on. I don't
>> know why it seems to work for some other packages, thought !?
> I think they'll failed too unless they configured the shell somehow...

You right! I figured out that I had myself the `INVOKE_RUN_SHELL` envvar set.


Toggle quote (2 lines)
> Pushed, thank you!

Thanks!

--
Tanguy
Closed
?