[PATCH] New gnu/packages/lisp.scm buildapp

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal
S
S
Sharlatan Hellseher wrote on 16 Jan 2021 23:16
(address . guix-patches@gnu.org)
CAO+9K5oa+fM05u0JhqT7Ka6faPtn10oRnrp+o51mKAHQP+BCFQ@mail.gmail.com
Hello Guix team!
`pgloader` uses `buildapp` to produce binary, so here is a patch to
make it available. I've placed it to lisp.scm and not lisp-xyz.sxm as
it's not ASDF system but stand alone binary build with itself and
ASDF+SBCL
--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
From 3b1f12cb045bdc41f50d42415423a5f4f232e131 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Sat, 16 Jan 2021 22:11:16 +0000
Subject: [PATCH] Add buildapp

* gnu/packages/lisp.scm (buildapp) new variable
---
gnu/packages/lisp.scm | 40 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)

Toggle diff (57 lines)
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index e357aad4e0..c8ab6bbbdb 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -17,6 +17,7 @@
;;; Copyright © 2019, 2020 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Zhu Zihao <all_but_last@163.com>
+;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1126,3 +1127,42 @@ and make for REPLs that start blazing fast.
@item It allows you to include arbitrary libraries.
@end itemize\n")
(license license:gpl3+)))
+
+(define-public buildapp
+ (package
+ (name "buildapp")
+ (version "1.5.6")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xach/buildapp")
+ (commit (string-append "release-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "020ipjfqa3l8skd97cj5kq837wgpj28ygfxnkv64cnjrlbnzh161"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("sbcl" ,sbcl)))
+ (arguments
+ `(#:tests? #f
+ #:make-flags
+ (list (string-append "DESTDIR=" (assoc-ref %outputs "out")))
+ #:strip-binaries? #f
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'unpack 'set-home
+ (lambda _
+ (setenv "HOME" "/tmp") #t))
+ (add-before 'install 'create-target-directory
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((bin (string-append (assoc-ref outputs "out") "/bin")))
+ (mkdir-p bin)
+ #t))))))
+ (home-page "https://www.xach.com/lisp/buildapp/")
+ (synopsis "Makes easy to build application executables with SBCL")
+ (description
+ "Buildapp is an application for SBCL or CCL that configures and saves an
+executable Common Lisp image. It is similar to cl-launch and hu.dwim.build. ")
+ (license license:bsd-2)))
--
2.30.0
G
G
Guillaume Le Vaillant wrote on 17 Jan 2021 10:20
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 45921-done@debbugs.gnu.org)
87v9bv538o.fsf@yamatai
Sharlatan Hellseher <sharlatanus@gmail.com> skribis:

Toggle quote (7 lines)
> Hello Guix team!
>
> `pgloader` uses `buildapp` to produce binary, so here is a patch to
> make it available. I've placed it to lisp.scm and not lisp-xyz.sxm as
> it's not ASDF system but stand alone binary build with itself and
> ASDF+SBCL

Patch pushed as 014845591a406a367082903da3e70d103b78bc44.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYAQBVw8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j+F5QD/WGwO/8DIY1pDWsWlU27JAaG+WJTJMeYg+SWH
chsPSU8A/jIcoMMW0I7bz+m/btDQllwLp/4i3vHod7DMNuY1l9a1
=zGhJ
-----END PGP SIGNATURE-----

Closed
?