(address . guix-patches@gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
* guix/ui.scm (run-guix-command): Modify order that extensions are allowed to
override default commands.
---
guix/ui.scm | 18 +++++++++---------
1 file changed, 9 insertions(+), 9 deletions(-)
Toggle diff (36 lines)
diff --git a/guix/ui.scm b/guix/ui.scm
index bd504c68da..ad78d5cedd 100644
--- a/guix/ui.scm
+++ b/guix/ui.scm
@@ -2126,18 +2126,18 @@ found."
(define module
(catch 'misc-error
(lambda ()
- (resolve-interface `(guix scripts ,command)))
- (lambda _
;; Check if there is a matching extension.
+ (match (search-path (extension-directories)
+ (format #f "~a.scm" command))
+ (#f
+ (throw 'misc-error))
+ (file
+ (load file)
+ (resolve-interface `(guix extensions ,command)))))
+ (lambda _
(catch 'misc-error
(lambda ()
- (match (search-path (extension-directories)
- (format #f "~a.scm" command))
- (#f
- (throw 'misc-error))
- (file
- (load file)
- (resolve-interface `(guix extensions ,command)))))
+ (resolve-interface `(guix scripts ,command)))
(lambda _
(format (current-error-port)
(G_ "guix: ~a: command not found~%") command)
base-commit: 884f320e7ceb35cb8472510e47fc5f1944675d82
--
2.29.2