[PATCH] gnu: Add emacs-scad-mode.

  • Done
  • quality assurance status badge
Details
2 participants
  • Morgan.J.Smith
  • Ludovic Courtès
Owner
unassigned
Submitted by
Morgan.J.Smith
Severity
normal
M
M
Morgan.J.Smith wrote on 15 Jan 2021 22:24
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
MWHPR0801MB36756510EF860581C59E3E88C5A70@MWHPR0801MB3675.namprd08.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/engineering.scm (emacs-scad-mode): New variable.
---
gnu/packages/engineering.scm | 23 ++++++++++++++++++++++-
1 file changed, 22 insertions(+), 1 deletion(-)

Toggle diff (50 lines)
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 826e2d89b6..fa48399853 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -20,7 +20,7 @@
;;; Copyright © 2020 Ekaitz Zarraga <ekaitz@elenq.tech>
;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
;;; Copyright © 2020, 2021 Vinicius Monego <monego@posteo.net>
-;;; Copyright © 2020 Morgan Smith <Morgan.J.Smith@outlook.com>
+;;; Copyright © 2020, 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -50,6 +50,7 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix build-system ant)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system emacs)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
#:use-module (guix build-system qt)
@@ -2513,6 +2514,26 @@ full programmatic control over your models.")
(home-page "https://www.openscad.org/")
(license license:gpl2+)))
+(define-public emacs-scad-mode
+ (package
+ (inherit openscad)
+ (name "emacs-scad-mode")
+ (native-inputs '())
+ (inputs '())
+ (build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir-elisp
+ ;; Elisp directory is not in root of the source.
+ (lambda _
+ (chdir "contrib")
+ #t)))))
+ (synopsis "Emacs major mode for editing editing OpenSCAD code")
+ (description "@code{scad-mode} provides an Emacs major mode for editing
+OpenSCAD code. It supports syntax highlighting, indenting and refilling of
+comments.")))
+
(define-public freecad
(let ((commit-ref "7616153b3c31ace006169cdc2fdafab484498858")
(revision "1"))
--
2.30.0
L
L
Ludovic Courtès wrote on 29 Jan 2021 11:57
(address . Morgan.J.Smith@outlook.com)(address . 45906-done@debbugs.gnu.org)
87r1m4huxk.fsf@gnu.org
Hi,

Morgan.J.Smith@outlook.com skribis:

Toggle quote (4 lines)
> From: Morgan Smith <Morgan.J.Smith@outlook.com>
>
> * gnu/packages/engineering.scm (emacs-scad-mode): New variable.

Applied, thanks!

Ludo’.
Closed
?