[PATCH 0/2] Update Renpy

  • Done
  • quality assurance status badge
Details
One participant
  • Leo Prikler
Owner
unassigned
Submitted by
Leo Prikler
Severity
normal
L
L
Leo Prikler wrote on 9 Jan 2021 09:39
(address . guix-patches@gnu.org)
87d9325eeb202a876c80652131de9f2f8cdcfce8.camel@student.tugraz.at
Hello Guix,

last year, Ren'py was updated to 7.4.0. It appears to still need to be
run on Python2 (despite a Python3 compatibility mode being added) with
full Python3 support being on the way for 8.0. At least I haven't yet
been able to build python3 versions of those packages, but I've tried
to make porting a little smoother in the future.

Regards,
Leo
L
L
Leo Prikler wrote on 9 Jan 2021 09:58
[PATCH 1/2] gnu: python2-pygame-sdl2: Update to renpy-version 7.4.0.
(address . 45736@debbugs.gnu.org)
20210109085812.17500-1-leo.prikler@student.tugraz.at
* gnu/packages/game-development.scm (python2-pygame-sdl2): Update to
renpy-version 7.4.0.
---
gnu/packages/game-development.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (31 lines)
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index fa7875d077..02e110ec0d 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1062,7 +1062,7 @@ to create fully featured games and multimedia programs in the python language.")
(define-public python2-pygame-sdl2
(let ((real-version "2.1.0")
- (renpy-version "7.3.5"))
+ (renpy-version "7.4.0"))
(package
(inherit python2-pygame)
(name "python2-pygame-sdl2")
@@ -1072,13 +1072,13 @@ to create fully featured games and multimedia programs in the python language.")
(method url-fetch)
(uri (string-append "https://www.renpy.org/dl/" renpy-version
"/pygame_sdl2-" version ".tar.gz"))
- (sha256 (base32 "1bmr7j9mlsc4czpgw70ld15ymyp4wxrk9hdsqad40wjwdxvvg2dr"))
+ (sha256 (base32 "04hnfy1zbncs8n0m46sh6r8l55l2bz5y08a1birkhlri13f8zc29"))
(modules '((guix build utils)))
(snippet
'(begin
;; drop generated sources
(delete-file-recursively "gen")
- (delete-file-recursively "gen3")
+ (delete-file-recursively "gen-static")
#t))))
(build-system python-build-system)
(arguments
--
2.30.0
L
L
Leo Prikler wrote on 9 Jan 2021 09:58
[PATCH 2/2] gnu: python2-renpy: Update to 7.4.0.
(address . 45736@debbugs.gnu.org)
20210109085812.17500-2-leo.prikler@student.tugraz.at
* gnu/packages/game-development.scm (python2-renpy): Update to 7.4.0.
(inputs): Add python2-future.
(#:phases)[install]: Infer python version from input.
* gnu/packages/patches/renpy-use-system-fribidi.patch: Update to renpy 7.4.0.
---
gnu/packages/game-development.scm | 10 ++++----
.../patches/renpy-use-system-fribidi.patch | 23 +++++++++++--------
2 files changed, 19 insertions(+), 14 deletions(-)

Toggle diff (90 lines)
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 02e110ec0d..863575d835 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1115,13 +1115,13 @@ developed mainly for Ren'py.")
(define-public python2-renpy
(package
(name "python2-renpy")
- (version "7.3.5")
+ (version "7.4.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.renpy.org/dl/" version
"/renpy-" version "-source.tar.bz2"))
- (sha256 (base32 "1anr5cfbvbsbik4v4rvrkdkciwhg700k4lydfbs4n85raimz9mw4"))
+ (sha256 (base32 "0av3mbh54xh6i3rvf60x5hbsjcfpzgia2j958mhyc5826zjxzfpg"))
(modules '((guix build utils)))
(patches
(search-patches
@@ -1178,8 +1178,8 @@ developed mainly for Ren'py.")
;; (both source and compiled) in the same directory.
(let* ((out (assoc-ref outputs "out"))
(site (string-append "/lib/python"
- ,(version-major+minor
- (package-version python-2))
+ (python-version
+ (assoc-ref inputs "python"))
"/site-packages")))
(with-directory-excursion "module"
(apply (assoc-ref %standard-phases 'install) args))
@@ -1192,6 +1192,7 @@ developed mainly for Ren'py.")
("fribidi" ,fribidi)
("glew" ,glew)
("libpng" ,libpng)
+ ("python2-future" ,python2-future)
("python2-pygame" ,python2-pygame-sdl2)
("sdl-union"
,(sdl-union (list sdl2 sdl2-image sdl2-mixer sdl2-ttf)))))
@@ -1208,7 +1209,6 @@ modules of Ren'py.")
(package
(inherit python2-renpy)
(name "renpy")
- (version "7.3.5")
(build-system python-build-system)
(arguments
`(#:tests? #f ; see python2-renpy
diff --git a/gnu/packages/patches/renpy-use-system-fribidi.patch b/gnu/packages/patches/renpy-use-system-fribidi.patch
index 1437274bcc..913415e317 100644
--- a/gnu/packages/patches/renpy-use-system-fribidi.patch
+++ b/gnu/packages/patches/renpy-use-system-fribidi.patch
@@ -2,22 +2,27 @@ See also [Arch] and [Gentoo] for similar patches in other distros.
[Arch] https://github.com/archlinux/svntogit-community/blob/packages/renpy/trunk/renpy-system-fribidi.patch
[Gentoo] https://gitweb.gentoo.org/repo/gentoo.git/tree/games-engines/renpy/files/renpy-7.3.5-use-system-fribidi.patch
-Index: renpy-7.3.5-source/module/renpybidicore.c
+Index: renpy-7.4.0-source/module/renpybidicore.c
===================================================================
---- renpy-7.3.5-source.orig/module/renpybidicore.c
-+++ renpy-7.3.5-source/module/renpybidicore.c
-@@ -1,5 +1,5 @@
+--- renpy-7.4.0-source.orig/module/renpybidicore.c
++++ renpy-7.4.0-source/module/renpybidicore.c
+@@ -1,9 +1,3 @@
#include <Python.h>
+-
+-#ifdef RENPY_BUILD
+ #include <fribidi.h>
+-#else
-#include <fribidi-src/lib/fribidi.h>
-+#include <fribidi.h>
+-#endif
+-
#include <stdlib.h>
#ifndef alloca
-Index: renpy-7.3.5-source/module/setup.py
+Index: renpy-7.4.0-source/module/setup.py
===================================================================
---- renpy-7.3.5-source.orig/module/setup.py
-+++ renpy-7.3.5-source/module/setup.py
-@@ -119,30 +119,13 @@ cython(
+--- renpy-7.4.0-source.orig/module/setup.py
++++ renpy-7.4.0-source/module/setup.py
+@@ -125,30 +125,13 @@ cython(
sdl + [ png, 'z', 'm' ])
FRIBIDI_SOURCES = """
--
2.30.0
L
L
Leo Prikler wrote on 23 Jan 2021 10:58
[PATCH v2 1/3] gnu: python2-pygame-sdl2: Update to renpy-version 7.4.0.
(address . 45736@debbugs.gnu.org)
20210123095802.9500-1-leo.prikler@student.tugraz.at
* gnu/packages/game-development.scm (python2-pygame-sdl2): Update to
renpy-version 7.4.0.
---
gnu/packages/game-development.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (31 lines)
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index fa7875d077..02e110ec0d 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1062,7 +1062,7 @@ to create fully featured games and multimedia programs in the python language.")
(define-public python2-pygame-sdl2
(let ((real-version "2.1.0")
- (renpy-version "7.3.5"))
+ (renpy-version "7.4.0"))
(package
(inherit python2-pygame)
(name "python2-pygame-sdl2")
@@ -1072,13 +1072,13 @@ to create fully featured games and multimedia programs in the python language.")
(method url-fetch)
(uri (string-append "https://www.renpy.org/dl/" renpy-version
"/pygame_sdl2-" version ".tar.gz"))
- (sha256 (base32 "1bmr7j9mlsc4czpgw70ld15ymyp4wxrk9hdsqad40wjwdxvvg2dr"))
+ (sha256 (base32 "04hnfy1zbncs8n0m46sh6r8l55l2bz5y08a1birkhlri13f8zc29"))
(modules '((guix build utils)))
(snippet
'(begin
;; drop generated sources
(delete-file-recursively "gen")
- (delete-file-recursively "gen3")
+ (delete-file-recursively "gen-static")
#t))))
(build-system python-build-system)
(arguments
--
2.30.0
L
L
Leo Prikler wrote on 23 Jan 2021 10:58
[PATCH v2 2/3] gnu: python2-renpy: Update to 7.4.0.
(address . 45736@debbugs.gnu.org)
20210123095802.9500-2-leo.prikler@student.tugraz.at
* gnu/packages/game-development.scm (python2-renpy): Update to 7.4.0.
(inputs): Move python2-pygame...
(propagated-inputs): ... to here. Add python2-future.
(#:phases)[install]: Infer python version from input.
* gnu/packages/patches/renpy-use-system-fribidi.patch: Update to renpy 7.4.0.

python2-renpy: propagate python inputs
---
gnu/packages/game-development.scm | 13 ++++++-----
.../patches/renpy-use-system-fribidi.patch | 23 +++++++++++--------
2 files changed, 21 insertions(+), 15 deletions(-)

Toggle diff (95 lines)
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 02e110ec0d..4e218b5205 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1115,13 +1115,13 @@ developed mainly for Ren'py.")
(define-public python2-renpy
(package
(name "python2-renpy")
- (version "7.3.5")
+ (version "7.4.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.renpy.org/dl/" version
"/renpy-" version "-source.tar.bz2"))
- (sha256 (base32 "1anr5cfbvbsbik4v4rvrkdkciwhg700k4lydfbs4n85raimz9mw4"))
+ (sha256 (base32 "0av3mbh54xh6i3rvf60x5hbsjcfpzgia2j958mhyc5826zjxzfpg"))
(modules '((guix build utils)))
(patches
(search-patches
@@ -1178,8 +1178,8 @@ developed mainly for Ren'py.")
;; (both source and compiled) in the same directory.
(let* ((out (assoc-ref outputs "out"))
(site (string-append "/lib/python"
- ,(version-major+minor
- (package-version python-2))
+ (python-version
+ (assoc-ref inputs "python"))
"/site-packages")))
(with-directory-excursion "module"
(apply (assoc-ref %standard-phases 'install) args))
@@ -1192,9 +1192,11 @@ developed mainly for Ren'py.")
("fribidi" ,fribidi)
("glew" ,glew)
("libpng" ,libpng)
- ("python2-pygame" ,python2-pygame-sdl2)
("sdl-union"
,(sdl-union (list sdl2 sdl2-image sdl2-mixer sdl2-ttf)))))
+ (propagated-inputs
+ `(("python2-future" ,python2-future)
+ ("python2-pygame" ,python2-pygame-sdl2)))
(native-inputs
`(("python2-cython" ,python2-cython)
("xdg-utils" ,xdg-utils)))
@@ -1208,7 +1210,6 @@ modules of Ren'py.")
(package
(inherit python2-renpy)
(name "renpy")
- (version "7.3.5")
(build-system python-build-system)
(arguments
`(#:tests? #f ; see python2-renpy
diff --git a/gnu/packages/patches/renpy-use-system-fribidi.patch b/gnu/packages/patches/renpy-use-system-fribidi.patch
index 1437274bcc..913415e317 100644
--- a/gnu/packages/patches/renpy-use-system-fribidi.patch
+++ b/gnu/packages/patches/renpy-use-system-fribidi.patch
@@ -2,22 +2,27 @@ See also [Arch] and [Gentoo] for similar patches in other distros.
[Arch] https://github.com/archlinux/svntogit-community/blob/packages/renpy/trunk/renpy-system-fribidi.patch
[Gentoo] https://gitweb.gentoo.org/repo/gentoo.git/tree/games-engines/renpy/files/renpy-7.3.5-use-system-fribidi.patch
-Index: renpy-7.3.5-source/module/renpybidicore.c
+Index: renpy-7.4.0-source/module/renpybidicore.c
===================================================================
---- renpy-7.3.5-source.orig/module/renpybidicore.c
-+++ renpy-7.3.5-source/module/renpybidicore.c
-@@ -1,5 +1,5 @@
+--- renpy-7.4.0-source.orig/module/renpybidicore.c
++++ renpy-7.4.0-source/module/renpybidicore.c
+@@ -1,9 +1,3 @@
#include <Python.h>
+-
+-#ifdef RENPY_BUILD
+ #include <fribidi.h>
+-#else
-#include <fribidi-src/lib/fribidi.h>
-+#include <fribidi.h>
+-#endif
+-
#include <stdlib.h>
#ifndef alloca
-Index: renpy-7.3.5-source/module/setup.py
+Index: renpy-7.4.0-source/module/setup.py
===================================================================
---- renpy-7.3.5-source.orig/module/setup.py
-+++ renpy-7.3.5-source/module/setup.py
-@@ -119,30 +119,13 @@ cython(
+--- renpy-7.4.0-source.orig/module/setup.py
++++ renpy-7.4.0-source/module/setup.py
+@@ -125,30 +125,13 @@ cython(
sdl + [ png, 'z', 'm' ])
FRIBIDI_SOURCES = """
--
2.30.0
L
L
Leo Prikler wrote on 23 Jan 2021 10:58
[PATCH v2 3/3] gnu: Minor whitespace cleanup.
(address . 45736@debbugs.gnu.org)
20210123095802.9500-3-leo.prikler@student.tugraz.at
* gnu/packages/game-development.scm: Update copyright line for previous renpy commits.
(love-nuklear): Strip space at the end of the line.
---
gnu/packages/game-development.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 4e218b5205..5bb26897a9 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -15,7 +15,7 @@
;;; Copyright © 2017, 2019 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
-;;; Copyright © 2019, 2020 Leo Prikler <leo.prikler@student.tugraz.at>
+;;; Copyright © 2019, 2020, 2021 Leo Prikler <leo.prikler@student.tugraz.at>
;;; Copyright © 2019 Jethro Cao <jethrocao@gmail.com>
;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2020 Timotej Lazar <timotej.lazar@araneo.si>
@@ -722,7 +722,7 @@ programming language.")
(url "https://github.com/keharriso/love-nuklear/")
(commit commit)
(recursive? #t)))
- ;; NOTE: the HEAD of the Nuklear git-submodule is at commit
+ ;; NOTE: the HEAD of the Nuklear git-submodule is at commit
;; "adc52d710fe3c87194b99f540c53e82eb75c2521" of Oct 1 2019
(file-name (git-file-name name version))
(sha256
--
2.30.0
L
L
Leo Prikler wrote on 7 Feb 2021 15:29
Re: [bug#46053] [PATCH 0/2] Add Ren'py build system
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)
2e82cd8cb0882ac3fde3b52b9ae897bb27ed32ba.camel@student.tugraz.at
Hello,

Am Sonntag, den 24.01.2021, 09:49 +0100 schrieb Nicolas Goaziou:
Toggle quote (1 lines)
> LGTM, in addition to #45736.
I've now pushed both this (well, v2 of it) and #45736.

Toggle quote (1 lines)
> It should also be documented in the manual.
Documentation is present in v2, which I've pushed. I hope it's
sufficient.

Regards,
Leo.
Closed
?