[PATCH] gnu: folly: Update to 2021.01.04.00.

  • Done
  • quality assurance status badge
Details
2 participants
  • Greg Hogan
  • Ludovic Courtès
Owner
unassigned
Submitted by
Greg Hogan
Severity
normal
G
G
Greg Hogan wrote on 8 Jan 2021 13:19
(address . guix-patches@gnu.org)
CA+3U0ZnMy7UBTU8DQi7P5VtKueSHQPUq=7saNFnBesXcx5_4CQ@mail.gmail.com
I went to build folly against core-updates and the link failed due to
missing dependencies on libicu*. This patch also updates the folly version.


From e710c98a2f5beef9d8640bf3618ae20bd12c12f7 Mon Sep 17 00:00:00 2001
From: Greg Hogan <code@greghogan.com>
Date: Thu, 7 Jan 2021 21:54:37 +0000
Subject: [PATCH] gnu: folly: Update to 2021.01.04.00.

* gnu/packages/cpp.scm (folly): Update to 2021.01.04.00.
[propagated-inputs]: Add icu4c.
---
gnu/packages/cpp.scm | 8 +++++---
1 file changed, 5 insertions(+), 3 deletions(-)

Toggle diff (49 lines)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 00e006928e..5032a5c58b 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -14,7 +14,7 @@
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Alexandros Theodotou <alex@zrythm.org>
-;;; Copyright © 2020 Greg Hogan <code@greghogan.com>
+;;; Copyright © 2020, 2021 Greg Hogan <code@greghogan.com>
;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
;;;
;;; This file is part of GNU Guix.
@@ -50,6 +50,7 @@
#:use-module (gnu packages crypto)
#:use-module (gnu packages curl)
#:use-module (gnu packages gcc)
+ #:use-module (gnu packages icu4c)
#:use-module (gnu packages libevent)
#:use-module (gnu packages libunwind)
#:use-module (gnu packages linux)
@@ -688,7 +689,7 @@ standard GNU style syntax for options.")
(define-public folly
(package
(name "folly")
- (version "2020.10.05.00")
+ (version "2021.01.04.00")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -697,7 +698,7 @@ standard GNU style syntax for options.")
(file-name (git-file-name name version))
(sha256
(base32
- "0q4w4cvjxffc462hvs8h4zryq4965j7015zvkwagcm6cj6wmz3cn"))))
+ "03r16q966p3qg4661ns6q5phmi67i536vi804ayja9fmd6hyfqdj"))))
(build-system cmake-build-system)
(arguments
'(;; Tests must be explicitly enabled
@@ -708,6 +709,7 @@ standard GNU style syntax for options.")
`(("boost" ,boost)
("gflags" ,gflags)
("glog" ,glog)
+ ("icu4c" ,icu4c)
("liburing" ,liburing)))
(inputs
`(("bzip2" ,bzip2)
--
2.29.2
Attachment: file
L
L
Ludovic Courtès wrote on 19 Jan 2021 15:59
(name . Greg Hogan)(address . code@greghogan.com)(address . 45727@debbugs.gnu.org)
87a6t5ht12.fsf@gnu.org
Hi Greg,

Greg Hogan <code@greghogan.com> skribis:

Toggle quote (12 lines)
> I went to build folly against core-updates and the link failed due to
> missing dependencies on libicu*. This patch also updates the folly version.
>
>
>>From e710c98a2f5beef9d8640bf3618ae20bd12c12f7 Mon Sep 17 00:00:00 2001
> From: Greg Hogan <code@greghogan.com>
> Date: Thu, 7 Jan 2021 21:54:37 +0000
> Subject: [PATCH] gnu: folly: Update to 2021.01.04.00.
>
> * gnu/packages/cpp.scm (folly): Update to 2021.01.04.00.
> [propagated-inputs]: Add icu4c.

If there’s a reason to propagate ICU4C, could you state it in a comment?
Otherwise, can we just move it to ‘inputs’?

Apart from that it LGTM, and it’s applicable to ‘master’.

Could you send an updated patch?

Thanks,
Ludo’.
G
G
Greg Hogan wrote on 26 Jan 2021 22:55
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 45727@debbugs.gnu.org)
CA+3U0Zk53XbQk0bP=rOuU_65YdDf2yyVQXfNH8RGjv8PsqVgLA@mail.gmail.com
Turns out this was an issue with Boost 1.75 (which I had patched over from
core-updates, requiring the C++20 support). I feel like I might as well
post the simple Folly version bump here and the core-updates Boost patch in
the following reply. Not sure when core-updates will be merged or if Boost
1.76 will be out by then.

From 334fc83ae2a3d92ba7813150709532b252592817 Mon Sep 17 00:00:00 2001
From: Greg Hogan <code@greghogan.com>
Date: Thu, 7 Jan 2021 21:54:37 +0000
Subject: [PATCH] gnu: folly: Update to 2021.01.25.00.

* gnu/packages/cpp.scm (folly): Update to 2021.01.25.00.
---
gnu/packages/cpp.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (63 lines)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index ca8f7a9f80..73a3ceb2df 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -14,7 +14,7 @@
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Alexandros Theodotou <alex@zrythm.org>
-;;; Copyright © 2020 Greg Hogan <code@greghogan.com>
+;;; Copyright © 2020, 2021 Greg Hogan <code@greghogan.com>
;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
;;;
;;; This file is part of GNU Guix.
@@ -689,7 +689,7 @@ standard GNU style syntax for options.")
(define-public folly
(package
(name "folly")
- (version "2020.10.05.00")
+ (version "2021.01.25.00")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -698,7 +698,7 @@ standard GNU style syntax for options.")
(file-name (git-file-name name version))
(sha256
(base32
- "0q4w4cvjxffc462hvs8h4zryq4965j7015zvkwagcm6cj6wmz3cn"))))
+ "14dl1g6vf7mc90mcync5h2lp14fwcx8n9h91pmiq6rfgv1fjjrwz"))))
(build-system cmake-build-system)
(arguments
'(;; Tests must be explicitly enabled
--
2.30.0

On Tue, Jan 19, 2021 at 9:59 AM Ludovic Courtès <ludo@gnu.org> wrote:

> Hi Greg,
>
> Greg Hogan <code@greghogan.com> skribis:
>
> > I went to build folly against core-updates and the link failed due to
> > missing dependencies on libicu*. This patch also updates the folly
> version.
> >
> >
> >>From e710c98a2f5beef9d8640bf3618ae20bd12c12f7 Mon Sep 17 00:00:00 2001
> > From: Greg Hogan <code@greghogan.com>
> > Date: Thu, 7 Jan 2021 21:54:37 +0000
> > Subject: [PATCH] gnu: folly: Update to 2021.01.04.00.
> >
> > * gnu/packages/cpp.scm (folly): Update to 2021.01.04.00.
> > [propagated-inputs]: Add icu4c.
>
> If there’s a reason to propagate ICU4C, could you state it in a comment?
> Otherwise, can we just move it to ‘inputs’?
>
> Apart from that it LGTM, and it’s applicable to ‘master’.
>
> Could you send an updated patch?
>
> Thanks,
> Ludo’.
>
Attachment: file
G
G
Greg Hogan wrote on 26 Jan 2021 22:57
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 45727@debbugs.gnu.org)
CA+3U0Z=x-69GFO8iTdz5q8qBCuotG20__6OJu6LuaDVOWT3o6g@mail.gmail.com
For core-updates.

From 03030191d82469532048f7a900291713e8208106 Mon Sep 17 00:00:00 2001
From: Greg Hogan <code@greghogan.com>
Date: Mon, 25 Jan 2021 17:35:27 +0000
Subject: [PATCH] gnu: boost: Patch transitive linking bug.

* gnu/packages/patches/boost-fix-transitive-linking.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/boost.scm (boost)[source]: Use it.
---
gnu/local.mk | 2 ++
gnu/packages/boost.scm | 3 +++
.../patches/boost-fix-transitive-linking.patch | 16 ++++++++++++++++
3 files changed, 21 insertions(+)
create mode 100644 gnu/packages/patches/boost-fix-transitive-linking.patch

Toggle diff (101 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index f84f859bdf..0e8e9c37b9 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -40,6 +40,7 @@
# Copyright © 2020 Malte Frank Gerdes <mate.f.gerdes@gmail.com>
# Copyright © 2020 Vinicius Monego <monego@posteo.net>
# Copyright © 2021 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
+# Copyright © 2021 Greg Hogan <code@greghogan.com>
#
# This file is part of GNU Guix.
#
@@ -866,6 +867,7 @@ dist_patch_DATA = \
%D%/packages/patches/blender-2.79-oiio2.patch \
%D%/packages/patches/blender-2.79-python-3.7-fix.patch \
%D%/packages/patches/blender-2.79-python-3.8-fix.patch \
+ %D%/packages/patches/boost-fix-transitive-linking.patch \
%D%/packages/patches/bpftrace-disable-bfd-disasm.patch \
%D%/packages/patches/byobu-writable-status.patch \
%D%/packages/patches/calibre-no-updates-dialog.patch \
diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index 1db173bd16..bc0e95b1ba 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -68,6 +69,8 @@
(uri (string-append "https://dl.bintray.com/boostorg/release/
"
version "/source/boost_"
(version-with-underscores version)
".tar.bz2"))
+ ; Should be included in next Boost update
+ (patches (search-patches
"boost-fix-transitive-linking.patch"))
(sha256
(base32
"1js9zpij58l60kx46s3lxdp5207igppjnhqigwhbpdvd04gb6gcm"))))
diff --git a/gnu/packages/patches/boost-fix-transitive-linking.patch
b/gnu/packages/patches/boost-fix-transitive-linking.patch
new file mode 100644
index 0000000000..a42feab109
--- /dev/null
+++ b/gnu/packages/patches/boost-fix-transitive-linking.patch
@@ -0,0 +1,16 @@
+Patch from https://github.com/boostorg/boost_install/issues/47
+which should be included in the Boost 1.76 release.
+
+This patch prevents CMake from explicitly linking against Boost
dependencies
+when building against the shared Boost libraries.
+--- a/tools/boost_install/boost-install.jam
++++ b/tools/boost_install/boost-install.jam
+@@ -483,7 +483,7 @@ rule generate-cmake-variant- ( target : sources * :
properties * )
+
+ .info " deps3=" $(deps3) ;
+
+- if $(deps3)
++ if $(deps3) && $(link) = static
+ {
+ print.text
+
--
2.30.0

On Tue, Jan 19, 2021 at 9:59 AM Ludovic Courtès <ludo@gnu.org> wrote:

> Hi Greg,
>
> Greg Hogan <code@greghogan.com> skribis:
>
> > I went to build folly against core-updates and the link failed due to
> > missing dependencies on libicu*. This patch also updates the folly
> version.
> >
> >
> >>From e710c98a2f5beef9d8640bf3618ae20bd12c12f7 Mon Sep 17 00:00:00 2001
> > From: Greg Hogan <code@greghogan.com>
> > Date: Thu, 7 Jan 2021 21:54:37 +0000
> > Subject: [PATCH] gnu: folly: Update to 2021.01.04.00.
> >
> > * gnu/packages/cpp.scm (folly): Update to 2021.01.04.00.
> > [propagated-inputs]: Add icu4c.
>
> If there’s a reason to propagate ICU4C, could you state it in a comment?
> Otherwise, can we just move it to ‘inputs’?
>
> Apart from that it LGTM, and it’s applicable to ‘master’.
>
> Could you send an updated patch?
>
> Thanks,
> Ludo’.
>
Attachment: file
L
L
Ludovic Courtès wrote on 26 Jan 2021 23:31
(name . Greg Hogan)(address . code@greghogan.com)(address . 45727@debbugs.gnu.org)
87bldbwcsa.fsf_-_@gnu.org
Hi,

Greg Hogan <code@greghogan.com> skribis:

Toggle quote (6 lines)
> Turns out this was an issue with Boost 1.75 (which I had patched over from
> core-updates, requiring the C++20 support). I feel like I might as well
> post the simple Folly version bump here and the core-updates Boost patch in
> the following reply. Not sure when core-updates will be merged or if Boost
> 1.76 will be out by then.

Sounds good to me.

Toggle quote (7 lines)
>>From 334fc83ae2a3d92ba7813150709532b252592817 Mon Sep 17 00:00:00 2001
> From: Greg Hogan <code@greghogan.com>
> Date: Thu, 7 Jan 2021 21:54:37 +0000
> Subject: [PATCH] gnu: folly: Update to 2021.01.25.00.
>
> * gnu/packages/cpp.scm (folly): Update to 2021.01.25.00.

Applied to ‘master’, thanks!
L
L
Ludovic Courtès wrote on 26 Jan 2021 23:41
(name . Greg Hogan)(address . code@greghogan.com)(address . 45727-done@debbugs.gnu.org)
877dnzwcci.fsf_-_@gnu.org
Greg Hogan <code@greghogan.com> skribis:

Toggle quote (9 lines)
>>From 03030191d82469532048f7a900291713e8208106 Mon Sep 17 00:00:00 2001
> From: Greg Hogan <code@greghogan.com>
> Date: Mon, 25 Jan 2021 17:35:27 +0000
> Subject: [PATCH] gnu: boost: Patch transitive linking bug.
>
> * gnu/packages/patches/boost-fix-transitive-linking.patch: New file.
> * gnu/local.mk (dist_patch_DATA): Add it.
> * gnu/packages/boost.scm (boost)[source]: Use it.

Pushed to ‘core-updates’. Thanks!

Ludo’.
Closed
?