[PATCH] gnu: Correct ZFS udev rules.

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • raid5atemyhomework
Owner
unassigned
Submitted by
raid5atemyhomework
Severity
normal
R
R
raid5atemyhomework wrote on 8 Jan 2021 06:31
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
ZMJg6M4vSHx2ED9-xAmuL-HFmgOTkXfaradEy90zBlySrdlZLihA_UU5QAzvH2XJ-WNesygZc5FGSbeISP8FdsA44G6Xjlb7OpuWQ2gcMP4=@protonmail.com
So ZFS has some udev rules, except one of them uses `/sbin/modprobe`, so we need to substitute it with an appropriate `modprobe`.

Slowly and surely ZFS is coming to Guix...


From 14322771ca333ff269f67cc41c4dcff8809da03b Mon Sep 17 00:00:00 2001
From: raid5atemyhomework <raid5atemyhomework@protonmail.com>
Date: Fri, 8 Jan 2021 13:11:53 +0800
Subject: [PATCH] gnu: Correct ZFS udev rules.

* gnu/packages/file-systems.scm (zfs): Add substitutions for /sbin/modprobe
in udev rules.
---
gnu/packages/file-systems.scm | 10 +++++++---
1 file changed, 7 insertions(+), 3 deletions(-)

Toggle diff (35 lines)
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index 2c5ad95d63..f74d519b33 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -885,7 +885,8 @@ APFS.")
(let ((out (assoc-ref outputs "out"))
(src (assoc-ref outputs "src"))
(util-linux (assoc-ref inputs "util-linux"))
- (nfs-utils (assoc-ref inputs "nfs-utils")))
+ (nfs-utils (assoc-ref inputs "nfs-utils"))
+ (kmod (assoc-ref inputs "kmod-runtime")))
(substitute* "contrib/Makefile.in"
;; This is not configurable nor is its hard-coded /usr prefix.
((" initramfs") ""))
@@ -915,7 +916,9 @@ APFS.")
(substitute* "contrib/pyzfs/Makefile.in"
((".*install-lib.*") ""))
(substitute* '("Makefile.am" "Makefile.in")
- (("\\$\\(prefix)/src") (string-append src "/src"))))
+ (("\\$\\(prefix)/src") (string-append src "/src")))
+ (substitute* (find-files "udev/rules.d/" ".rules.in$")
+ (("/sbin/modprobe") (string-append kmod "/bin/modprobe"))))
#t))
(replace 'build
(lambda _ (invoke "make")))
@@ -947,7 +950,8 @@ APFS.")
("python-cffi" ,python-cffi)
("util-linux" ,util-linux)
("util-linux:lib" ,util-linux "lib")
- ("zlib" ,zlib)))
+ ("zlib" ,zlib)
+ ("kmod-runtime" ,kmod)))
(home-page "https://zfsonlinux.org/")
(synopsis "Native ZFS on Linux")
(description
--
2.30.0
E
E
Efraim Flashner wrote on 20 Jan 2021 13:44
(name . raid5atemyhomework)(address . raid5atemyhomework@protonmail.com)(address . 45723-done@debbugs.gnu.org)
YAgllyjiBuBzWRc1@3900XT
I moved kmod-runtime so that it was sorted alphabetically and pushed the
patch.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmAIJZcACgkQQarn3Mo9
g1Gs/g//WT1yKbaWtRD+AEXsi6gVbfm+LfIOW7prVFfkjYdm3ZzzcsaTI0o+e3h/
LwIIUVYaI4LFthyqBQDIJuxrFftSkRQuWlgIsLm6cYDtTmgy/DBCf36PfSxt+ADq
ox7cTeDthEARPkQh6XAO1FiVLNaDGDf5OUujXLSj4eiAkakD3OnSQdk+WCVl+3zG
MXPuLSV51h4YLEl1e7ranu3MdAXcOhYfqaZHDlnSvRBDltJIKQYSEu0MmbLHytQ/
zMKXAflt+apuy+NSjOtiLdz7kIx9p20GN9F9yqvbleIXbZa6OUNB529VrBq6DFeb
3hlsDPMMbO/IEq3fAChmfk3Czpk0F1nUiWgkfj7NwleVjYwnfwzUL1iqdb+A3sGV
ukZ9QewBFaz2tK25S92E+RPw/3RO0UK7EFM16BDhsKEHcXp73VV/uEGfrfN+tTGI
ML30JgW4XCPQyVQE451jyl3qAM0tksD/0nWX0+ffhpKB29/fEp/BYDXpJZew8GAv
zH7gPy/jLk54ZMGDyfiPYyHxAecesMo7FGIJOcKvLTh/AlHWVhUF+qjvXVRhanrk
cFpxTh0DAJ2S4cpLjCu2I/LkLm4HeM2wJxXy+h65feJ3Z7bv6utkx/duJg4IsNve
m1pXQzz00kon9NYOz5tzFUxGF/5FVWmHJrQ7zMcU6Jnb/7aHUeI=
=h2Ue
-----END PGP SIGNATURE-----


Closed
?