[PATCH] gnu: libnode: Delete patch-node-shebang.

  • Done
  • quality assurance status badge
Details
One participant
  • Tim Howes
Owner
unassigned
Submitted by
Tim Howes
Severity
normal
T
T
Tim Howes wrote on 6 Jan 2021 18:42
[PATCH] * gnu/packages/node.scm (libnode): Delete patch-node-shebang.
(address . guix-patches@gnu.org)
20210106174215.15245-1-timhowes@lavabit.com
[arguments]: Delete patch-node-shebang phase inherited from node.
---
The build for libnode fails when it tries to run this phase.

gnu/packages/node.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index 9e07cd906e..687b5590ab 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2018, 2019, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2020 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2021 Tim Howes <timhowes@lavabit.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -238,4 +239,5 @@ devices.")
`(cons* "--shared" "--without-npm" ,flags))
((#:phases phases '%standard-phases)
`(modify-phases ,phases
- (delete 'patch-npm-shebang)))))))
+ (delete 'patch-npm-shebang)
+ (delete 'patch-node-shebang)))))))

base-commit: f40ddf95a34944673cd6262b7aae0c643e653ff9
--
2.30.0
T
T
Tim Howes wrote on 8 Jan 2021 21:32
[PATCH v2] gnu: libnode: Delete patch-node-shebang.
(address . 45697@debbugs.gnu.org)
875z47np9q.fsf@lavabit.com
Fixed the commit message formatting.
From 4237b0f79b50f6783f6389e82b28a6daefec0a47 Mon Sep 17 00:00:00 2001
From: Tim Howes <timhowes@lavabit.com>
Date: Wed, 6 Jan 2021 09:20:00 -0800
Subject: [PATCH] gnu: libnode: Delete patch-node-shebang.

* gnu/packages/node.scm (libnode): Delete patch-node-shebang.
[arguments]: Delete patch-node-shebang phase inherited from node.
---
The build for libnode fails when it tries to run this phase.

gnu/packages/node.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index 9e07cd906e..687b5590ab 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2018, 2019, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2020 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2021 Tim Howes <timhowes@lavabit.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -238,4 +239,5 @@ devices.")
`(cons* "--shared" "--without-npm" ,flags))
((#:phases phases '%standard-phases)
`(modify-phases ,phases
- (delete 'patch-npm-shebang)))))))
+ (delete 'patch-npm-shebang)
+ (delete 'patch-node-shebang)))))))

base-commit: f40ddf95a34944673cd6262b7aae0c643e653ff9
--
2.30.0
T
T
Tim Howes wrote on 8 Jan 2021 21:38
(address . control@debbugs.gnu.org)
8735zbnp02.fsf@lavabit.com
retitle 45697 [PATCH] gnu: libnode: Delete patch-node-shebang.
thanks
T
T
Tim Howes wrote on 20 Jan 2021 23:00
(address . control@debbugs.gnu.org)
4ff63513-962d-00a3-f006-0e7508675321@lavabit.com
close 45697
thanks

Fixed in #45862
?