[PATCH] Add three Jekyll plugins.

  • Done
  • quality assurance status badge
Details
2 participants
  • Björn Höfling
  • paul
Owner
unassigned
Submitted by
paul
Severity
normal
P
(address . guix-patches@gnu.org)
9a3ed9b8-d22d-7ccd-3fb5-f83deba1b765@autistici.org
Dear Guixers,

I'm sending a patch series to add three Jekyll plugins.

Thank you,

Giacomo
G
G
Giacomo Leidi wrote on 4 Jan 2021 02:00
[PATCH 1/3] gnu: Add ruby-jekyll-feed.
(address . 45642@debbugs.gnu.org)(name . Giacomo Leidi)(address . goodoldpaul@autistici.org)
20210104010014.15582-1-goodoldpaul@autistici.org
* gnu/packages/ruby.scm (ruby-jekyll-feed): New variable.
---
gnu/packages/ruby.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index c5b1af79d3..03b287abc1 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -11758,3 +11758,28 @@ defined in @file{.travis.yml} on your local machine, using @code{rvm},
you the speed and portability of libgit2 with the beauty of the Ruby
language.")
(license license:expat)))
+
+(define-public ruby-jekyll-feed
+ (package
+ (name "ruby-jekyll-feed")
+ (version "0.15.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "jekyll-feed" version))
+ (sha256
+ (base32
+ "1zxqkrnix0xiw98531h5ga6h69jhzlx2jh9qhvcl67p8nq3sgza9"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #false)) ;there are none
+ (propagated-inputs
+ `(("jekyll" ,jekyll)))
+ (synopsis
+ "Jekyll plugin to generate an Atom feed of your Jekyll posts")
+ (description
+ "This package provides a Jekyll plugin to generate an Atom feed
+of your Jekyll posts.")
+ (home-page
+ "https://github.com/jekyll/jekyll-feed")
+ (license license:expat)))
--
2.29.2
G
G
Giacomo Leidi wrote on 4 Jan 2021 02:00
[PATCH 2/3] gnu: Add ruby-jekyll-sitemap.
(address . 45642@debbugs.gnu.org)(name . Giacomo Leidi)(address . goodoldpaul@autistici.org)
20210104010014.15582-2-goodoldpaul@autistici.org
* gnu/packages/ruby.scm (ruby-jekyll-sitemap): New variable.
---
gnu/packages/ruby.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 03b287abc1..55867297ec 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -11783,3 +11783,28 @@ of your Jekyll posts.")
(home-page
"https://github.com/jekyll/jekyll-feed")
(license license:expat)))
+
+(define-public ruby-jekyll-sitemap
+ (package
+ (name "ruby-jekyll-sitemap")
+ (version "1.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "jekyll-sitemap" version))
+ (sha256
+ (base32
+ "0622rwsn5i0m5xcyzdn86l68wgydqwji03lqixdfm1f1xdfqrq0d"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #false)) ;there are none
+ (propagated-inputs
+ `(("jekyll" ,jekyll)))
+ (synopsis
+ "Automatically generate a sitemap.xml for your Jekyll site")
+ (description
+ "This package provides a Jekyll plugin to silently generate
+a sitemaps.org compliant sitemap for your Jekyll site.")
+ (home-page
+ "https://github.com/jekyll/jekyll-sitemap")
+ (license license:expat)))
--
2.29.2
G
G
Giacomo Leidi wrote on 4 Jan 2021 02:00
[PATCH 3/3] gnu: Add ruby-jekyll-seo-tag.
(address . 45642@debbugs.gnu.org)(name . Giacomo Leidi)(address . goodoldpaul@autistici.org)
20210104010014.15582-3-goodoldpaul@autistici.org
* gnu/packages/ruby.scm (ruby-jekyll-seo-tag): New variable.
---
gnu/packages/ruby.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 55867297ec..14c69c4065 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -11808,3 +11808,28 @@ a sitemaps.org compliant sitemap for your Jekyll site.")
(home-page
"https://github.com/jekyll/jekyll-sitemap")
(license license:expat)))
+
+(define-public ruby-jekyll-seo-tag
+ (package
+ (name "ruby-jekyll-seo-tag")
+ (version "2.7.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "jekyll-seo-tag" version))
+ (sha256
+ (base32
+ "0fsi75hymk2wswy216fs224p5ycrzjw1kshw1bsl5czhv42wr2w3"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #false))
+ (propagated-inputs
+ `(("jekyll" ,jekyll)))
+ (synopsis
+ "Jekyll plugin to add metadata tags for search engines and social networks")
+ (description
+ "This package provides a Jekyll plugin to add metadata tags for search engines
+and social networks to better index and display your site's content.")
+ (home-page
+ "https://github.com/jekyll/jekyll-seo-tag")
+ (license license:expat)))
--
2.29.2
B
B
Björn Höfling wrote on 28 Feb 2021 23:18
Re: [bug#45642] [PATCH] Add three Jekyll plugins.
(name . paul)(address . goodoldpaul@autistici.org)(address . 45642-done@debbugs.gnu.org)
20210228231846.0ec6f2d8@alma-ubu
On Mon, 4 Jan 2021 01:58:36 +0100
paul <goodoldpaul@autistici.org> wrote:

Toggle quote (4 lines)
> Dear Guixers,
>
> I'm sending a patch series to add three Jekyll plugins.

Pushed as

d4baac70b85ec5f9690328c5e0b0adee84b6b420

Thanks,

Björn
-----BEGIN PGP SIGNATURE-----

iF0EAREKAB0WIQQiGUP0np8nb5SZM4K/KGy2WT5f/QUCYDwWxgAKCRC/KGy2WT5f
/an9AKCxa+V/bG45EwN3s6h7ABycN0mFjgCfd5iQKZ5tXjS1L4aaPX4ues5om3Q=
=LI9r
-----END PGP SIGNATURE-----


Closed
?