[PATCH] Add js_of_ocaml

  • Done
  • quality assurance status badge
Details
2 participants
  • divoplade
  • pukkamustard
Owner
unassigned
Submitted by
divoplade
Severity
normal
D
D
divoplade wrote on 30 Dec 2020 20:22
(address . guix-patches@gnu.org)
559a908f91e39af40a1580447a708209785c69b8.camel@divoplade.fr
Dear guix,

I finally got js_of_ocaml packaged. I'm not sure I did everything
correctly (especially indentation, but also how to make non-4.07
packages, and whether the package should have multiple outputs
corresponding to the opam packages), so do not hesitate to sendfeedback.

Best regards,

divoplade
From 0a753eb2d96b2deb7059bce0be6846f6623a85e4 Mon Sep 17 00:00:00 2001
From: divoplade <d@divoplade.fr>
Date: Wed, 30 Dec 2020 18:45:28 +0100
Subject: [PATCH 1/5] gnu: Add ocaml-compiler-libs

* gnu/packages/ocaml.scm (ocaml-compiler-libs): New variable.
(ocaml4.07-compiler-libs): Inherit from ocaml-compiler-libs.
---
gnu/packages/ocaml.scm | 45 +++++++++++++++++++++++++++++++-----------
1 file changed, 33 insertions(+), 12 deletions(-)

Toggle diff (87 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 2df16e7cd2..4b1ed09a79 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3683,7 +3683,7 @@ syntax checking on dedukti files.")
`(("ocaml-base" ,(package-with-ocaml4.07 ocaml-base))
("ocaml-migrate-parsetree"
,(package-with-ocaml4.07 ocaml-migrate-parsetree))
- ("ocaml-compiler-libs" ,ocaml4.07-compiler-libs)
+ ("ocaml-compiler-libs" ,(package-with-ocaml4.07 ocaml-compiler-libs))
("ocaml-sexplib0" ,(package-with-ocaml4.07 ocaml-sexplib0))
("ocaml-stdio" ,ocaml4.07-stdio)
("ocaml-ppxlib" ,ocaml4.07-ppxlib)))
@@ -4285,10 +4285,10 @@ provided by companion libraries such as
#:dune ,ocaml4.07-dune))
(properties '()))))
-(define-public ocaml4.07-compiler-libs
+(define-public ocaml-compiler-libs
(package
- (name "ocaml4.07-compiler-libs")
- (version "0.11.0")
+ (name "ocaml-compiler-libs")
+ (version "0.12.3")
(home-page "https://github.com/janestreet/ocaml-compiler-libs")
(source
(origin
@@ -4299,20 +4299,41 @@ provided by companion libraries such as
(file-name (git-file-name name version))
(sha256
(base32
- "03jds7bszh8wwpfwxb3dg0gyr1j1872wxwx1xqhry5ir0i84bg0s"))))
+ "00nrar7h2pyflbdiq6wwwrb4k5jh9iff0jllihzm6ms8d5pspsg5"))))
(build-system dune-build-system)
- (arguments
- `(#:tests? #f ;no tests
- #:ocaml ,ocaml-4.07
- #:findlib ,ocaml4.07-findlib
- #:dune ,ocaml4.07-dune))
- (properties `((upstream-name . "ocaml-compiler-libs")))
+ (arguments `(#:tests? #f))
+ (properties `((upstream-name . "ocaml-compiler-libs")
+ (ocaml4.07-variant . ,(delay ocaml4.07-compiler-libs))))
(synopsis "Compiler libraries repackaged")
(description "This package simply repackages the OCaml compiler libraries
so they don't expose everything at toplevel. For instance, @code{Ast_helper}
is now @code{Ocaml_common.Ast_helper}.")
(license license:expat)))
+(define-public ocaml4.07-compiler-libs
+ (package-with-ocaml4.07
+ (package
+ (inherit ocaml-compiler-libs)
+ (name "ocaml4.07-compiler-libs")
+ (version "0.11.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append (package-home-page ocaml-compiler-libs)
+ ".git"))
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "03jds7bszh8wwpfwxb3dg0gyr1j1872wxwx1xqhry5ir0i84bg0s"))))
+ (arguments
+ `(#:tests? #f ;no tests
+ #:ocaml ,ocaml-4.07
+ #:findlib ,ocaml4.07-findlib
+ #:dune ,ocaml4.07-dune))
+ (properties '()))))
+
(define-public ocaml4.07-stdio
(package
(name "ocaml4.07-stdio")
@@ -4389,7 +4410,7 @@ as part of the same ocaml-migrate-parsetree driver.")
(build-system dune-build-system)
(propagated-inputs
`(("ocaml-base" ,(package-with-ocaml4.07 ocaml-base))
- ("ocaml-compiler-libs" ,ocaml4.07-compiler-libs)
+ ("ocaml-compiler-libs" ,(package-with-ocaml4.07 ocaml-compiler-libs))
("ocaml-migrate-parsetree"
,(package-with-ocaml4.07 ocaml-migrate-parsetree))
("ocaml-ppx-derivers" ,(package-with-ocaml4.07 ocaml-ppx-derivers))
--
2.29.2
From c53824f13472d91cd7087e965976876725164e66 Mon Sep 17 00:00:00 2001
From: divoplade <d@divoplade.fr>
Date: Wed, 30 Dec 2020 19:06:57 +0100
Subject: [PATCH 4/5] gnu: Add ocaml-graphics

---
gnu/packages/ocaml.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 828dd6ff73..353394e4d4 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6148,3 +6148,32 @@ provides support to program with time varying values: declarative events and
signals. React doesn't define any primitive event or signal, it lets the
client chooses the concrete timeline.")
(license license:lgpl2.1+)))
+
+(define-public ocaml-graphics
+ (package
+ (name "ocaml-graphics")
+ (version "5.1.0")
+ (home-page "https://github.com/ocaml/graphics")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append home-page ".git"))
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1ilw5r1lpy88fpfcpifxxbdg74f468jb5xhimw92iwmr410gnqp2"))))
+ (build-system dune-build-system)
+ (propagated-inputs
+ `(("dune-configurator" ,dune-configurator)
+ ("libx11" ,libx11)
+ ("pkg-config" ,pkg-config)))
+ (synopsis "The OCaml graphics library")
+ (description
+ "The graphics library provides a set of portable drawing
+primitives. Drawing takes place in a separate window that is created
+when Graphics.open_graph is called.
+
+This library used to be distributed with OCaml up to OCaml 4.08.")
+ (license license:lgpl2.1+)))
--
2.29.2
From 151ffb96657268adf40103d8c4aac04f4d3a61fb Mon Sep 17 00:00:00 2001
From: divoplade <d@divoplade.fr>
Date: Wed, 30 Dec 2020 19:08:57 +0100
Subject: [PATCH 5/5] gnu: Add ocaml-js-of-ocaml

---
gnu/packages/ocaml.scm | 38 ++++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 353394e4d4..ce1d09f936 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6177,3 +6177,41 @@ when Graphics.open_graph is called.
This library used to be distributed with OCaml up to OCaml 4.08.")
(license license:lgpl2.1+)))
+
+(define-public ocaml-js-of-ocaml
+ (package
+ (name "ocaml-js-of-ocaml")
+ (version "3.8.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ocsigen/js_of_ocaml")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ls3nhavhifsfwwz45k4xw91ml9zi6rnkfp3175b2havbavbzral"))))
+ (build-system dune-build-system)
+ (arguments `(#:tests? #f))
+ (propagated-inputs
+ `(("ocaml-ppxlib" ,ocaml-ppxlib)
+ ("ocaml-uchar" ,ocaml-uchar)
+ ("ocaml-menhir" ,ocaml-menhir)
+ ("ocaml-reactivedata" ,ocaml-reactivedata)
+ ("ocaml-cmdliner" ,ocaml-cmdliner)
+ ("ocaml-lwt" ,ocaml-lwt)
+ ("ocaml-tyxml" ,ocaml-tyxml)
+ ("ocaml-re" ,ocaml-re)
+ ("ocaml-uutf" ,ocaml-uutf)
+ ("ocaml-graphics" ,ocaml-graphics)))
+ (properties `((upstream-name . "js_of_ocaml")))
+ (home-page
+ "http://ocsigen.github.io/js_of_ocaml")
+ (synopsis
+ "Compiler from OCaml bytecode to Javascript")
+ (description
+ "Js_of_ocaml is a compiler from OCaml bytecode to JavaScript.
+It makes it possible to run pure OCaml programs in JavaScript
+environment like browsers and Node.js
+")
+ (license license:lgpl2.1+)))
--
2.29.2
P
P
pukkamustard wrote on 3 May 2021 14:38
(name . divoplade)(address . d@divoplade.fr)
86im3z9gdd.fsf@posteo.net
Hi divoplade,

divoplade <d@divoplade.fr> writes:

Toggle quote (2 lines)
> I finally got js_of_ocaml packaged.

Thank you!

Toggle quote (2 lines)
> I'm not sure I did everything correctly (especially indentation

There do seem to be some indentation issues. Have you seen the
section "Formatting Code" in the Guix manual? There is also a
little script in the guix repository that will automatically
indent a package definition.

Also your commit logs don't seem to be exactly in the required
format. For example: "gnu: add ocaml-ppxlib" should be "gnu: Add
ocaml-ppxlib.". Check the section "Submitting Patches" in the Guix
manual and also the commit history for examples.

There are also some things that the linter discovers. For example
you can omit the ".git" suffix for GitHub sources or that
pkg-config is not needed in ocaml-graphics. You can run `git lint
PACKAGE` too see what the linter has to say (and maybe should do
that for modified package definitions).

Toggle quote (2 lines)
> , but also how to make non-4.07 packages

This looks ok.

I submitted a series of patches that does this for many OCaml
packages including the ones included in your series
(https://issues.guix.gnu.org/47768).I'm sorry I should have
included your work in my patch series instead of duplicating.

Maybe a small difference is that the patches in #47769 include a
more recent version of ocaml-ppxlib (and the required version of
ocaml-migrate-parsetree).

I have updated your patches for ocaml-graphics and js_of_ocaml so
that they can be applied on #47769. Some changes in the attached
patches:

ocaml-graphics:
- Use version 5.1.1 instead of 5.1.0 (5.1.1 was released after you
submitted the patches)
- Remove unnecessary inputs
- Change git-reference url to homepage (GitHub without the ".git"
suffix)
- Minor changes to description too make linter happy

ocaml-js-of-ocaml:
- Use version 3.9.0 instead of 3.8.0 (again released after you
submitted the patches)
- Enable source maps by including ocaml-yojson as input
- Enable tests (this requires ocaml-ppx-expect,
ocaml-ppx-variants-conv, ocaml-variantslib and an updated
version of ocaml-num)
From ef943e9e01e979a3de7c84d88d5f8d3d6535da9a Mon Sep 17 00:00:00 2001
From: divoplade <d@divoplade.fr>
Date: Wed, 30 Dec 2020 19:06:57 +0100
Subject: [PATCH 1/6] gnu: Add ocaml-graphics.

* gnu/packages/ocaml.scm (ocaml-graphics): New variable.

Co-Authored-By: pukkamustard <pukkamustard@posteo.net>
---
gnu/packages/ocaml.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index c390a8bce9..4727b294d9 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6900,3 +6900,29 @@ Both interfaces give the user total control over the blocking behavior of
their application, with the unbuffered interface enabling zero-copy IO.
Parsers are backtracking by default and support unbounded lookahead.")
(license license:bsd-3)))
+
+(define-public ocaml-graphics
+ (package
+ (name "ocaml-graphics")
+ (version "5.1.1")
+ (home-page "https://github.com/ocaml/graphics")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "14w07ydji2nbdk366nfp2pzs9484xp9vqv63n345id13v48z8bfi"))))
+ (build-system dune-build-system)
+ (propagated-inputs
+ `(("libx11" ,libx11)))
+ (synopsis "The OCaml graphics library")
+ (description
+ "The graphics library provides a set of portable drawing primitives.
+Drawing takes place in a separate window that is created when
+Graphics.open_graph is called. This library used to be distributed with OCaml
+up to OCaml 4.08.")
+ (license license:lgpl2.1+)))
--
2.31.1
From 96f9bb75aa9a401f353619d112e414eab2745db1 Mon Sep 17 00:00:00 2001
From: pukkamustard <pukkamustard@posteo.net>
Date: Mon, 3 May 2021 22:49:23 +0200
Subject: [PATCH 2/6] gnu: Add ocaml-variantslib.

* gnu/packages/ocaml.scm (ocaml-variantslib): New variable.
(ocaml4.07-variantslib): Inherit from ocaml-variantslib.
---
gnu/packages/ocaml.scm | 52 ++++++++++++++++++++++++------------------
1 file changed, 30 insertions(+), 22 deletions(-)

Toggle diff (90 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 4727b294d9..e40bc78db2 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5137,37 +5137,45 @@ of a record and create new record values.")
"12948pzxrl360lybm9fzyvplgcl87zjbn4m3sk1aw75zk85p1388"))
(properties `((upstream-name . "fieldslib"))))))
-(define-public ocaml4.07-variantslib
+(define-public ocaml-variantslib
(package
- (name "ocaml4.07-variantslib")
- (version "0.11.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://ocaml.janestreet.com/ocaml-core/v"
- (version-major+minor version)
- "/files/variantslib-v" version ".tar.gz"))
- (sha256
- (base32
- "1hsdwmkslvk4cznqr4lyyiy7vvk5spil226k0z2in26fxq6y0hf3"))))
+ (name "ocaml-variantslib")
+ (version "0.14.0")
+ (source
+ (janestreet-origin "variantslib" version
+ "11zp27gh282dx9ifbhcp6i7fkc97fvk8amaj58mf1g1hwklc0lm3"))
(build-system dune-build-system)
(arguments
;; No tests
- `(#:tests? #f
- #:ocaml ,ocaml-4.07
- #:findlib ,ocaml4.07-findlib
- #:dune ,ocaml4.07-dune))
+ `(#:tests? #f))
(propagated-inputs
- `(("ocaml-base" ,(package-with-ocaml4.07 ocaml-base))
- ("ocaml-migrate-parsetree"
- ,(package-with-ocaml4.07 ocaml-migrate-parsetree))
- ("ocaml-ppxlib" ,(package-with-ocaml4.07 ocaml-ppxlib))))
- (properties `((upstream-name . "variantslib")))
+ `(("ocaml-base" ,ocaml-base)
+ ("ocaml-migrate-parsetree" ,ocaml-migrate-parsetree)
+ ("ocaml-ppxlib" ,ocaml-ppxlib)))
+ (properties `((upstream-name . "variantslib")
+ (ocaml4.07-variant . ,(delay ocaml4.07-variantslib))))
(home-page "https://github.com/janestreet/variantslib")
(synopsis "OCaml variants as first class values")
(description "The Core suite of libraries is an alternative to OCaml's
standard library.")
(license license:asl2.0)))
+(define-public ocaml4.07-variantslib
+ (package-with-ocaml4.07
+ (package
+ (inherit ocaml-variantslib)
+ (name "ocaml-variantslib")
+ (version "0.11.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://ocaml.janestreet.com/ocaml-core/v"
+ (version-major+minor version)
+ "/files/variantslib-v" version ".tar.gz"))
+ (sha256
+ (base32
+ "1hsdwmkslvk4cznqr4lyyiy7vvk5spil226k0z2in26fxq6y0hf3"))))
+ (properties `((upstream-name . "variantslib"))))))
+
(define-public ocaml-ppx-fields-conv
(package
(name "ocaml-ppx-fields-conv")
@@ -5268,7 +5276,7 @@ definitions.")
(build-system dune-build-system)
(propagated-inputs
`(("ocaml-base" ,(package-with-ocaml4.07 ocaml-base))
- ("ocaml-variantslib" ,ocaml4.07-variantslib)
+ ("ocaml-variantslib" ,(package-with-ocaml4.07 ocaml-variantslib))
("ocaml-migrate-parsetree"
,(package-with-ocaml4.07 ocaml-migrate-parsetree))
("ocaml-ppxlib" ,(package-with-ocaml4.07 ocaml-ppxlib))))
@@ -6312,7 +6320,7 @@ standard library that was developed by Jane Street.")
("ocaml-splittable-random" ,ocaml4.07-splittable-random)
("ocaml-stdio" ,(package-with-ocaml4.07 ocaml-stdio))
("ocaml-typerep" ,ocaml4.07-typerep)
- ("ocaml-variantslib" ,ocaml4.07-variantslib)
+ ("ocaml-variantslib" ,(package-with-ocaml4.07 ocaml-variantslib))
("ocaml-migrate-parsetree"
,(package-with-ocaml4.07 ocaml-migrate-parsetree))))
(properties `((upstream-name . "core_kernel")))
--
2.31.1
From ac57c989bb2dab51e45561c3faeed8ef5a52cb3a Mon Sep 17 00:00:00 2001
From: pukkamustard <pukkamustard@posteo.net>
Date: Tue, 4 May 2021 07:58:43 +0200
Subject: [PATCH 5/6] gnu: ocaml-num: Update to 1.4.

* gnu/packages/ocaml.scm (ocaml-num): Update to 1.4.
---
gnu/packages/ocaml.scm | 31 +++----------------------------
1 file changed, 3 insertions(+), 28 deletions(-)

Toggle diff (51 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index c4a024c850..349124c99e 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -958,7 +958,7 @@ written in Objective Caml.")
(define-public ocaml-num
(package
(name "ocaml-num")
- (version "1.1")
+ (version "1.4")
(source
(origin
(method git-fetch)
@@ -967,33 +967,8 @@ written in Objective Caml.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0a4mhxgs5hi81d227aygjx35696314swas0vzy3ig809jb7zq4h0"))))
- (build-system ocaml-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (add-before 'build 'fix-makefile
- (lambda* (#:key outputs #:allow-other-keys)
- ;; This package supposes we install to the same directory as
- ;; the ocaml package.
- (substitute* "src/META"
- (("\"\\^\"") (string-append "\"" (assoc-ref outputs "out")
- "/lib/ocaml/site-lib\"")))
- (substitute* "src/Makefile"
- (("\\) \\$\\(STDLIBDIR\\)")
- (string-append ") " (assoc-ref outputs "out")
- "/lib/ocaml/site-lib")))
- #t))
- (add-after 'install 'fix-stubslib
- (lambda* (#:key outputs #:allow-other-keys)
- (format #t "~a~%" (find-files "." ".*.so"))
- (let ((stubdir (string-append (assoc-ref outputs "out")
- "/lib/ocaml/site-lib/stublibs")))
- (delete-file stubdir)
- (mkdir-p stubdir)
- (install-file "src/dllnums.so" stubdir))
- #t)))))
+ (base32 "1vzdnvpj5dbj3ifx03v25pj2jj1ccav072v4d29pk1czdba2lzfc"))))
+ (build-system dune-build-system)
(home-page "https://github.com/ocaml/num")
(synopsis "Arbitrary-precision integer and rational arithmetic")
(description "OCaml-Num contains the legacy Num library for
--
2.31.1
From 7a19c648423b31d2322a86dc762dd01e39c417c0 Mon Sep 17 00:00:00 2001
From: divoplade <d@divoplade.fr>
Date: Wed, 30 Dec 2020 19:08:57 +0100
Subject: [PATCH 6/6] gnu: Add ocaml-js-of-ocaml.

* gnu/packages/ocaml.scm (ocaml-js-of-ocaml): New variable.

Co-Authored-By: pukkamustard <pukkamustard@posteo.net>
---
gnu/packages/ocaml.scm | 41 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (58 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 349124c99e..24d9e814fa 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -61,6 +61,7 @@
#:use-module (gnu packages maths)
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages ncurses)
+ #:use-module (gnu packages node)
#:use-module (gnu packages pcre)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
@@ -6939,3 +6940,43 @@ Drawing takes place in a separate window that is created when
Graphics.open_graph is called. This library used to be distributed with OCaml
up to OCaml 4.08.")
(license license:lgpl2.1+)))
+
+(define-public ocaml-js-of-ocaml
+ (package
+ (name "ocaml-js-of-ocaml")
+ (version "3.9.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ocsigen/js_of_ocaml")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "00hdjaj94j3nc6f6wbbpx59h4yc79siphs34i1hry11r56paaqyk"))))
+ (build-system dune-build-system)
+ (arguments `(#:test-target "."))
+ (propagated-inputs
+ `(("ocaml-ppxlib" ,ocaml-ppxlib)
+ ("ocaml-uchar" ,ocaml-uchar)
+ ("ocaml-menhir" ,ocaml-menhir)
+ ("ocaml-reactivedata" ,ocaml-reactivedata)
+ ("ocaml-cmdliner" ,ocaml-cmdliner)
+ ("ocaml-lwt" ,ocaml-lwt)
+ ("ocaml-tyxml" ,ocaml-tyxml)
+ ("ocaml-re" ,ocaml-re)
+ ("ocaml-uutf" ,ocaml-uutf)
+ ("ocaml-graphics" ,ocaml-graphics)
+ ("ocaml-yojson" ,ocaml-yojson)))
+ (native-inputs
+ ;; for tests
+ `(("node" ,node)
+ ("ocaml-ppx-expect" ,ocaml-ppx-expect)
+ ("ocaml-num" ,ocaml-num)))
+ (properties `((upstream-name . "js_of_ocaml")))
+ (home-page "https://ocsigen.org/js_of_ocaml/")
+ (synopsis "Compiler from OCaml bytecode to Javascript")
+ (description "Js_of_ocaml is a compiler from OCaml bytecode to JavaScript.
+It makes it possible to run pure OCaml programs in JavaScript environment like
+browsers and Node.js.")
+ (license license:lgpl2.1+)))
--
2.31.1
Best regards,
pukkamustard
D
D
divoplade wrote on 4 May 2021 11:10
(name . pukkamustard)(address . pukkamustard@posteo.net)
d119a73d318ec0bc0de19ca05ac9343253eb9adf.camel@divoplade.fr
Hello,

Thank you for the interest in this issue. I realize I opened it at a
rather inconvenient time, so I guess it ended up on the bottom of the
pile for quite some time.

Le lundi 03 mai 2021 à 12:38 +0000, pukkamustard a écrit :
Toggle quote (4 lines)
> I submitted a series of patches that does this for many OCaml
> packages including the ones included in your series
> (https://issues.guix.gnu.org/47768).

The situation is quite complex to me, please bear with me. If I
understand correctly, you pushed a lot of ocaml updates last month,
making some of the changes I made in december somewhat obsolete. Right?

So, now, I should your modified 5 patches in this issue on top of the
37 patches in the other issue to get js-of-ocaml. Is it correct?

At this rate, if it is possible, maybe you could just append these 5 to
the other issue, it would be easier to track.

What do you think?

I didn’t detect indentation problems by running ./etc/indent-code.el;
even if other packages in the module have some indentation problems.
P
P
pukkamustard wrote on 10 May 2021 07:18
(name . divoplade)(address . d@divoplade.fr)
86fsyvb1a4.fsf@posteo.net
Hi divoplade,

divoplade <d@divoplade.fr> writes:

[...]

Toggle quote (9 lines)
> So, now, I should your modified 5 patches in this issue on top
> of the
> 37 patches in the other issue to get js-of-ocaml. Is it correct?
>
> At this rate, if it is possible, maybe you could just append
> these 5 to
> the other issue, it would be easier to track.
>
> What do you think?
Yeah, that makes sense. I just submitted a V2 of #47768
(https://issues.guix.gnu.org/47768)that includes your patches for
js_of_ocaml, merging the issues.

Closing this issue in favor of #47769.

-pukkamustard
Closed
?