[PATCH] gnu: hdf5: Update to 1.12.0.

  • Done
  • quality assurance status badge
Details
4 participants
  • Efraim Flashner
  • Leo Famulari
  • Vincent Legoll
  • zimoun
Owner
unassigned
Submitted by
Vincent Legoll
Severity
normal
V
V
Vincent Legoll wrote on 29 Dec 2020 13:12
(address . guix-patches@gnu.org)(name . Vincent Legoll)(address . vincent.legoll@gmail.com)
20201229121203.5353-1-vincent.legoll@gmail.com
* gnu/packages/maths.scm (hdf5): Update to 1.12.0.
---
gnu/packages/maths.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index b54cd6dff1..09e0837872 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1200,7 +1200,7 @@ extremely large and complex data collections.")
(define-public hdf5-1.10
(package/inherit hdf5-1.8
- (version "1.10.7")
+ (version "1.12.0")
(source
(origin
(method url-fetch)
@@ -1214,7 +1214,7 @@ extremely large and complex data collections.")
(take (string-split version #\.) 2))
"/src/hdf5-" version ".tar.bz2")))
(sha256
- (base32 "0pm5xxry55i0h7wmvc7svzdaa90rnk7h78rrjmnlkz2ygsn8y082"))
+ (base32 "0qazfslkqbmzg495jafpvqp0khws3jkxa0z7rph9qvhacil6544p"))
(patches (search-patches "hdf5-config-date.patch"))))))
(define-public hdf5
--
2.29.2
L
L
Leo Famulari wrote on 30 Dec 2020 03:19
(name . Vincent Legoll)(address . vincent.legoll@gmail.com)(address . 45531@debbugs.gnu.org)
X+vjt7JY7mYDbCsp@jasmine.lan
On Tue, Dec 29, 2020 at 01:12:03PM +0100, Vincent Legoll wrote:
Toggle quote (2 lines)
> * gnu/packages/maths.scm (hdf5): Update to 1.12.0.

Thanks!

Toggle quote (5 lines)
> (define-public hdf5-1.10
> (package/inherit hdf5-1.8
> - (version "1.10.7")
> + (version "1.12.0")

The variable name should be updated to reflect the new version, and any
packages using it would also need to be adjusted.

Can you send a revised patch?
V
V
Vincent Legoll wrote on 30 Dec 2020 17:01
(name . Leo Famulari)(address . leo@famulari.name)(address . 45531@debbugs.gnu.org)
CAEwRq=odMVVXL+6qkVJywZfak9Avjfra4AdNYEKHrsa2M6qk7g@mail.gmail.com
Hello,

On Wed, Dec 30, 2020 at 3:19 AM Leo Famulari <leo@famulari.name> wrote:
Toggle quote (8 lines)
> > (define-public hdf5-1.10
> > (package/inherit hdf5-1.8
> > - (version "1.10.7")
> > + (version "1.12.0")
>
> The variable name should be updated to reflect the new version, and any
> packages using it would also need to be adjusted.

oops,completely missed that, sorry.

Toggle quote (2 lines)
> Can you send a revised patch?

Yep, I'll do.

Thanks for the review

--
Vincent Legoll
Z
Z
zimoun wrote on 30 Dec 2020 19:34
(address . 45531@debbugs.gnu.org)
86lfdfrvmj.fsf@gmail.com
Hi,

On Wed, 30 Dec 2020 at 17:01, Vincent Legoll <vincent.legoll@gmail.com> wrote:
Toggle quote (12 lines)
> On Wed, Dec 30, 2020 at 3:19 AM Leo Famulari <leo@famulari.name> wrote:

>> > (define-public hdf5-1.10
>> > (package/inherit hdf5-1.8
>> > - (version "1.10.7")
>> > + (version "1.12.0")
>>
>> The variable name should be updated to reflect the new version, and any
>> packages using it would also need to be adjusted.
>
> oops,completely missed that, sorry.

Please check that all the packages depending on hdf5-1.10 correctly
build with 1.12.0, for example: freecad, libmedfile, etc.

And also hdf5-parallel-openmpi which inherits from, so packages
depending on that too.

Therefore, instead it could be simpler to add a new variable hdf5-1.12
and use it as default with the variable hdf5.


All the best,
simon
V
V
Vincent Legoll wrote on 5 Jan 2021 10:34
(name . zimoun)(address . zimon.toutoune@gmail.com)
CAEwRq=rpohr1MVrCje901-bt8MkB05d35g+WRwG40WhmkmA3VQ@mail.gmail.com
Hello,

On Wed, Dec 30, 2020 at 7:35 PM zimoun <zimon.toutoune@gmail.com> wrote:
Toggle quote (6 lines)
> Please check that all the packages depending on hdf5-1.10 correctly
> build with 1.12.0, for example: freecad, libmedfile, etc.
>
> And also hdf5-parallel-openmpi which inherits from, so packages
> depending on that too.

Is this specific to that package or should I always rebuild all the
dependencies (& their dependencies) for each package update ?

--
Vincent Legoll
E
E
Efraim Flashner wrote on 5 Jan 2021 13:32
(name . Vincent Legoll)(address . vincent.legoll@gmail.com)
X/Rce3zaCUDlAoXY@3900XT
On Tue, Jan 05, 2021 at 10:34:36AM +0100, Vincent Legoll wrote:
Toggle quote (13 lines)
> Hello,
>
> On Wed, Dec 30, 2020 at 7:35 PM zimoun <zimon.toutoune@gmail.com> wrote:
> > Please check that all the packages depending on hdf5-1.10 correctly
> > build with 1.12.0, for example: freecad, libmedfile, etc.
> >
> > And also hdf5-parallel-openmpi which inherits from, so packages
> > depending on that too.
>
> Is this specific to that package or should I always rebuild all the
> dependencies (& their dependencies) for each package update ?
>

The packages which share a source should definitely be tested out. As
far as ones that depend on them test them out to your best ability. It
normally depends on computing power and whether they built previously or
not.

Some package groups have special needs. rust packages only really need
to pass their build phase, and anything that depends on them should just
keep working. I've never gotten a good result from java packages so I'll
build those out to the very end. Due to the way python works it can be
hit-or-miss.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl/0XHsACgkQQarn3Mo9
g1EN8g/+I0KYjSy2tSRpJ3i/8XuJ1/nEBAGaJPh/G1BLaUaX7SJ83pq2kLOeWstV
4bEaGSBtq3FK9PXMvY1mhStLw8dbXtERW34MQU//mIBTMtQARMDqV+YwyfAibt+L
wytF2nCPhQP/3RIuLj0zMQoZWn5xPNdPUFnoSpVje7dNp8KYWhEQL0oVmns4Wsug
9eHffg+QxG6D3kmg8U/bcjhIYfQz6Ep0fr1Lh30y3d0jBFW0fIqKqgUuQuiHUQWS
WpNTfbpgx5MuDN4aQYavNej03TcvVaqI89vZJl6GppvmBh1nnDA/Tzq7AvWP7vUa
topYIVtBVFvHMBd0UHgd7zB3zbQhduMWGyNOc+yMSGpeYLsxt/KMODMW6DrOLl3c
g3SEdSzGVsghEZVR4578k0lIqY+8lq7+ZRR2rYZqq2a+/OAY2HA/IIzO6jnfwUNj
pLT8HX7GWpczMV6KXgCNSF/Dvf/ZY3QnCocHWvnOEfJvhDOvLFQq9dngMhv4Ng5y
8s9jRU0JpP1jDnCKGE9X+X0fU+flI3wOyiTdbtV+13w3SEVSKHZVD6rBFYcwwHOB
BhIn4Tj0YA4NM1yTY4F7HMldVbDE8bGHs6DbvcGSKYgyZ1NflgxD8Kzi8byT5tye
G1S2gMJlNgpF9t6Iaalt8uU10lqw+5Ilk29+1viAD1axOUZymAo=
=zFTy
-----END PGP SIGNATURE-----


Z
Z
zimoun wrote on 6 Jan 2021 19:38
(name . Vincent Legoll)(address . vincent.legoll@gmail.com)
86czyhykq6.fsf@gmail.com
Hi,

On Tue, 05 Jan 2021 at 10:34, Vincent Legoll <vincent.legoll@gmail.com> wrote:
Toggle quote (10 lines)
> On Wed, Dec 30, 2020 at 7:35 PM zimoun <zimon.toutoune@gmail.com> wrote:
>> Please check that all the packages depending on hdf5-1.10 correctly
>> build with 1.12.0, for example: freecad, libmedfile, etc.
>>
>> And also hdf5-parallel-openmpi which inherits from, so packages
>> depending on that too.
>
> Is this specific to that package or should I always rebuild all the
> dependencies (& their dependencies) for each package update ?

I do not know if there is a rule. But hdf5 is used by many scientific
packages and so changing the default version needs some care, IMHO.
Upgrading the version could lead to annoying breakages and it is better
to fix them at this upgrading time than to discover them later.

Well, I am not sure about your initial intention with your patch,

a) add the new variable hdf5-1.12
b) change the variable hdf5-1.10 by hdf5-1.12 which means replace all
the occurrences of hdf5-1.10 and check everything builds; note the
default hdf5 is changed too so it is a lot of rebuilds

Some packages specifically depends on hdf5-1.8 so maybe some packages
also specifically require hdf5-1.10; I have not checked.

These 9 packages specifically use hdf5-1.10:

hdf5-parallel-openmpi, freecad, libmedfile, hdf5-blosc,
python-h5py, python-tables, sbcl-hdf5-cffi, r-rhdf5lib,
sra-tools

so they need special care, at least. :-)

My point is “guix refresh -l hdf5” says the upgrade could have an impact
on a couple of packages and I just wanted be sure that you were aware of
that. :-)


All the best,
simon
V
V
Vincent Legoll wrote on 7 Jan 2021 09:40
(name . zimoun)(address . zimon.toutoune@gmail.com)
CAEwRq=rxSq8Z9XMzm6s58_pfHE3HKkrPD8gJ+RL6s12kOnfKfw@mail.gmail.com
Hello,

Thanks for the explanation, I'll see if I can build
those & report here.

--
Vincent Legoll
V
V
Vincent Legoll wrote on 11 Jan 2021 18:57
(name . zimoun)(address . zimon.toutoune@gmail.com)
CAEwRq=rqSuyvhiaVNuj3ysjFfy3RyhU-99Di62JwH=eq_cAp-A@mail.gmail.com
Hello,

I tried to make it the default, but at least ecl-hdf5-cffi
did not rebuild properly, so I think the best way forward
would be to add 1.12.0 as a separate non-default version,
and then let the users of the dependent packages update
as they want / have tested. I'm not user of any of those...

Or completely drop my (random-)update.

--
Vincent Legoll
Z
Z
zimoun wrote on 14 Jan 2021 13:38
(name . Vincent Legoll)(address . vincent.legoll@gmail.com)
CAJ3okZ3hKsDqnyLwMj0EY9piULOSuTC2rxc0vpfv75ypApAhtw@mail.gmail.com
Hi Vincent,

Thank you for testing.

On Mon, 11 Jan 2021 at 18:57, Vincent Legoll <vincent.legoll@gmail.com> wrote:

Toggle quote (6 lines)
> I tried to make it the default, but at least ecl-hdf5-cffi
> did not rebuild properly, so I think the best way forward
> would be to add 1.12.0 as a separate non-default version,
> and then let the users of the dependent packages update
> as they want / have tested. I'm not user of any of those...

This was my initial suggestion. :-)
On the other hand, if only one package is failing with 1.12.0, maybe
upgrade the default and keep the previous for this specific package
only.

All the best,
simon
V
V
Vincent Legoll wrote on 21 Feb 2021 22:29
Closing
(address . 45531-DONE@debbugs.gnu.org)
CAEwRq=pci2bcWX8_VM31rOxdcDKiw63G3zr0Ox5S5PHV3fH=Fg@mail.gmail.com
Closing as duplicate of :
f601cdc6981888f55882c942dab413cb783caecc
--
Vincent Legoll
Closed
?