[PATCH 2/2] image: Rename "raw" image-type to "efi-raw".

  • Done
  • quality assurance status badge
Details
2 participants
  • Mathieu Othacehe
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Mathieu Othacehe
Severity
normal
Merged with
M
M
Mathieu Othacehe wrote on 3 Dec 2020 11:53
(address . guix-patches@gnu.org)
20201203105353.149482-3-othacehe@gnu.org
* gnu/system/image.scm (raw-image-type): Rename to "efi-raw-image-type".
* guix/scripts/system.scm (%default-options): Adapt accordingly.
* doc/guix.texi: Ditto.
---
doc/guix.texi | 10 +++++-----
gnu/system/image.scm | 6 +++---
guix/scripts/system.scm | 2 +-
3 files changed, 9 insertions(+), 9 deletions(-)

Toggle diff (75 lines)
diff --git a/doc/guix.texi b/doc/guix.texi
index 889f380108..c44f330fec 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -31156,7 +31156,7 @@ the @option{--image-size} option is ignored in the case of
@cindex disk-image, creating disk images
The @code{disk-image} command can produce various image types. The
image type can be selected using the @option{--image-type} option. It
-defaults to @code{raw}. When its value is @code{iso9660}, the
+defaults to @code{efi-raw}. When its value is @code{iso9660}, the
@option{--label} option can be used to specify a volume ID with
@code{disk-image}. By default, the root file system of a disk image is
mounted non-volatile; the @option{--volatile} option can be provided to
@@ -31175,8 +31175,8 @@ qemu-system-x86_64 -enable-kvm -hda /tmp/my-image.qcow2 -m 1000 \
-bios $(guix build ovmf)/share/firmware/ovmf_x64.bin
@end example
-When using the @code{raw} image type, a raw disk image is produced; it
-can be copied as is to a USB stick, for instance. Assuming
+When using the @code{efi-raw} image type, a raw disk image is produced;
+it can be copied as is to a USB stick, for instance. Assuming
@code{/dev/sdc} is the device corresponding to a USB stick, one can copy
the image to it using the following command:
@@ -31303,8 +31303,8 @@ of the image.
@itemx -t @var{type}
For the @code{disk-image} action, create an image with given @var{type}.
-When this option is omitted, @command{guix system} uses the @code{raw}
-image type.
+When this option is omitted, @command{guix system} uses the
+@code{efi-raw} image type.
@cindex ISO-9660 format
@cindex CD image format
diff --git a/gnu/system/image.scm b/gnu/system/image.scm
index f3d5734381..5505540100 100644
--- a/gnu/system/image.scm
+++ b/gnu/system/image.scm
@@ -70,7 +70,7 @@
arm64-disk-image
image-with-os
- raw-image-type
+ efi-raw-image-type
qcow2-image-type
iso-image-type
uncompressed-iso-image-type
@@ -159,9 +159,9 @@ set to the given OS."
(inherit base-image)
(operating-system os)))
-(define raw-image-type
+(define efi-raw-image-type
(image-type
- (name 'raw)
+ (name 'efi-raw)
(constructor (cut image-with-os efi-disk-image <>))))
(define qcow2-image-type
diff --git a/guix/scripts/system.scm b/guix/scripts/system.scm
index db80e0be8f..f077947d75 100644
--- a/guix/scripts/system.scm
+++ b/guix/scripts/system.scm
@@ -1116,7 +1116,7 @@ Some ACTIONS support additional ARGS.\n"))
(debug . 0)
(verbosity . #f) ;default
(validate-reconfigure . ,ensure-forward-reconfigure)
- (image-type . raw)
+ (image-type . efi-raw)
(image-size . guess)
(install-bootloader? . #t)
(label . #f)
--
2.29.2
M
M
Mathieu Othacehe wrote on 3 Dec 2020 11:58
control message for bug #45022
(address . control@debbugs.gnu.org)
87lfefyx3q.fsf@cervin.i-did-not-set--mail-host-address--so-tickle-me
merge 45022 45020
quit
?